aboutsummaryrefslogtreecommitdiffstats
path: root/packages/hostap
diff options
context:
space:
mode:
Diffstat (limited to 'packages/hostap')
-rw-r--r--packages/hostap/hostap-daemon_0.2.4.bb17
-rw-r--r--packages/hostap/hostap-modules_0.1.3.bb16
-rw-r--r--packages/hostap/hostap-modules_0.2.6.bb18
-rw-r--r--packages/hostap/hostap-modules_0.3.5.bb14
-rw-r--r--packages/hostap/hostap-modules_0.3.7.bb14
-rw-r--r--packages/hostap/hostap-utils_0.2.6.bb23
-rw-r--r--packages/hostap/hostap-utils_0.3.2.bb26
-rw-r--r--packages/hostap/hostap-utils_0.3.7.bb24
8 files changed, 121 insertions, 31 deletions
diff --git a/packages/hostap/hostap-daemon_0.2.4.bb b/packages/hostap/hostap-daemon_0.2.4.bb
index e69de29bb2..86566ce828 100644
--- a/packages/hostap/hostap-daemon_0.2.4.bb
+++ b/packages/hostap/hostap-daemon_0.2.4.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "User space daemon for extended IEEE 802.11 management"
+HOMEPAGE = "http://hostap.epitest.fi"
+SECTION = "kernel/userland"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+RDEPENDS = "hostap-modules (${PV}) hostap-utils (${PV})"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostapd-${PV}.tar.gz"
+S = "${WORKDIR}/hostapd-${PV}"
+
+do_install() {
+ install -d ${D}${sysconfdir} ${D}${bindir}
+ install -m 0644 hostapd.conf ${D}${sysconfdir}/
+ install -m 0755 hostapd ${D}${bindir}
+}
+
diff --git a/packages/hostap/hostap-modules_0.1.3.bb b/packages/hostap/hostap-modules_0.1.3.bb
index d88da7e971..a471da8d39 100644
--- a/packages/hostap/hostap-modules_0.1.3.bb
+++ b/packages/hostap/hostap-modules_0.1.3.bb
@@ -14,13 +14,13 @@ inherit module
MAKE_TARGETS = "hostap pccard"
do_install() {
- install -d ${D}/${base_libdir}/modules/${KERNEL_VERSION}/net \
- ${D}/${base_libdir}/modules/${KERNEL_VERSION}/pcmcia \
- ${D}/${sysconfdir}/pcmcia
- install -m 0755 driver/modules/hostap_crypt_wep${KERNEL_OBJECT_SUFFIX} ${D}/${base_libdir}/modules/${KERNEL_VERSION}/net/
- install -m 0755 driver/modules/hostap${KERNEL_OBJECT_SUFFIX} ${D}/${base_libdir}/modules/${KERNEL_VERSION}/net/
- install -m 0755 driver/modules/hostap_cs${KERNEL_OBJECT_SUFFIX} ${D}/${base_libdir}/modules/${KERNEL_VERSION}/pcmcia/
- install -m 0644 driver/etc/hostap_cs.conf ${D}/${sysconfdir}/pcmcia/hostap_cs.conf
- cat ${WORKDIR}/hostap_cs.conf >>${D}/${sysconfdir}/pcmcia/hostap_cs.conf
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net \
+ ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia \
+ ${D}${sysconfdir}/pcmcia
+ install -m 0755 driver/modules/hostap_crypt_wep${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
+ install -m 0755 driver/modules/hostap${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
+ install -m 0755 driver/modules/hostap_cs${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia/
+ install -m 0644 driver/etc/hostap_cs.conf ${D}${sysconfdir}/pcmcia/hostap_cs.conf
+ cat ${WORKDIR}/hostap_cs.conf >>${D}${sysconfdir}/pcmcia/hostap_cs.conf
}
diff --git a/packages/hostap/hostap-modules_0.2.6.bb b/packages/hostap/hostap-modules_0.2.6.bb
index 6b4007425d..ca7ccd6271 100644
--- a/packages/hostap/hostap-modules_0.2.6.bb
+++ b/packages/hostap/hostap-modules_0.2.6.bb
@@ -21,20 +21,20 @@ MAKE_TARGETS = "KERNEL_PATH=${STAGING_KERNEL_DIR} MAKE='make -e'"
NET_MODULES = "hostap hostap_pci hostap_crypt_ccmp hostap_crypt_tkip hostap_crypt_wep"
do_install() {
- install -d ${D}/${base_libdir}/modules/${KERNEL_VERSION}/net \
- ${D}/${base_libdir}/modules/${KERNEL_VERSION}/pcmcia \
- ${D}/${sysconfdir}/pcmcia
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net \
+ ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia \
+ ${D}${sysconfdir}/pcmcia
for i in ${NET_MODULES}
do
- install -m 0644 driver/modules/$i${KERNEL_OBJECT_SUFFIX} ${D}/${base_libdir}/modules/${KERNEL_VERSION}/net/
+ install -m 0644 driver/modules/$i${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
done
- install -m 0644 driver/modules/hostap_cs${KERNEL_OBJECT_SUFFIX} ${D}/${base_libdir}/modules/${KERNEL_VERSION}/pcmcia/
- install -m 0644 driver/etc/hostap_cs.conf ${D}/${sysconfdir}/pcmcia/hostap_cs.conf
- cat ${WORKDIR}/hostap_cs.conf >>${D}/${sysconfdir}/pcmcia/hostap_cs.conf
+ install -m 0644 driver/modules/hostap_cs${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia/
+ install -m 0644 driver/etc/hostap_cs.conf ${D}${sysconfdir}/pcmcia/hostap_cs.conf
+ cat ${WORKDIR}/hostap_cs.conf >>${D}${sysconfdir}/pcmcia/hostap_cs.conf
if [ "${MACHINE}" = "mtx-1" ]; then
- install -d ${D}/${sysconfdir}/modutils
- echo "hostap_pci" > ${D}/${sysconfdir}/modutils/hostap
+ install -d ${D}${sysconfdir}/modutils
+ echo "hostap_pci" > ${D}${sysconfdir}/modutils/hostap
fi
}
diff --git a/packages/hostap/hostap-modules_0.3.5.bb b/packages/hostap/hostap-modules_0.3.5.bb
index 6db38c4f35..0aa8e846ea 100644
--- a/packages/hostap/hostap-modules_0.3.5.bb
+++ b/packages/hostap/hostap-modules_0.3.5.bb
@@ -22,16 +22,16 @@ MAKE_TARGETS = "KERNEL_PATH=${KERNEL_SOURCE} MAKE='make -e'"
NET_MODULES = "hostap hostap_pci hostap_crypt_ccmp hostap_crypt_tkip hostap_crypt_wep"
do_install() {
- install -d ${D}/${base_libdir}/modules/${KERNEL_VERSION}/net \
- ${D}/${base_libdir}/modules/${KERNEL_VERSION}/pcmcia \
- ${D}/${sysconfdir}/pcmcia
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net \
+ ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia \
+ ${D}${sysconfdir}/pcmcia
for i in ${NET_MODULES}
do
- install -m 0644 driver/modules/$i${KERNEL_OBJECT_SUFFIX} ${D}/${base_libdir}/modules/${KERNEL_VERSION}/net/
+ install -m 0644 driver/modules/$i${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
done
- install -m 0644 driver/modules/hostap_cs${KERNEL_OBJECT_SUFFIX} ${D}/${base_libdir}/modules/${KERNEL_VERSION}/pcmcia/
- install -m 0644 driver/etc/hostap_cs.conf ${D}/${sysconfdir}/pcmcia/hostap_cs.conf
- cat ${WORKDIR}/hostap_cs.conf >>${D}/${sysconfdir}/pcmcia/hostap_cs.conf
+ install -m 0644 driver/modules/hostap_cs${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia/
+ install -m 0644 driver/etc/hostap_cs.conf ${D}${sysconfdir}/pcmcia/hostap_cs.conf
+ cat ${WORKDIR}/hostap_cs.conf >>${D}${sysconfdir}/pcmcia/hostap_cs.conf
}
PACKAGES = "hostap-modules-cs hostap-modules-pci hostap-modules"
diff --git a/packages/hostap/hostap-modules_0.3.7.bb b/packages/hostap/hostap-modules_0.3.7.bb
index a68d8b959b..de7fe1d5f6 100644
--- a/packages/hostap/hostap-modules_0.3.7.bb
+++ b/packages/hostap/hostap-modules_0.3.7.bb
@@ -22,16 +22,16 @@ MAKE_TARGETS = "KERNEL_PATH=${KERNEL_SOURCE} MAKE='make -e'"
NET_MODULES = "hostap hostap_pci hostap_crypt_ccmp hostap_crypt_tkip hostap_crypt_wep"
do_install() {
- install -d ${D}/${base_libdir}/modules/${KERNEL_VERSION}/net \
- ${D}/${base_libdir}/modules/${KERNEL_VERSION}/pcmcia \
- ${D}/${sysconfdir}/pcmcia
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net \
+ ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia \
+ ${D}${sysconfdir}/pcmcia
for i in ${NET_MODULES}
do
- install -m 0644 driver/modules/$i${KERNEL_OBJECT_SUFFIX} ${D}/${base_libdir}/modules/${KERNEL_VERSION}/net/
+ install -m 0644 driver/modules/$i${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
done
- install -m 0644 driver/modules/hostap_cs${KERNEL_OBJECT_SUFFIX} ${D}/${base_libdir}/modules/${KERNEL_VERSION}/pcmcia/
- install -m 0644 driver/etc/hostap_cs.conf ${D}/${sysconfdir}/pcmcia/hostap_cs.conf
- cat ${WORKDIR}/hostap_cs.conf >>${D}/${sysconfdir}/pcmcia/hostap_cs.conf
+ install -m 0644 driver/modules/hostap_cs${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia/
+ install -m 0644 driver/etc/hostap_cs.conf ${D}${sysconfdir}/pcmcia/hostap_cs.conf
+ cat ${WORKDIR}/hostap_cs.conf >>${D}${sysconfdir}/pcmcia/hostap_cs.conf
}
PACKAGES = "hostap-modules-cs hostap-modules-pci hostap-modules"
diff --git a/packages/hostap/hostap-utils_0.2.6.bb b/packages/hostap/hostap-utils_0.2.6.bb
index e69de29bb2..deafe7c026 100644
--- a/packages/hostap/hostap-utils_0.2.6.bb
+++ b/packages/hostap/hostap-utils_0.2.6.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "User mode helpers for the hostap driver"
+HOMEPAGE = "http://hostap.epitest.fi"
+SECTION = "kernel/userland"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+RDEPENDS = "hostap-modules (${PV})"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostap-utils-${PV}.tar.gz \
+ file://hostap-fw-load.patch;patch=1"
+S = "${WORKDIR}/hostap-utils-${PV}"
+
+BINARIES = "hostap_crypt_conf hostap_diag hostap_fw_load hostap_io_debug \
+ hostap_rid prism2_param prism2_srec split_combined_hex"
+
+do_install() {
+ install -d ${D}${sbindir}/
+ for f in ${BINARIES}
+ do
+ install -m 0755 $f ${D}${sbindir}/
+ done
+}
+
diff --git a/packages/hostap/hostap-utils_0.3.2.bb b/packages/hostap/hostap-utils_0.3.2.bb
index e69de29bb2..49036a7421 100644
--- a/packages/hostap/hostap-utils_0.3.2.bb
+++ b/packages/hostap/hostap-utils_0.3.2.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "User mode helpers for the hostap driver"
+HOMEPAGE = "http://hostap.epitest.fi"
+SECTION = "kernel/userland"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+RDEPENDS = "hostap-modules (${PV})"
+PR = "r1"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostap-utils-${PV}.tar.gz \
+ file://hostap-fw-load.patch;patch=1"
+S = "${WORKDIR}/hostap-utils-${PV}"
+
+BINARIES = "hostap_crypt_conf hostap_diag hostap_fw_load hostap_io_debug \
+ hostap_rid prism2_param prism2_srec split_combined_hex"
+
+do_install() {
+ install -d ${D}${sbindir}/
+ for f in ${BINARIES}
+ do
+ install -m 0755 $f ${D}${sbindir}/
+ done
+}
+
diff --git a/packages/hostap/hostap-utils_0.3.7.bb b/packages/hostap/hostap-utils_0.3.7.bb
index e69de29bb2..93a3cb550e 100644
--- a/packages/hostap/hostap-utils_0.3.7.bb
+++ b/packages/hostap/hostap-utils_0.3.7.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "User mode helpers for the hostap driver"
+HOMEPAGE = "http://hostap.epitest.fi"
+SECTION = "kernel/userland"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+RDEPENDS = "hostap-modules (${PV})"
+PR = "r0"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostap-utils-${PV}.tar.gz \
+ file://hostap-fw-load.patch;patch=1"
+S = "${WORKDIR}/hostap-utils-${PV}"
+
+BINARIES = "hostap_crypt_conf hostap_diag hostap_fw_load hostap_io_debug \
+ hostap_rid prism2_param prism2_srec split_combined_hex"
+
+do_install() {
+ install -d ${D}${sbindir}/
+ for f in ${BINARIES}
+ do
+ install -m 0755 $f ${D}${sbindir}/
+ done
+}
+