aboutsummaryrefslogtreecommitdiffstats
path: root/packages/images/essential-machine-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/images/essential-machine-image.bb')
-rw-r--r--packages/images/essential-machine-image.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/packages/images/essential-machine-image.bb b/packages/images/essential-machine-image.bb
new file mode 100644
index 0000000000..c3c7b33b92
--- /dev/null
+++ b/packages/images/essential-machine-image.bb
@@ -0,0 +1,37 @@
+#
+# Copyright Matthias Hentges <devel@hentges.net> (c) 2006
+# License: GPL (see http://www.gnu.org/licenses/gpl.txt for a copy of the license)
+#
+# Filename: essential-machine-image.bb
+# Date: 24-Apr-06
+
+DESCRIPTION = "<description>"
+MAINTAINER = "Matthias 'CoreDump' Hentges <oe@hentges.net>"
+HOMEPAGE = "http://www.hentges.net/misc/openzaurus/index.shtml"
+
+######################################################################################
+
+PV = "0.0.1"
+PR = "r0"
+
+######################################################################################
+
+inherit image_ipk
+
+######################################################################################
+
+DEPENDS = "task-essential-to-boot task-essential-parts"
+
+######################################################################################
+
+MACHINE_TASKS_akita = "task-essential-to-boot \
+ task-essential-pcmcia task-essential-userspace \
+ task-essential-usbhost task-essential-usbclient \
+ task-essential-sound task-essential-irda \
+ task-essential-sd"
+
+######################################################################################
+
+export IMAGE_BASENAME = "essential-image"
+export IMAGE_LINGUAS = ""
+export IPKG_INSTALL = "${MACHINE_TASKS}"