aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ixp425-eth/ixp425-eth_1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/ixp425-eth/ixp425-eth_1.1.bb')
-rw-r--r--packages/ixp425-eth/ixp425-eth_1.1.bb21
1 files changed, 11 insertions, 10 deletions
diff --git a/packages/ixp425-eth/ixp425-eth_1.1.bb b/packages/ixp425-eth/ixp425-eth_1.1.bb
index 9225cb3df7..a8be7757c3 100644
--- a/packages/ixp425-eth/ixp425-eth_1.1.bb
+++ b/packages/ixp425-eth/ixp425-eth_1.1.bb
@@ -2,12 +2,13 @@ DEPENDS = "ixp4xx-csr patcher-native"
LICENSE = "GPL"
MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
SRC_URI = "http://www.intel.com/design/network/swsup/ixp400LinuxEthernetDriverPatch-1_1.zip \
+ http://nslu.sourceforge.net/downloads/ixp425_eth.c.patch \
file://makefile.patch;patch=1 \
file://ethhdr.patch;patch=1 \
file://intdriven.patch;patch=1 \
file://pollcontroller.patch;patch=1 \
file://mm4.patch;patch=1"
-PR = "r5"
+PR = "r6"
S = "${WORKDIR}"
@@ -21,15 +22,15 @@ inherit module
KERNEL_CC += "${TARGET_CC_ARCH} -mno-thumb-interwork"
# KERNEL_LD +=
-do_ixp425_c_patch_fetch () {
- if test ! -e ${DL_DIR}/ixp425_eth.c.patch.md5; then
- cd ${DL_DIR}
- wget -Oixp425_eth.c.patch http://sourceforge.net/tracker/download.php?group_id=74209\&atid=544386\&file_id=90129\&aid=970193
- md5sum > ixp425_eth.c.patch.md5
- fi
-}
-
-addtask ixp425_c_patch_fetch after do_fetch before do_unpack
+#do_ixp425_c_patch_fetch () {
+# if test ! -e ${DL_DIR}/ixp425_eth.c.patch.md5; then
+# cd ${DL_DIR}
+# wget -Oixp425_eth.c.patch http://sourceforge.net/tracker/download.php?group_id=74209\&atid=544386\&file_id=90129\&aid=970193
+# md5sum > ixp425_eth.c.patch.md5
+# fi
+#}
+#
+#addtask ixp425_c_patch_fetch after do_fetch before do_unpack
do_ixp425_c_patch_unpack () {
install -m 0644 ${DL_DIR}/ixp425_eth.c.patch ${WORKDIR}/