aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libxine/libxine-1.0.0-beta12/configure.ac.patch
diff options
context:
space:
mode:
Diffstat (limited to 'packages/libxine/libxine-1.0.0-beta12/configure.ac.patch')
-rw-r--r--packages/libxine/libxine-1.0.0-beta12/configure.ac.patch152
1 files changed, 152 insertions, 0 deletions
diff --git a/packages/libxine/libxine-1.0.0-beta12/configure.ac.patch b/packages/libxine/libxine-1.0.0-beta12/configure.ac.patch
index e69de29bb2..7eda48ab25 100644
--- a/packages/libxine/libxine-1.0.0-beta12/configure.ac.patch
+++ b/packages/libxine/libxine-1.0.0-beta12/configure.ac.patch
@@ -0,0 +1,152 @@
+--- xine-lib/configure.ac 2003-08-10 15:20:01.000000000 +0200
++++ xine-lib/configure.ac.patched 2003-08-10 15:23:42.000000000 +0200
+@@ -506,10 +506,10 @@
+ dnl ---------------------------------------------
+ dnl check for SDL
+ dnl ---------------------------------------------
+-AM_PATH_SDL(1.1.5,
+- AC_DEFINE(HAVE_SDL,1,[Define this if you have SDL library installed]),
+- [])
+-AM_CONDITIONAL(HAVE_SDL, [test x"$no_sdl" != x"yes"])
++dnl AM_PATH_SDL(1.1.5,
++dnl AC_DEFINE(HAVE_SDL,1,[Define this if you have SDL library installed]),
++dnl [])
++dnl AM_CONDITIONAL(HAVE_SDL, [test x"$no_sdl" != x"yes"])
+
+
+ dnl ---------------------------------------------
+@@ -608,19 +608,19 @@
+ dnl Ogg/Theora libs.
+ dnl ---------------------------------------------
+
+-AM_PATH_OGG(
+- [ AM_PATH_THEORA(AC_DEFINE(HAVE_THEORA,1,[Define this if you have theora]),
+- AC_MSG_RESULT([*** All OGG/THEORA dependent parts will be disabled ***]))
+- ],
+- AC_MSG_RESULT([*** All of OGG/Theora dependent parts will be disabled ***]))
+-AM_CONDITIONAL(HAVE_THEORA, [test x"$no_ogg" != "xyes" -a x"$no_theora" != "xyes"])
++dnl AM_PATH_OGG(
++dnl [ AM_PATH_THEORA(AC_DEFINE(HAVE_THEORA,1,[Define this if you have theora]),
++dnl AC_MSG_RESULT([*** All OGG/THEORA dependent parts will be disabled ***]))
++dnl ],
++dnl AC_MSG_RESULT([*** All of OGG/Theora dependent parts will be disabled ***]))
++dnl AM_CONDITIONAL(HAVE_THEORA, [test x"$no_ogg" != "xyes" -a x"$no_theora" != "xyes"])
+
+ dnl ---------------------------------------------
+ dnl check for libFLAC
+ dnl ---------------------------------------------
+-AM_PATH_LIBFLAC([],
+- AC_MSG_RESULT([*** All FLAC dependent parts will be disabled ***]))
+-AM_CONDITIONAL(HAVE_FLAC, [test x"$no_libFLAC" != "xyes"])
++dnl AM_PATH_LIBFLAC([],
++dnl AC_MSG_RESULT([*** All FLAC dependent parts will be disabled ***]))
++dnl AM_CONDITIONAL(HAVE_FLAC, [test x"$no_libFLAC" != "xyes"])
+
+ dnl ---------------------------------------------
+ dnl XviD libs.
+@@ -668,90 +668,7 @@
+ AC_SUBST(PNG_LIBS)
+
+ dnl ---------------------------------------------
+-dnl freetype2 lib.
+-dnl ---------------------------------------------
+-AC_PATH_PROG(FREETYPE_CONFIG, moooooooooooo_putain_de_script_freetype-config, no)
+-if test "$FREETYPE_CONFIG" = "no" ; then
+- AC_MSG_RESULT([*** freetype-config not found, freetype2 support disabled ***])
+-else
+- FT2_CFLAGS=`$FREETYPE_CONFIG --cflags`
+- FT2_LIBS=`$FREETYPE_CONFIG --libs`
+- have_ft2="yes"
+- AC_DEFINE(HAVE_FT2,1,[Define this if you have freetype2 library])
+-fi
+-
+-AM_CONDITIONAL(HAVE_FT2, test x"$have_ft2" = "xyes" )
+-AC_SUBST(FT2_CFLAGS)
+-AC_SUBST(FT2_LIBS)
+-
+-dnl ---------------------------------------------
+-dnl OSS style audio interface
+-dnl ---------------------------------------------
+-AC_MSG_CHECKING(for OSS audio support)
+-have_ossaudio=no
+-AC_TRY_COMPILE([
+- #ifdef __NetBSD__
+- #include <soundcard.h>
+- #else
+- #include <sys/soundcard.h>
+- #endif
+- ],[
+- int arg = SNDCTL_DSP_SETFRAGMENT;
+- ],[
+- have_ossaudio=yes
+- ])
+-AC_MSG_RESULT($have_ossaudio)
+-AM_CONDITIONAL(HAVE_OSS, test x"$have_ossaudio" = "xyes")
+-
+-
+-dnl ---------------------------------------------
+-dnl Alsa support
+-dnl ---------------------------------------------
+-AM_PATH_ALSA(0.9.0,
+- [ AC_DEFINE(HAVE_ALSA,1,[Define this if you have Alsa (libasound) installed])
+- if test x"$have_alsa09" = "xyes"; then
+- AC_DEFINE(HAVE_ALSA09,1,[Define this if you have alsa 0.9.x and more installed])
+- fi
+- ],
+- AC_MSG_RESULT(*** All of ALSA dependent parts will be disabled ***))
+-AM_CONDITIONAL(HAVE_ALSA, test x"$no_alsa" != "xyes")
+-AM_CONDITIONAL(HAVE_ALSA09, test x"$have_alsa09" = "xyes")
+-
+-
+-dnl ---------------------------------------------
+-dnl ESD support
+-dnl ---------------------------------------------
+-AM_PATH_ESD(0.2.8,
+- AC_DEFINE(HAVE_ESD,1,[Define this if you have ESD (libesd) installed]),
+- AC_MSG_RESULT(*** All of ESD dependent parts will be disabled ***))
+-AM_CONDITIONAL(HAVE_ESD, test x"$no_esd" != "xyes")
+-
+-dnl ---------------------------------------------
+-dnl ARTS support
+-dnl ---------------------------------------------
+-AM_PATH_ARTS(0.9.5,
+- AC_DEFINE(HAVE_ARTS,1,[Define this if you have ARTS (libartsc) installed]),
+- AC_MSG_RESULT(*** All of ARTS dependent parts will be disabled ***))
+-AM_CONDITIONAL(HAVE_ARTS, test x"$no_arts" != "xyes")
+-
+-dnl ---------------------------------------------
+-dnl gnome-vfs support
+-dnl ---------------------------------------------
+-PKG_CHECK_MODULES(GNOME_VFS, putain_de_module_gnome-vfs-2.0,
+- no_gnome_vfs=no,
+- no_gnome_vfs=yes)
+-AC_SUBST(GNOME_VFS_CFLAGS)
+-AC_SUBST(GNOME_VFS_LIBS)
+-if test x"$no_gnome_vfs" != "xyes"; then
+-AC_DEFINE(HAVE_GNOME_VFS,1,[Define this if you have gnome-vfs installed])
+-else
+-AC_MSG_RESULT(*** All of the gnome-vfs dependent parts will be disabled ***)
+-fi
+-AM_CONDITIONAL(HAVE_GNOME_VFS, test x"$no_gnome_vfs" != "xyes")
+-
+-
+-dnl ---------------------------------------------
+-dnl SUN style audio interface
++dnl freetype2 lib.snterface
+ dnl ---------------------------------------------
+ AC_MSG_CHECKING(for Sun audio support)
+ have_sunaudio=no
+--- xine-lib/configure.ac Sat Aug 23 21:22:05 2003
++++ xine-lib/configure.ac.aalib Sat Aug 23 21:22:31 2003
+@@ -456,8 +456,10 @@
+ dnl ---------------------------------------------
+ dnl Checks for Ascii-Art library
+ dnl ---------------------------------------------
++AC_ARG_ENABLE(aalib, [ --disable-aalib Disable AAlib support],
++ enable_aalib=no, enable_aalib=yes)
+ AM_PATH_AALIB(1.4,, AC_MSG_RESULT([*** All of AALIB dependent parts will be disabled ***]))
+-AM_CONDITIONAL(HAVE_AA, test x$no_aalib != "xyes")
++AM_CONDITIONAL(HAVE_AA, [test x"$enable_aalib" = "xyes" && test x"$no_aalib" != "xyes" ])
+
+ dnl ---------------------------------------------
+ dnl Check solaris framebuffer device support