aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libxine/libxine-1.0.0-rc5
diff options
context:
space:
mode:
Diffstat (limited to 'packages/libxine/libxine-1.0.0-rc5')
-rw-r--r--packages/libxine/libxine-1.0.0-rc5/.mtn2git_empty0
-rw-r--r--packages/libxine/libxine-1.0.0-rc5/configure.patch95
-rw-r--r--packages/libxine/libxine-1.0.0-rc5/cpu.patch75
-rw-r--r--packages/libxine/libxine-1.0.0-rc5/libxine-libvorbis.patch39
-rw-r--r--packages/libxine/libxine-1.0.0-rc5/libxine-tremor-autoconf.patch16
-rw-r--r--packages/libxine/libxine-1.0.0-rc5/no-caca-no-aalib.patch24
6 files changed, 249 insertions, 0 deletions
diff --git a/packages/libxine/libxine-1.0.0-rc5/.mtn2git_empty b/packages/libxine/libxine-1.0.0-rc5/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/libxine/libxine-1.0.0-rc5/.mtn2git_empty
diff --git a/packages/libxine/libxine-1.0.0-rc5/configure.patch b/packages/libxine/libxine-1.0.0-rc5/configure.patch
index e69de29bb2..155027efac 100644
--- a/packages/libxine/libxine-1.0.0-rc5/configure.patch
+++ b/packages/libxine/libxine-1.0.0-rc5/configure.patch
@@ -0,0 +1,95 @@
+Xine is stupid in that they don't have --with or --without comments for
+all of their items. That should be fixed, but until then, this configure
+script should avoid some of the pain and or suffering
+
+--- xine-lib-1-rc5/configure.ac 2004-06-20 16:39:04.000000000 -0700
++++ xine-lib-1-rc5.new/configure.ac 2004-06-29 15:06:26.057570960 -0700
+@@ -887,46 +887,28 @@
+ dnl Ogg/Theora libs.
+ dnl ---------------------------------------------
+
+-AM_PATH_OGG(
+- [ AM_PATH_THEORA(AC_DEFINE(HAVE_THEORA,1,[Define this if you have theora]),
+- AC_MSG_RESULT([*** All OGG/THEORA dependent parts will be disabled ***]))
+- ],
+- AC_MSG_RESULT([*** All of OGG/Theora dependent parts will be disabled ***]))
+-AM_CONDITIONAL(HAVE_THEORA, [test x"$no_ogg" != "xyes" -a x"$no_theora" != "xyes"])
++AM_CONDITIONAL(HAVE_THEORA, 0)
+
+
+ dnl ---------------------------------------------
+ dnl Ogg/Speex libs.
+ dnl ---------------------------------------------
+
+-AM_PATH_OGG(
+- [ AM_PATH_SPEEX(AC_DEFINE(HAVE_SPEEX,1,[Define this if you have speex]),
+- AC_MSG_RESULT([*** All OGG/SPEEX dependent parts will be disabled ***]))
+- ],
+- AC_MSG_RESULT([*** All of OGG/Speex dependent parts will be disabled ***]))
+-AM_CONDITIONAL(HAVE_SPEEX, [test x"$no_ogg" != "xyes" -a x"$no_speex" != "xyes"])
+-
++AM_CONDITIONAL(HAVE_SPEEX, 0)
+
+ dnl ---------------------------------------------
+ dnl check for libFLAC
+ dnl ---------------------------------------------
+
+-AM_PATH_LIBFLAC([],
+- AC_MSG_RESULT([*** All FLAC dependent parts will be disabled ***]))
+-AM_CONDITIONAL(HAVE_FLAC, [test x"$no_libFLAC" != "xyes"])
++AM_CONDITIONAL(HAVE_FLAC, 0)
+
+
+ dnl ---------------------------------------------
+ dnl MNG libs.
+ dnl ---------------------------------------------
+
+-AC_CHECK_LIB(mng, mng_initialize,
+- [ AC_CHECK_HEADER(libmng.h,
+- [ have_libmng=yes
+- MNG_LIBS="-lmng" ],
+- AC_MSG_RESULT([*** All libmng dependent parts will be disabled ***]))],
+- AC_MSG_RESULT([*** All libmng dependent parts will be disabled ***]))
+-AM_CONDITIONAL(HAVE_LIBMNG, test x"$have_libmng" = "xyes")
++MNG_LIBS=""
++AM_CONDITIONAL(HAVE_LIBMNG, 0)
+ AC_SUBST(MNG_LIBS)
+
+
+@@ -1204,35 +1186,7 @@
+ ],ISOC99_PRAGMA=no)
+ AC_MSG_RESULT($ISOC99_PRAGMA)
+
+- dnl bitfield order
+- AC_MSG_CHECKING(bitfield ordering in structs)
+- AC_TRY_RUN([
+-int
+- main() {
+- struct { char bit_0:1, bit_12:2, bit_345:3, bit_67:2; }
+-#if __GNUC__ > 2 || (__GNUC__ == 2 && __GNUC_MINOR__ > 4)
+- __attribute__((packed))
+-#endif
+- bf = { 1,1,1,1 };
+- if (sizeof (bf) != 1) return 1;
+- return *((unsigned char*) &bf) != 0x4b; }
+-], bf_lsbf=1, AC_TRY_RUN([
+-int
+-main() {
+- struct { char bit_0:1, bit_12:2, bit_345:3, bit_67:2; }
+-#if __GNUC__ > 2 || (__GNUC__ == 2 && __GNUC_MINOR__ > 4)
+- __attribute__((packed))
+-#endif
+- bf = { 1,1,1,1 };
+- if (sizeof (bf) != 1) return 1;
+- return *((unsigned char*) &bf) != 0xa5; }
+-], bf_lsbf=0, AC_MSG_ERROR([unsupported bitfield ordering])))
+- if test "x$bf_lsbf" = "x1"; then
+- AC_MSG_RESULT(LSBF)
+- AC_DEFINE(BITFIELD_LSBF, [], [compiler does lsbf in struct bitfields])
+- else
+- AC_MSG_RESULT(MSBF)
+- fi
++ AC_DEFINE(BITFIELD_LSBF, [], [compiler does lsbf in struct bitfields])
+
+ AC_HAVE_HEADERS( errno.h fcntl.h \
+ stdbool.h stdlib.h stdint.h stdio.h string.h \
diff --git a/packages/libxine/libxine-1.0.0-rc5/cpu.patch b/packages/libxine/libxine-1.0.0-rc5/cpu.patch
index e69de29bb2..a2444d9ed3 100644
--- a/packages/libxine/libxine-1.0.0-rc5/cpu.patch
+++ b/packages/libxine/libxine-1.0.0-rc5/cpu.patch
@@ -0,0 +1,75 @@
+For those x86 folks - ebx is used by PIC and shouldn't be used by
+anyone else
+
+--- xine-lib-1-rc5/src/post/goom/zoom_filter_xmmx.c 2003-09-15 15:53:53.000000000 -0700
++++ xine-lib-1-rc5.new/src/post/goom/zoom_filter_xmmx.c 2004-06-29 15:25:45.763268896 -0700
+@@ -108,23 +108,23 @@
+ * post : mm3 & mm4 : coefs for this position
+ * mm1 : X vector [0|X]
+ *
+- * modif : eax,ebx
++ * modif : eax,ecx
+ */
+ __asm__ __volatile__ (
+- "movd %%mm0,%%ebx\n"
++ "movd %%mm0,%%ecx\n"
+ "movq %%mm0,%%mm1\n"
+
+- "andl $15,%%ebx\n"
++ "andl $15,%%ecx\n"
+ "psrlq $32,%%mm1\n"
+
+- "shll $6,%%ebx\n"
++ "shll $6,%%ecx\n"
+ "movd %%mm1,%%eax\n"
+
+- "addl %0,%%ebx\n"
++ "addl %0,%%ecx\n"
+ "andl $15,%%eax\n"
+
+- "movd (%%ebx,%%eax,4),%%mm3\n"
+- ::"X"(precalCoef):"eax","ebx");
++ "movd (%%ecx,%%eax,4),%%mm3\n"
++ ::"X"(precalCoef):"eax","ecx");
+
+ /*
+ * extraction des coefficients...
+@@ -152,7 +152,7 @@
+ * post : mm0 : expix1[position]
+ * mm2 : expix1[position+largeur]
+ *
+- * modif : eax,ebx
++ * modif : eax,ecx
+ */
+ psrld_i2r (PERTEDEC,mm0);
+ psrld_i2r (PERTEDEC,mm1);
+@@ -161,23 +161,23 @@
+ /*^*/ "movq %%mm3,%%mm5\n" /*^*/
+
+ "mull %1\n"
+- "movd %%mm0,%%ebx\n"
++ "movd %%mm0,%%ecx\n"
+ /*^*/ "punpcklbw %%mm5, %%mm3\n" /*^*/
+
+- "addl %%ebx,%%eax\n"
++ "addl %%ecx,%%eax\n"
+ /*^*/ "movq %%mm3,%%mm4\n" /*^*/
+ /*^*/ "movq %%mm3,%%mm5\n" /*^*/
+
+- "movl %0,%%ebx\n"
++ "movl %0,%%ecx\n"
+ /*^*/ "punpcklbw %%mm5,%%mm3\n" /*^*/
+
+- "movq (%%ebx,%%eax,4),%%mm0\n"
++ "movq (%%ecx,%%eax,4),%%mm0\n"
+ /*^*/ "punpckhbw %%mm5,%%mm4\n" /*^*/
+
+ "addl %1,%%eax\n"
+- "movq (%%ebx,%%eax,4),%%mm2\n"
++ "movq (%%ecx,%%eax,4),%%mm2\n"
+
+- : : "X"(expix1), "X"(prevX):"eax","ebx"
++ : : "X"(expix1), "X"(prevX):"eax","ecx"
+ );
+
+ /*
diff --git a/packages/libxine/libxine-1.0.0-rc5/libxine-libvorbis.patch b/packages/libxine/libxine-1.0.0-rc5/libxine-libvorbis.patch
index e69de29bb2..81bcbd5468 100644
--- a/packages/libxine/libxine-1.0.0-rc5/libxine-libvorbis.patch
+++ b/packages/libxine/libxine-1.0.0-rc5/libxine-libvorbis.patch
@@ -0,0 +1,39 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+Index: xine-lib-1.0/src/libvorbis/xine_decoder.c
+===================================================================
+--- xine-lib-1.0.orig/src/libvorbis/xine_decoder.c 2005-02-20 18:21:57.924625900 +0100
++++ xine-lib-1.0/src/libvorbis/xine_decoder.c 2005-02-20 18:52:02.016033646 +0100
+@@ -40,7 +40,7 @@
+ #include "buffer.h"
+
+ #include <ogg/ogg.h>
+-#include <vorbis/codec.h>
++#include <tremor/ivorbiscodec.h>
+
+ #define MAX_NUM_SAMPLES 4096
+
+@@ -216,7 +216,7 @@
+
+ } else if (this->output_open) {
+
+- float **pcm;
++ int **pcm;
+ int samples;
+
+ if(vorbis_synthesis(&this->vb,&this->op,1)==0)
+@@ -245,9 +245,9 @@
+ interleave */
+ for(i=0;i<this->vi.channels;i++){
+ ogg_int16_t *ptr=audio_buffer->mem+i;
+- float *mono=pcm[i];
++ int *mono=pcm[i];
+ for(j=0;j<bout;j++){
+- int val=mono[j]*32767.f;
++ int val=mono[j]>>9;
+ /* might as well guard against clipping */
+ if(val>32767){
+ val=32767;
diff --git a/packages/libxine/libxine-1.0.0-rc5/libxine-tremor-autoconf.patch b/packages/libxine/libxine-1.0.0-rc5/libxine-tremor-autoconf.patch
index e69de29bb2..bbedc81de3 100644
--- a/packages/libxine/libxine-1.0.0-rc5/libxine-tremor-autoconf.patch
+++ b/packages/libxine/libxine-1.0.0-rc5/libxine-tremor-autoconf.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- xine-lib-1-rc7/m4/vorbis.m4~libxine-tremor-autoconf
++++ xine-lib-1-rc7/m4/vorbis.m4
+@@ -18,7 +18,7 @@
+ VORBIS_LIBDIR="-L$vorbis_prefix/$XINE_LIBNAME"
+ fi
+
+- VORBIS_LIBS="$VORBIS_LIBDIR -lvorbis -lm"
++ VORBIS_LIBS="$VORBIS_LIBDIR -lvorbisidec -lm"
+ VORBISFILE_LIBS="-lvorbisfile"
+ VORBISENC_LIBS="-lvorbisenc"
+
diff --git a/packages/libxine/libxine-1.0.0-rc5/no-caca-no-aalib.patch b/packages/libxine/libxine-1.0.0-rc5/no-caca-no-aalib.patch
index e69de29bb2..2269b3b14e 100644
--- a/packages/libxine/libxine-1.0.0-rc5/no-caca-no-aalib.patch
+++ b/packages/libxine/libxine-1.0.0-rc5/no-caca-no-aalib.patch
@@ -0,0 +1,24 @@
+diff -urNd ../libxine-1.0.0-rc5-r0.old/xine-lib-1-rc5/configure.ac xine-lib-1-rc5/configure.ac
+--- ../libxine-1.0.0-rc5-r0.old/xine-lib-1-rc5/configure.ac 2004-06-21 00:39:04 +01:00
++++ xine-lib-1-rc5/configure.ac 2005-04-08 02:47:53 +01:00
+@@ -607,16 +607,16 @@
+ dnl Checks for Ascii-Art library
+ dnl ---------------------------------------------
+
+-AM_PATH_AALIB(1.4,, AC_MSG_RESULT([*** All of AALIB dependent parts will be disabled ***]))
+-AM_CONDITIONAL(HAVE_AA, test x$no_aalib != "xyes")
++dnl AM_PATH_AALIB(1.4,, AC_MSG_RESULT([*** All of AALIB dependent parts will be disabled ***]))
++AM_CONDITIONAL(HAVE_AA, 0)
+
+
+ dnl ---------------------------------------------
+ dnl Checks for Color AsCii Art library
+ dnl ---------------------------------------------
+
+-AM_PATH_CACA(0.3,, AC_MSG_RESULT([*** All CACA-dependent parts will be disabled ***]))
+-AM_CONDITIONAL(HAVE_CACA, test x$no_caca != "xyes")
++dnl AM_PATH_CACA(0.3,, AC_MSG_RESULT([*** All CACA-dependent parts will be disabled ***]))
++AM_CONDITIONAL(HAVE_CACA, 0)
+
+
+ dnl ---------------------------------------------