aboutsummaryrefslogtreecommitdiffstats
path: root/packages/lighttpd/lighttpd_1.4.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/lighttpd/lighttpd_1.4.15.bb')
-rw-r--r--packages/lighttpd/lighttpd_1.4.15.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/packages/lighttpd/lighttpd_1.4.15.bb b/packages/lighttpd/lighttpd_1.4.15.bb
new file mode 100644
index 0000000000..c759188b6b
--- /dev/null
+++ b/packages/lighttpd/lighttpd_1.4.15.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "Web server"
+SECTION = "net"
+LICENSE = "BSD"
+PR = "r0"
+
+SRC_URI = "http://www.lighttpd.net/download/lighttpd-1.4.15.tar.gz \
+ file://configure.in.patch;patch=1 \
+ file://src-server.c.patch;patch=1 \
+ file://index.html \
+ file://lighttpd.conf \
+ file://lighttpd"
+
+EXTRA_OECONF="--without-bzip2 \
+ --without-ldap \
+ --without-lua \
+ --without-memcache \
+ --without-pcre \
+ --without-webdav-props \
+ --without-webdav-locks \
+ --without-openssl \
+ --disable-nls \
+ --disable-static"
+
+inherit autotools pkgconfig update-rc.d
+
+INITSCRIPT_NAME = "lighttpd"
+INITSCRIPT_PARAMS = "defaults 70"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d ${D}/www/logs ${D}/www/pages/dav ${D}/www/var
+ install -m 0755 ${WORKDIR}/lighttpd ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/lighttpd.conf ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/index.html ${D}/www/pages/
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${libdir}/mod_*.so ${sysconfdir} /www"