aboutsummaryrefslogtreecommitdiffstats
path: root/packages/maradns/maradns_1.0.39.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/maradns/maradns_1.0.39.bb')
-rw-r--r--packages/maradns/maradns_1.0.39.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/packages/maradns/maradns_1.0.39.bb b/packages/maradns/maradns_1.0.39.bb
new file mode 100644
index 0000000000..d89bcf849d
--- /dev/null
+++ b/packages/maradns/maradns_1.0.39.bb
@@ -0,0 +1,43 @@
+DESCRIPTION = "A security-aware DNS server"
+SECTION = "console/network"
+HOMEPAGE = "http://www.maradns.org"
+LICENSE = "PD"
+
+SRC_URI = "http://www.maradns.org/download/1.0/maradns-${PV}.tar.bz2 \
+ file://init \
+ file://rng-makefile-build-cc.patch;patch=1;pnum=0"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${sbindir}
+ install -d ${D}${sysconfdir}
+ install -d ${D}${sysconfdir}/mararc
+ install -d ${D}${sysconfdir}/init.d
+ install -d ${D}${mandir}/man1
+ install -d ${D}${mandir}/man5
+ install -d ${D}${mandir}/man8
+
+ sed -i -e "s:PREFIX/man:PREFIX/share/man:" \
+ -e "s:PREFIX/doc/maradns-\$VERSION:PREFIX/share/doc/${PF}:" \
+ build/install.locations
+
+ oe_runmake \
+ TOPLEVEL=${S} \
+ BUILDDIR=${S}/build \
+ RPM_BUILD_ROOT=${D} \
+ PREFIX=${D}/usr \
+ MAN1=${D}${mandir}/man1 \
+ MAN5=${D}${mandir}/man5 \
+ MAN8=${D}${mandir}/man8 \
+ install
+
+ mv ${D}${sysconfdir}/mararc/example_mararc ${D}${sysconfdir}/maradns/mararc
+ rm -r ${D}${sysconfdir}/mararc/
+ install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/maradns
+}
+
+PACKAGES =+ "maradns-zone maradns-ask"
+FILES_maradns-zone = "${sbindir}/zoneserver ${bindir}/getzone"
+FILES_maradns-ask = "${bindir}/askmara"
+
+CONFFILES_${PN}_nylon = "/etc/maradns/mararc"