aboutsummaryrefslogtreecommitdiffstats
path: root/packages/matchbox-wm/matchbox-wm_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/matchbox-wm/matchbox-wm_svn.bb')
-rw-r--r--packages/matchbox-wm/matchbox-wm_svn.bb19
1 files changed, 11 insertions, 8 deletions
diff --git a/packages/matchbox-wm/matchbox-wm_svn.bb b/packages/matchbox-wm/matchbox-wm_svn.bb
index 606e3ebc01..fdf38d6e68 100644
--- a/packages/matchbox-wm/matchbox-wm_svn.bb
+++ b/packages/matchbox-wm/matchbox-wm_svn.bb
@@ -4,13 +4,20 @@ LICENSE = "GPL"
DEPENDS = "libmatchbox x11 xext xcomposite libxfixes xdamage libxrender startup-notification expat gconf matchbox-common"
RDEPENDS = "matchbox-common"
PV = "0.9cvs${CVSDATE}"
+PR = "r1"
DEFAULT_PREFERENCE = "-1"
-SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-window-manager;proto=http"
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-window-manager;proto=http \
+ file://kbdconfig"
S = "${WORKDIR}/matchbox-window-manager"
-inherit autotools pkgconfig
+inherit autotools pkgconfig update-alternatives
+
+ALTERNATIVE_NAME = "x-window-manager"
+ALTERNATIVE_LINK = "${bindir}/x-window-manager"
+ALTERNATIVE_PATH = "${bindir}/matchbox-session"
+ALTERNATIVE_PRIORITY = "10"
FILES_${PN} = "${bindir} \
${datadir}/matchbox \
@@ -21,11 +28,7 @@ FILES_${PN} = "${bindir} \
EXTRA_OECONF = "--enable-composite --enable-startup-notification --disable-xrm"
-pkg_postinst() {
-update-alternatives --install ${bindir}/x-window-manager x-window-manager ${bindir}/matchbox-session 10
-}
-
-pkg_postrm() {
-update-alternatives --remove x-window-manager ${bindir}/matchbox-session
+do_install_prepend() {
+ install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
}