aboutsummaryrefslogtreecommitdiffstats
path: root/packages/neon
diff options
context:
space:
mode:
Diffstat (limited to 'packages/neon')
-rw-r--r--packages/neon/neon_0.24.7.bb18
1 files changed, 12 insertions, 6 deletions
diff --git a/packages/neon/neon_0.24.7.bb b/packages/neon/neon_0.24.7.bb
index 2e2ba4de59..d53260b3cf 100644
--- a/packages/neon/neon_0.24.7.bb
+++ b/packages/neon/neon_0.24.7.bb
@@ -1,18 +1,24 @@
-inherit autotools
-
-DEPENDS = "zlib libxml2 expat"
+DESCRIPTION = "neon is an HTTP and WebDAV client library, with a C interface."
SECTION = "base"
LICENSE = "LGPL"
-DESCRIPTION = "neon is an HTTP and WebDAV client library, with a C interface."
+DEPENDS = "openssl zlib libxml2 expat time"
+
PR = "r1"
SRC_URI = "http://www.webdav.org/neon/neon-0.24.7.tar.gz \
file://no-func-checks.patch;patch=1"
-EXTRA_OECONF = " --without-ssl --with-libxml2 --with-expat \
- --enable-shared --enable-static"
+inherit autotools lib_package
+
+EXTRA_OECONF = " --with-ssl --with-libxml2 --with-expat --enable-shared"
do_stage () {
autotools_stage_includes
oe_libinstall -C src -so -a libneon ${STAGING_LIBDIR}/
+
+ cat neon-config | sed -e "s,^prefix=.*,prefix=${STAGING_BINDIR}/..," \
+ -e "s,^exec_prefix=.*,exec_prefix=${STAGING_BINDIR}/..," \
+ -e "s,^includedir=.*,includedir=${STAGING_INCDIR}," \
+ -e "s,^libdir=.*,libdir=${STAGING_LIBDIR}," > ${STAGING_BINDIR}/neon-config
+ chmod a+rx ${STAGING_BINDIR}/neon-config
}