aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ntp/ntp_4.1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/ntp/ntp_4.1.2.bb')
-rw-r--r--packages/ntp/ntp_4.1.2.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/ntp/ntp_4.1.2.bb b/packages/ntp/ntp_4.1.2.bb
index e69de29bb2..97bd23b196 100644
--- a/packages/ntp/ntp_4.1.2.bb
+++ b/packages/ntp/ntp_4.1.2.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "The Network Time Protocol (NTP) is used to \
+synchronize the time of a computer client or server to \
+another server or reference time source, such as a radio \
+or satellite receiver or modem."
+HOMEPAGE = "http://ntp.isc.org/bin/view/Main/WebHome"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "ntp"
+PR = "r1"
+
+SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-${PV}.tar.gz \
+ file://configure.patch;patch=1 \
+ file://readline.patch;patch=1 \
+ file://ntpdate"
+
+inherit autotools
+
+EXTRA_OECONF = "--without-openssl"
+CFLAGS_append = " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED"
+
+PACKAGES = "ntpdate ntp"
+
+FILES_ntpdate = "/usr/bin/ntpdate /etc/init.d/ntpdate"
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 755 ${WORKDIR}/ntpdate ${D}/${sysconfdir}/init.d
+}