aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ppp
diff options
context:
space:
mode:
Diffstat (limited to 'packages/ppp')
-rw-r--r--packages/ppp/ppp_2.4.1.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/packages/ppp/ppp_2.4.1.bb b/packages/ppp/ppp_2.4.1.bb
index e69de29bb2..7f4e58e107 100644
--- a/packages/ppp/ppp_2.4.1.bb
+++ b/packages/ppp/ppp_2.4.1.bb
@@ -0,0 +1,40 @@
+SECTION = "console/network"
+DESCRIPTION = "Point-to-Point Protocol (PPP) daemon"
+HOMEPAGE = "http://samba.org/ppp/"
+LICENSE = "BSD GPLv2"
+PR = "r4"
+
+SRC_URI = "ftp://ftp.samba.org/pub/ppp/ppp-2.4.1.tar.gz \
+ file://pppd.patch;patch=1 \
+ file://man.patch;patch=1 \
+ file://pon \
+ file://poff \
+ file://init \
+ file://ip-up \
+ file://ip-down"
+
+inherit autotools libtool
+
+EXTRA_OEMAKE = "STRIPPROG=${STRIP}"
+EXTRA_OECONF = --disable-strip
+
+do_install_append () {
+ install -d ${D}${bindir}/ ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/pon ${D}${bindir}/pon
+ install -m 0755 ${WORKDIR}/poff ${D}${bindir}/poff
+ install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/ppp
+ install -m 0755 ${WORKDIR}/ip-up ${D}${sysconfdir}/ppp/
+ install -m 0755 ${WORKDIR}/ip-down ${D}${sysconfdir}/ppp/
+ install -d ${D}${sysconfdir}/ppp/ip-up.d/
+ install -d ${D}${sysconfdir}/ppp/ip-down.d/
+}
+
+CONFFILES_${PN}_nylon = "${sysconfdir}/ppp/pap-secrets ${sysconfdir}/ppp/chap-secrets"
+
+pkg_postinst() {
+if test "x$D" != "x"; then
+ exit 1
+else
+ chmod u+s /usr/sbin/pppd
+fi
+}