aboutsummaryrefslogtreecommitdiffstats
path: root/packages/sylpheed/sylpheed-claws_2.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/sylpheed/sylpheed-claws_2.2.0.bb')
-rw-r--r--packages/sylpheed/sylpheed-claws_2.2.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/sylpheed/sylpheed-claws_2.2.0.bb b/packages/sylpheed/sylpheed-claws_2.2.0.bb
new file mode 100644
index 0000000000..405762eb1c
--- /dev/null
+++ b/packages/sylpheed/sylpheed-claws_2.2.0.bb
@@ -0,0 +1,29 @@
+SECTION = "x11/network"
+DESCRIPTION = "Mail user agent"
+DEPENDS = "gtk+ gpgme gnutls libetpan"
+MAINTAINER = "Graeme Gregory <dp@xora.org.uk>"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/sylpheed-claws/sylpheed-claws-2.2.0.tar.bz2"
+
+
+FILES_${PN} = "${bindir} ${datadir}/pixmaps ${datadir}/applications"
+
+EXTRA_OECONF = "--disable-aspell"
+
+CFLAGS += "-D_GNU_SOURCE"
+
+do_configure_prepend() {
+ mkdir -p m4
+}
+
+inherit autotools
+
+do_install_append() {
+ install -d ${D}${datadir}/applications
+ install -m 0644 sylpheed-claws.desktop ${D}${datadir}/applications/
+ install -d ${D}${datadir}/pixmaps
+ install -m 0644 sylpheed-claws.png ${D}${datadir}/pixmaps/
+}
+