aboutsummaryrefslogtreecommitdiffstats
path: root/packages/thc/hydra_4.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/thc/hydra_4.4.bb')
-rw-r--r--packages/thc/hydra_4.4.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/thc/hydra_4.4.bb b/packages/thc/hydra_4.4.bb
index e69de29bb2..dacb5ada8d 100644
--- a/packages/thc/hydra_4.4.bb
+++ b/packages/thc/hydra_4.4.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "A very fast network logon cracker which support many different services"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+SECTION = "console/network"
+DEPENDS = "openssl"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://thc.org/releases/hydra-${PV}-src.tar.gz"
+S = "${WORKDIR}/hydra-${PV}-src"
+
+inherit autotools
+
+do_configure() {
+ echo "Now that's a sucky build system..."
+ cp -f Makefile.am Makefile
+}
+
+BINARIES = "pw-inspector hydra"
+
+do_install() {
+ install -d ${D}${bindir}
+ for f in ${BINARIES}
+ do
+ install -m 0755 $f ${D}${bindir}
+ done
+}