aboutsummaryrefslogtreecommitdiffstats
path: root/packages/xcomposite/xcomposite_cvs.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/xcomposite/xcomposite_cvs.bb')
-rw-r--r--packages/xcomposite/xcomposite_cvs.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/packages/xcomposite/xcomposite_cvs.bb b/packages/xcomposite/xcomposite_cvs.bb
index e69de29bb2..8782dcb42c 100644
--- a/packages/xcomposite/xcomposite_cvs.bb
+++ b/packages/xcomposite/xcomposite_cvs.bb
@@ -0,0 +1,18 @@
+PV = "0.0cvs${CVSDATE}"
+LICENSE= "BSD-X"
+SECTION = "x11/libs"
+DEPENDS = "x11 compositeext xextensions libxfixes"
+DESCRIPTION = "X Composite extension library."
+
+SRC_URI = "cvs://anoncvs:anoncvs@pdx.freedesktop.org/cvs/xlibs;module=Xcomposite"
+S = "${WORKDIR}/Xcomposite"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ oe_runmake install prefix=${STAGING_DIR} \
+ bindir=${STAGING_BINDIR} \
+ includedir=${STAGING_INCDIR} \
+ libdir=${STAGING_LIBDIR} \
+ datadir=${STAGING_DATADIR}
+}