aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
Diffstat (limited to 'packages')
-rw-r--r--packages/mumpot/files/mumpot-cyclemap.desktop8
-rw-r--r--packages/mumpot/mumpot_0.3.2.bb20
2 files changed, 28 insertions, 0 deletions
diff --git a/packages/mumpot/files/mumpot-cyclemap.desktop b/packages/mumpot/files/mumpot-cyclemap.desktop
new file mode 100644
index 0000000000..e761d0f3f1
--- /dev/null
+++ b/packages/mumpot/files/mumpot-cyclemap.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Mumpot cyclemap
+Comment=Mumpot cyclemap
+Exec=mumpot-cyclemap
+Terminal=0
+Type=Application
+Categories=Application;PIM;GTK
+StartupNotify=True
diff --git a/packages/mumpot/mumpot_0.3.2.bb b/packages/mumpot/mumpot_0.3.2.bb
new file mode 100644
index 0000000000..ab9d876902
--- /dev/null
+++ b/packages/mumpot/mumpot_0.3.2.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "A map-viewer, simple editor and routing application for OSM maps"
+HOMEPAGE = "http://www.mumpot.org/"
+AUTHOR = "Andreas Kemnade"
+SECTION = "x11/applications"
+LICENSE = "GPLv3"
+DEPENDS = "gtk+ bluez-libs bzip2 libxml2 libpng jpeg"
+
+SRC_URI = "http://www.mumpot.org/download/mumpot-${PV}.tar.gz \
+ file://mumpot-tah.desktop \
+ file://mumpot-mapnik.desktop \
+ file://mumpot-cyclemap.desktop"
+
+inherit autotools pkgconfig
+
+do_install_append() {
+ install -d ${D}${datadir}/applications
+ install -m 0644 ${WORKDIR}/mumpot-tah.desktop ${D}${datadir}/applications/mumpot-tah.desktop
+ install -m 0644 ${WORKDIR}/mumpot-mapnik.desktop ${D}${datadir}/applications/mumpot-mapnik.desktop
+ install -m 0644 ${WORKDIR}/mumpot-cyclemap.desktop ${D}${datadir}/applications/mumpot-cyclemap.desktop
+}