aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
Diffstat (limited to 'packages')
-rw-r--r--packages/wireshark/files/acinclude-net-snmp-fix.patch13
-rw-r--r--packages/wireshark/files/libtool-fix.patch14
-rw-r--r--packages/wireshark/tshark_0.99.4.bb6
-rw-r--r--packages/wireshark/wireshark_0.99.4.bb2
4 files changed, 33 insertions, 2 deletions
diff --git a/packages/wireshark/files/acinclude-net-snmp-fix.patch b/packages/wireshark/files/acinclude-net-snmp-fix.patch
new file mode 100644
index 0000000000..3f6dbf3b05
--- /dev/null
+++ b/packages/wireshark/files/acinclude-net-snmp-fix.patch
@@ -0,0 +1,13 @@
+Index: wireshark-0.99.4/acinclude.m4
+===================================================================
+--- wireshark-0.99.4.orig/acinclude.m4 2009-01-03 22:57:54.106829288 +0300
++++ wireshark-0.99.4/acinclude.m4 2009-01-03 22:57:59.806420438 +0300
+@@ -1117,7 +1117,7 @@ AC_DEFUN([AC_WIRESHARK_NETSNMP_CHECK],
+ #
+ AC_PATH_PROG(NETSNMPCONFIG, net-snmp-config)
+ else
+- NETSNMPCNFIG=$netsnmpconfig
++ NETSNMPCONFIG=$netsnmpconfig
+ if test ! -x $NETSNMPCONFIG -o ! -f $NETSNMPCONFIG ; then
+ NETSNMPCONFIG=$netsnmpconfig/bin/net-snmp-config
+ if test ! -x $NETSNMPCONFIG -o ! -f $NETSNMPCONFIG ; then
diff --git a/packages/wireshark/files/libtool-fix.patch b/packages/wireshark/files/libtool-fix.patch
new file mode 100644
index 0000000000..4a978bad92
--- /dev/null
+++ b/packages/wireshark/files/libtool-fix.patch
@@ -0,0 +1,14 @@
+Index: wireshark-0.99.4/configure.in
+===================================================================
+--- wireshark-0.99.4.orig/configure.in 2009-01-05 01:23:50.887336868 +0300
++++ wireshark-0.99.4/configure.in 2009-01-05 01:24:03.136385630 +0300
+@@ -16,8 +16,7 @@ dnl Checks for programs.
+ AC_PROG_CC
+ AC_PROG_CPP
+ dnl Work around libtool bug (fixed in the version 1.5a?)
+-AC_DEFUN([AC_PROVIDE_AC_LIBTOOL_DLOPEN], )
+-AC_LIBTOOL_DLOPEN
++LT_INIT([dlopen])
+ AC_PROG_LIBTOOL
+ AC_PROG_YACC
+ AM_PROG_LEX
diff --git a/packages/wireshark/tshark_0.99.4.bb b/packages/wireshark/tshark_0.99.4.bb
index 7338efdda7..e63a0c2f23 100644
--- a/packages/wireshark/tshark_0.99.4.bb
+++ b/packages/wireshark/tshark_0.99.4.bb
@@ -2,17 +2,19 @@ DESCRIPTION = "tshark is the text based verion of wireshark - a popular network
HOMEPAGE = "http://www.ethereal.com"
SECTION = "network"
LICENSE = "GPL"
-DEPENDS = "perl-native gnutls libpcap pcre expat"
+DEPENDS = "perl-native gnutls libpcap pcre expat glib-2.0 net-snmp"
SRC_URI = "${SOURCEFORGE_MIRROR}/wireshark/wireshark-${PV}.tar.bz2 \
file://use-our-lemon.patch;patch=1 \
+ file://acinclude-net-snmp-fix.patch;patch=1 \
+ file://libtool-fix.patch;patch=1 \
file://no-host-includes.patch;patch=1"
S=${WORKDIR}/wireshark-${PV}
inherit autotools
-EXTRA_OECONF = "--disable-wireshark"
+EXTRA_OECONF = "--disable-wireshark --with-net-snmp=${STAGING_DIR_HOST}${layout_bindir}/net-snmp-config"
do_compile_prepend() {
${BUILD_CC} ${BUILD_CFLAGS} -o rdps rdps.c
diff --git a/packages/wireshark/wireshark_0.99.4.bb b/packages/wireshark/wireshark_0.99.4.bb
index e34ca849d4..357f26448c 100644
--- a/packages/wireshark/wireshark_0.99.4.bb
+++ b/packages/wireshark/wireshark_0.99.4.bb
@@ -8,6 +8,8 @@ PR = "r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${PN}-${PV}.tar.bz2 \
file://use-our-lemon.patch;patch=1 \
+ file://acinclude-net-snmp-fix.patch;patch=1 \
+ file://libtool-fix.patch;patch=1 \
file://no-host-includes.patch;patch=1"
inherit autotools