aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
Diffstat (limited to 'packages')
-rw-r--r--packages/qmake/qmake2-native.inc1
-rw-r--r--packages/qmake/qmake2-native/0008-backport-qt-lib-infix.patch33
-rw-r--r--packages/qt4/files/0008-backport-qt-lib-infix.patch137
-rw-r--r--packages/qt4/qt4-x11-free.inc1
-rw-r--r--packages/qt4/qt_configuration.inc10
-rw-r--r--packages/qt4/qt_packaging.inc66
-rw-r--r--packages/qt4/qt_staging.inc1
-rw-r--r--packages/qt4/qtopia-core.inc4
-rw-r--r--packages/qt4/qtopia-core_4.3.3.bb3
9 files changed, 214 insertions, 42 deletions
diff --git a/packages/qmake/qmake2-native.inc b/packages/qmake/qmake2-native.inc
index 058bf176f9..0a204bb535 100644
--- a/packages/qmake/qmake2-native.inc
+++ b/packages/qmake/qmake2-native.inc
@@ -10,6 +10,7 @@ QTVER = "qtopia-core-opensource-src-${QTVERSION}"
FILESDIR += "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/qmake2-native"
SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/${QTVER}.tar.gz \
file://0001-fix-mkspecs.patch;patch=1 \
+ file://0008-backport-qt-lib-infix.patch;patch=1 \
file://qt-config.patch;patch=1 \
file://use-lflags-last.patch;patch=1 \
file://linux-oe-qmake.conf"
diff --git a/packages/qmake/qmake2-native/0008-backport-qt-lib-infix.patch b/packages/qmake/qmake2-native/0008-backport-qt-lib-infix.patch
new file mode 100644
index 0000000000..f87576a07b
--- /dev/null
+++ b/packages/qmake/qmake2-native/0008-backport-qt-lib-infix.patch
@@ -0,0 +1,33 @@
+diff --git a/mkspecs/features/qt_functions.prf b/mkspecs/features/qt_functions.prf
+index 32a7fd5..48d584f 100644
+--- a/mkspecs/features/qt_functions.prf
++++ b/mkspecs/features/qt_functions.prf
+@@ -28,7 +28,7 @@ defineTest(qtAddLibrary) {
+ INCLUDEPATH -= $$FRAMEWORK_INCLUDE
+ INCLUDEPATH = $$FRAMEWORK_INCLUDE $$INCLUDEPATH
+ }
+- LINKAGE = -framework $${LIB_NAME}
++ LINKAGE = -framework $${LIB_NAME}$${QT_LIBINFIX}
+ } else:!qt_no_framework { #detection
+ for(frmwrk_dir, $$list($$QMAKE_LIBDIR_QT $$QMAKE_LIBDIR $$(DYLD_FRAMEWORK_PATH) /Library/Frameworks)) {
+ exists($${frmwrk_dir}/$${LIB_NAME}.framework) {
+@@ -46,15 +46,15 @@ defineTest(qtAddLibrary) {
+ }
+ isEmpty(LINKAGE) {
+ CONFIG(debug, debug|release) {
+- win32:LINKAGE = -l$${LIB_NAME}d
+- mac:LINKAGE = -l$${LIB_NAME}_debug
++ win32:LINKAGE = -l$${LIB_NAME}$${QT_LIBINFIX}d
++ mac:LINKAGE = -l$${LIB_NAME}$${QT_LIBINFIX}_debug
+ }
+- isEmpty(LINKAGE):LINKAGE = -l$${LIB_NAME}
++ isEmpty(LINKAGE):LINKAGE = -l$${LIB_NAME}$${QT_LIBINFIX}
+ }
+ !isEmpty(QMAKE_LSB) {
+ QMAKE_LFLAGS *= --lsb-libpath=$$$$QMAKE_LIBDIR_QT
+ QMAKE_LFLAGS *= -L/opt/lsb/lib
+- QMAKE_LFLAGS *= --lsb-shared-libs=$${LIB_NAME}
++ QMAKE_LFLAGS *= --lsb-shared-libs=$${LIB_NAME}${QT_LIBINFIX}
+ }
+ LIBS += $$LINKAGE
+ export(LIBS)
diff --git a/packages/qt4/files/0008-backport-qt-lib-infix.patch b/packages/qt4/files/0008-backport-qt-lib-infix.patch
new file mode 100644
index 0000000000..79786e517e
--- /dev/null
+++ b/packages/qt4/files/0008-backport-qt-lib-infix.patch
@@ -0,0 +1,137 @@
+diff --git a/configure b/configure
+index c5bdc34..a52607f 100755
+--- a/configure
++++ b/configure
+@@ -782,6 +782,11 @@ while [ "$#" -gt 0 ]; do
+ VAR=endian
+ VAL=`echo $1 | sed "s,^-\(.*\)-.*,\1,"`
+ ;;
++ -qtlibinfix)
++ VAR="qtlibinfix"
++ shift
++ VAL="$1"
++ ;;
+ -D?*|-D)
+ VAR="add_define"
+ if [ "$1" = "-D" ]; then
+@@ -903,6 +908,9 @@ while [ "$#" -gt 0 ]; do
+ libdir)
+ QT_INSTALL_LIBS="$VAL"
+ ;;
++ qtlibinfix)
++ QT_LIBINFIX="$VAL"
++ ;;
+ translationdir)
+ QT_INSTALL_TRANSLATIONS="$VAL"
+ ;;
+@@ -2606,6 +2614,8 @@ fi
+ -no-sse ............ Do not compile with use of SSE instructions.
+ -no-sse2 ........... Do not compile with use of SSE2 instructions.
+
++ -qtlibinfix <infix> Renames all libQt*.so to libQt<infix>.so.
++
+ -D <string> ........ Add an explicit define to the preprocessor.
+ -I <string> ........ Add an explicit include path.
+ -L <string> ........ Add an explicit library path.
+@@ -5273,6 +5283,8 @@ QT_MAJOR_VERSION = $QT_MAJOR_VERSION
+ QT_MINOR_VERSION = $QT_MINOR_VERSION
+ QT_PATCH_VERSION = $QT_PATCH_VERSION
+
++QT_LIBINFIX = $QT_LIBINFIX
++
+ EOF
+ if [ "$CFG_RPATH" = "yes" ]; then
+ echo "QMAKE_RPATHDIR += \"$QT_INSTALL_LIBS\"" >> "$QTCONFIG.tmp"
+diff --git a/mkspecs/features/qt_functions.prf b/mkspecs/features/qt_functions.prf
+index 32a7fd5..48d584f 100644
+--- a/mkspecs/features/qt_functions.prf
++++ b/mkspecs/features/qt_functions.prf
+@@ -28,7 +28,7 @@ defineTest(qtAddLibrary) {
+ INCLUDEPATH -= $$FRAMEWORK_INCLUDE
+ INCLUDEPATH = $$FRAMEWORK_INCLUDE $$INCLUDEPATH
+ }
+- LINKAGE = -framework $${LIB_NAME}
++ LINKAGE = -framework $${LIB_NAME}$${QT_LIBINFIX}
+ } else:!qt_no_framework { #detection
+ for(frmwrk_dir, $$list($$QMAKE_LIBDIR_QT $$QMAKE_LIBDIR $$(DYLD_FRAMEWORK_PATH) /Library/Frameworks)) {
+ exists($${frmwrk_dir}/$${LIB_NAME}.framework) {
+@@ -46,15 +46,15 @@ defineTest(qtAddLibrary) {
+ }
+ isEmpty(LINKAGE) {
+ CONFIG(debug, debug|release) {
+- win32:LINKAGE = -l$${LIB_NAME}d
+- mac:LINKAGE = -l$${LIB_NAME}_debug
++ win32:LINKAGE = -l$${LIB_NAME}$${QT_LIBINFIX}d
++ mac:LINKAGE = -l$${LIB_NAME}$${QT_LIBINFIX}_debug
+ }
+- isEmpty(LINKAGE):LINKAGE = -l$${LIB_NAME}
++ isEmpty(LINKAGE):LINKAGE = -l$${LIB_NAME}$${QT_LIBINFIX}
+ }
+ !isEmpty(QMAKE_LSB) {
+ QMAKE_LFLAGS *= --lsb-libpath=$$$$QMAKE_LIBDIR_QT
+ QMAKE_LFLAGS *= -L/opt/lsb/lib
+- QMAKE_LFLAGS *= --lsb-shared-libs=$${LIB_NAME}
++ QMAKE_LFLAGS *= --lsb-shared-libs=$${LIB_NAME}${QT_LIBINFIX}
+ }
+ LIBS += $$LINKAGE
+ export(LIBS)
+diff --git a/src/qbase.pri b/src/qbase.pri
+index 4db7e70..278e011 100644
+--- a/src/qbase.pri
++++ b/src/qbase.pri
+@@ -138,7 +138,7 @@ DEFINES += QT_NO_CAST_TO_ASCII QT_ASCII_CAST_WARNINGS QT_44_API_QSQLQUERY_FINISH
+ contains(QT_CONFIG, qt3support):DEFINES *= QT3_SUPPORT
+ DEFINES *= QT_MOC_COMPAT #we don't need warnings from calling moc code in our generated code
+
+-TARGET = $$qtLibraryTarget($$TARGET) #do this towards the end
++TARGET = $$qtLibraryTarget($$TARGET$$QT_LIBINFIX) #do this towards the end
+
+ moc_dir.name = moc_location
+ moc_dir.variable = QMAKE_MOC
+diff --git a/tools/assistant/lib/lib.pro b/tools/assistant/lib/lib.pro
+index c121f28..83c3ed7 100644
+--- a/tools/assistant/lib/lib.pro
++++ b/tools/assistant/lib/lib.pro
+@@ -52,7 +52,7 @@ mac:!static:contains(QT_CONFIG, qt_framework) {
+ }
+ }
+
+-TARGET = $$qtLibraryTarget($$TARGET) #done towards the end
++TARGET = $$qtLibraryTarget($$TARGET$$QT_LIBINFIX) #done towards the end
+
+ target.path=$$[QT_INSTALL_LIBS]
+ INSTALLS += target
+diff --git a/tools/designer/src/components/component.pri b/tools/designer/src/components/component.pri
+index 15c0cf2..78b075d 100644
+--- a/tools/designer/src/components/component.pri
++++ b/tools/designer/src/components/component.pri
+@@ -1,2 +1,2 @@
+
+-TARGET = $$qtLibraryTarget($$TARGET)
++TARGET = $$qtLibraryTarget($$TARGET$$QT_LIBINFIX)
+diff --git a/tools/qdbus/src/src.pro b/tools/qdbus/src/src.pro
+index 47ef100..0669a46 100644
+--- a/tools/qdbus/src/src.pro
++++ b/tools/qdbus/src/src.pro
+@@ -70,7 +70,7 @@ mac:!static:contains(QT_CONFIG, qt_framework) {
+ }
+ }
+
+-TARGET = $$qtLibraryTarget($$TARGET) #done towards the end (after framework)
++TARGET = $$qtLibraryTarget($$TARGET$$QT_LIBINFIX) #done towards the end (after framework)
+
+ # Input
+
+diff --git a/tools/qtestlib/src/src.pro b/tools/qtestlib/src/src.pro
+index 5120a29..7d2082e 100644
+--- a/tools/qtestlib/src/src.pro
++++ b/tools/qtestlib/src/src.pro
+@@ -61,7 +61,7 @@ mac:!static:contains(QT_CONFIG, qt_framework) {
+ }
+ }
+
+-TARGET = $$qtLibraryTarget($$TARGET) #done towards the end (after framework)
++TARGET = $$qtLibraryTarget($$TARGET$$QT_LIBINFIX) #done towards the end (after framework)
+
+ # Input
+ HEADERS = qtest_global.h qtestcase.h qtestdata.h qtesteventloop.h
diff --git a/packages/qt4/qt4-x11-free.inc b/packages/qt4/qt4-x11-free.inc
index 75f7344e24..1647b07fd3 100644
--- a/packages/qt4/qt4-x11-free.inc
+++ b/packages/qt4/qt4-x11-free.inc
@@ -18,7 +18,6 @@ S = "${WORKDIR}/qt-x11-opensource-src-${PV}"
QT_CONFIG_FLAGS += "-no-xinerama -no-tablet -no-xkb -no-opengl"
QT_BASE_NAME = "qt4"
QT_BASE_LIB = "libqt"
-QT_LIBRARY_NAME = "Qt"
QT_DIR_NAME = "qt4"
require qt_depends.inc
require qt_configuration.inc
diff --git a/packages/qt4/qt_configuration.inc b/packages/qt4/qt_configuration.inc
index aa4f8c6c5e..252a80a408 100644
--- a/packages/qt4/qt_configuration.inc
+++ b/packages/qt4/qt_configuration.inc
@@ -2,11 +2,11 @@ require qt4_arch.inc
QT_ARCH := "${@qt_arch(d)}"
QT_ENDIAN = "${@qt_endian(d)}"
-QT_CONFIG_FLAGS = "-release -no-cups -no-accessibility -reduce-relocations \
- -shared -no-nas-sound -no-sm -no-nis \
- -qt-gif -system-libjpeg -system-libpng -system-zlib \
- -no-sql-ibase -no-sql-mysql -no-sql-odbc -no-sql-psql -no-sql-sqlite -no-sql-sqlite2 \
- -no-pch -qdbus -stl -glib"
+QT_CONFIG_FLAGS += "-release -no-cups -no-accessibility -reduce-relocations \
+ -shared -no-nas-sound -no-sm -no-nis \
+ -qt-gif -system-libjpeg -system-libpng -system-zlib \
+ -no-sql-ibase -no-sql-mysql -no-sql-odbc -no-sql-psql -no-sql-sqlite -no-sql-sqlite2 \
+ -no-pch -qdbus -stl -glib"
EXTRA_OEMAKE = "-e"
diff --git a/packages/qt4/qt_packaging.inc b/packages/qt4/qt_packaging.inc
index 472faa3da4..5f94cb46f5 100644
--- a/packages/qt4/qt_packaging.inc
+++ b/packages/qt4/qt_packaging.inc
@@ -60,56 +60,56 @@ RDEPENDS_${PN}-dev = "${DEV_PACKAGES}"
RDEPENDS_${PN}-dbg = "${DBG_PACKAGES}"
def qt_default_dev(name):
- return """${libdir}/lib${QT_LIBRARY_NAME}%(name)s.la
- ${libdir}/lib${QT_LIBRARY_NAME}%(name)s.prl
- ${libdir}/lib${QT_LIBRARY_NAME}%(name)s.so
+ return """${libdir}/libQt%(name)s${QT_LIBINFIX}.la
+ ${libdir}/libQt%(name)s${QT_LIBINFIX}.prl
+ ${libdir}/libQt%(name)s${QT_LIBINFIX}.so
${includedir}/${QT_DIR_NAME}/Qt%(name)s*
- ${libdir}/pkgconfig/${QT_LIBRARY_NAME}%(name)s.pc""" % locals()
+ ${libdir}/pkgconfig/Qt%(name)s${QT_LIBINFIX}.pc""" % locals()
-FILES_${QT_BASE_LIB}core4 = "${libdir}/lib${QT_LIBRARY_NAME}Core.so.*"
+FILES_${QT_BASE_LIB}core4 = "${libdir}/libQtCore${QT_LIBINFIX}.so.*"
FILES_${QT_BASE_LIB}core4-dev = "${@qt_default_dev('Core')}"
-FILES_${QT_BASE_LIB}core4-dbg = "${libdir}/.debug/lib${QT_LIBRARY_NAME}Core*"
-FILES_${QT_BASE_LIB}gui4 = "${libdir}/lib${QT_LIBRARY_NAME}Gui.so.*"
+FILES_${QT_BASE_LIB}core4-dbg = "${libdir}/.debug/libQtCore*"
+FILES_${QT_BASE_LIB}gui4 = "${libdir}/libQtGui${QT_LIBINFIX}.so.*"
FILES_${QT_BASE_LIB}gui4-dev = "${@qt_default_dev('Gui')}"
-FILES_${QT_BASE_LIB}gui4-dbg = "${libdir}/.debug/lib${QT_LIBRARY_NAME}Gui*"
-FILES_${QT_BASE_LIB}network4 = "${libdir}/lib${QT_LIBRARY_NAME}Network.so.*"
+FILES_${QT_BASE_LIB}gui4-dbg = "${libdir}/.debug/libQtGui*"
+FILES_${QT_BASE_LIB}network4 = "${libdir}/libQtNetwork${QT_LIBINFIX}.so.*"
FILES_${QT_BASE_LIB}network4-dev = "${@qt_default_dev('Network')}"
-FILES_${QT_BASE_LIB}network4-dbg = "${libdir}/.debug/lib${QT_LIBRARY_NAME}Network*"
-FILES_${QT_BASE_LIB}sql4 = "${libdir}/lib${QT_LIBRARY_NAME}Sql.so.*"
+FILES_${QT_BASE_LIB}network4-dbg = "${libdir}/.debug/libQtNetwork${QT_LIBINFIX}*"
+FILES_${QT_BASE_LIB}sql4 = "${libdir}/libQtSql${QT_LIBINFIX}.so.*"
FILES_${QT_BASE_LIB}sql4-dev = "${@qt_default_dev('Sql')}"
-FILES_${QT_BASE_LIB}sql4-dbg = "${libdir}/.debug/lib${QT_LIBRARY_NAME}Sql*"
-FILES_${QT_BASE_LIB}svg4 = "${libdir}/lib${QT_LIBRARY_NAME}Svg.so.*"
+FILES_${QT_BASE_LIB}sql4-dbg = "${libdir}/.debug/libQtSql*"
+FILES_${QT_BASE_LIB}svg4 = "${libdir}/libQtSvg${QT_LIBINFIX}.so.*"
FILES_${QT_BASE_LIB}svg4-dev = "${@qt_default_dev('Svg')}"
-FILES_${QT_BASE_LIB}svg4-dbg = "${libdir}/.debug/lib${QT_LIBRARY_NAME}Svg*"
-FILES_${QT_BASE_LIB}test4 = "${libdir}/lib${QT_LIBRARY_NAME}Test.so.*"
+FILES_${QT_BASE_LIB}svg4-dbg = "${libdir}/.debug/libQtSvg*"
+FILES_${QT_BASE_LIB}test4 = "${libdir}/libQtTest${QT_LIBINFIX}.so.*"
FILES_${QT_BASE_LIB}test4-dev = "${@qt_default_dev('Test')}"
-FILES_${QT_BASE_LIB}test4-dbg = "${libdir}/.debug/lib${QT_LIBRARY_NAME}Test*"
-FILES_${QT_BASE_LIB}xml4 = "${libdir}/lib${QT_LIBRARY_NAME}Xml.so.*"
+FILES_${QT_BASE_LIB}test4-dbg = "${libdir}/.debug/libQtTest*"
+FILES_${QT_BASE_LIB}xml4 = "${libdir}/libQtXml${QT_LIBINFIX}.so.*"
FILES_${QT_BASE_LIB}xml4-dev = "${@qt_default_dev('Xml')}"
-FILES_${QT_BASE_LIB}xml4-dbg = "${libdir}/.debug/lib${QT_LIBRARY_NAME}Xml*"
-FILES_${QT_BASE_LIB}designer4 = "${libdir}/lib${QT_LIBRARY_NAME}Designer.so.*"
+FILES_${QT_BASE_LIB}xml4-dbg = "${libdir}/.debug/libQtXml*"
+FILES_${QT_BASE_LIB}designer4 = "${libdir}/libQtDesigner${QT_LIBINFIX}.so.*"
FILES_${QT_BASE_LIB}designer4-dev = "${@qt_default_dev('Designer')}"
-FILES_${QT_BASE_LIB}designer4-dbg = "${libdir}/.debug/lib${QT_LIBRARY_NAME}Designer*"
-FILES_${QT_BASE_LIB}designercomponents4 = "${libdir}/lib${QT_LIBRARY_NAME}DesignerComponents.so.*"
+FILES_${QT_BASE_LIB}designer4-dbg = "${libdir}/.debug/libQtDesigner*"
+FILES_${QT_BASE_LIB}designercomponents4 = "${libdir}/libQtDesignerComponents${QT_LIBINFIX}.so.*"
FILES_${QT_BASE_LIB}designercomponents4-dev = "${@qt_default_dev('DesignerComponents')}"
-FILES_${QT_BASE_LIB}designercomponents4-dbg = "${libdir}/.debug/lib${QT_LIBRARY_NAME}DesignerComponents*"
-FILES_${QT_BASE_LIB}3support4 = "${libdir}/lib${QT_LIBRARY_NAME}3Support.so.*"
+FILES_${QT_BASE_LIB}designercomponents4-dbg = "${libdir}/.debug/libQtDesignerComponents*"
+FILES_${QT_BASE_LIB}3support4 = "${libdir}/libQt3Support${QT_LIBINFIX}.so.*"
FILES_${QT_BASE_LIB}3support4-dev = "${@qt_default_dev('3Support')}"
-FILES_${QT_BASE_LIB}3support4-dbg = "${libdir}/.debug/lib${QT_LIBRARY_NAME}3Support*"
-FILES_${QT_BASE_LIB}assistantclient4 = "${libdir}/lib${QT_LIBRARY_NAME}AssistantClient.so.*"
+FILES_${QT_BASE_LIB}3support4-dbg = "${libdir}/.debug/libQt3Support*"
+FILES_${QT_BASE_LIB}assistantclient4 = "${libdir}/libQtAssistantClient${QT_LIBINFIX}.so.*"
FILES_${QT_BASE_LIB}assistantclient4-dev = "${@qt_default_dev('AssistantClient')} ${includedir}/${QT_DIR_NAME}/QtAssistant*"
-FILES_${QT_BASE_LIB}assistantclient4-dbg = "${libdir}/.debug/lib${QT_LIBRARY_NAME}AssistantClient*"
-FILES_${QT_BASE_LIB}script4 = "${libdir}/lib${QT_LIBRARY_NAME}Script.so.*"
+FILES_${QT_BASE_LIB}assistantclient4-dbg = "${libdir}/.debug/libQtAssistantClient*"
+FILES_${QT_BASE_LIB}script4 = "${libdir}/libQtScript${QT_LIBINFIX}.so.*"
FILES_${QT_BASE_LIB}script4-dev = "${@qt_default_dev('Script')}"
-FILES_${QT_BASE_LIB}script4-dbg = "${libdir}/.debug/lib${QT_LIBRARY_NAME}Script*"
-FILES_${QT_BASE_LIB}dbus4 = "${libdir}/lib${QT_LIBRARY_NAME}DBus.so.*"
+FILES_${QT_BASE_LIB}script4-dbg = "${libdir}/.debug/libQtScript*"
+FILES_${QT_BASE_LIB}dbus4 = "${libdir}/libQtDBus${QT_LIBINFIX}.so.*"
FILES_${QT_BASE_LIB}dbus4-dev = "${@qt_default_dev('DBus')}"
-FILES_${QT_BASE_LIB}dbus4-dbg = "${libdir}/.debug/lib${QT_LIBRARY_NAME}DBus*"
-FILES_${QT_BASE_LIB}opengl4 = "${libdir}/lib${QT_LIBRARY_NAME}OpenGL.so.*"
+FILES_${QT_BASE_LIB}dbus4-dbg = "${libdir}/.debug/libQtDBus*"
+FILES_${QT_BASE_LIB}opengl4 = "${libdir}/libQtOpenGL${QT_LIBINFIX}.so.*"
FILES_${QT_BASE_LIB}opengl4-dev = "${@qt_default_dev('OpenGL')}"
-FILES_${QT_BASE_LIB}opengl4-dbg = "${libdir}/.debug/lib${QT_LIBRARY_NAME}OpenGL*"
-FILES_${QT_BASE_LIB}uitools4-dev = "${libdir}/lib${QT_LIBRARY_NAME}UiTools* ${includedir}/${QT_DIR_NAME}/QtUiTools* ${libdir}/pkgconfig/${QT_LIBRARY_NAME}UiTools.pc"
+FILES_${QT_BASE_LIB}opengl4-dbg = "${libdir}/.debug/libQtOpenGL*"
+FILES_${QT_BASE_LIB}uitools4-dev = "${libdir}/libQtUiTools* ${includedir}/${QT_DIR_NAME}/QtUiTools* ${libdir}/pkgconfig/${QT_LIBRARY_NAME}UiTools.pc"
FILES_${QT_BASE_NAME}-plugins-accessible = "${libdir}/${QT_DIR_NAME}/plugins/accessible/*.so"
diff --git a/packages/qt4/qt_staging.inc b/packages/qt4/qt_staging.inc
index 21f17590b5..37002ca50e 100644
--- a/packages/qt4/qt_staging.inc
+++ b/packages/qt4/qt_staging.inc
@@ -18,6 +18,7 @@ do_stage() {
for i in ${STAGE_TEMP}/${libdir}/*.la
do
+ cp -fpPR $i ${STAGING_LIBDIR}/${QT_DIR_NAME}/
oe_libinstall -C ${STAGE_TEMP}/${libdir} -so $(basename $i .la) ${STAGING_LIBDIR}/${QT_DIR_NAME}
done
diff --git a/packages/qt4/qtopia-core.inc b/packages/qt4/qtopia-core.inc
index 06837787cf..9e4eebc92e 100644
--- a/packages/qt4/qtopia-core.inc
+++ b/packages/qt4/qtopia-core.inc
@@ -15,12 +15,12 @@ S = "${WORKDIR}/qtopia-core-opensource-src-${PV}"
QT_CONFIG_FLAGS += " \
- -nomake demos -nomake examples -nomake tools \
+ -nomake demos -nomake examples -nomake tools -qtlibinfix E\
-qt-mouse-tslib -qt-gfx-transformed -embedded ${QT_ARCH}"
QT_BASE_NAME = "qtopiacore"
QT_BASE_LIB = "libqtopiacore"
-QT_LIBRARY_NAME = "Qt"
QT_DIR_NAME = "qtopia"
+QT_LIBINFIX="E"
require qt_depends.inc
require qt_configuration.inc
require qt_packaging.inc
diff --git a/packages/qt4/qtopia-core_4.3.3.bb b/packages/qt4/qtopia-core_4.3.3.bb
index b903e2b06a..9dad97f49a 100644
--- a/packages/qt4/qtopia-core_4.3.3.bb
+++ b/packages/qt4/qtopia-core_4.3.3.bb
@@ -1,4 +1,5 @@
require qtopia-core.inc
SRC_URI += " \
file://0006-freetype-host-includes.patch;patch=1 \
- file://0007-openssl-host-includes.patch;patch=1 "
+ file://0007-openssl-host-includes.patch;patch=1 \
+ file://0008-backport-qt-lib-infix.patch;patch=1"