aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
Diffstat (limited to 'packages')
-rw-r--r--packages/tuxbox/tuxbox-tuxtxt-32bpp.bb5
-rw-r--r--packages/tuxbox/tuxbox-tuxtxt-32bpp/fake_lcd0_device.diff42
2 files changed, 45 insertions, 2 deletions
diff --git a/packages/tuxbox/tuxbox-tuxtxt-32bpp.bb b/packages/tuxbox/tuxbox-tuxtxt-32bpp.bb
index 8129d5cc60..93c444fcc4 100644
--- a/packages/tuxbox/tuxbox-tuxtxt-32bpp.bb
+++ b/packages/tuxbox/tuxbox-tuxtxt-32bpp.bb
@@ -10,13 +10,14 @@ SRC_URI = "cvs://anoncvs@cvs.tuxbox.org/cvs/tuxbox;module=apps/tuxbox/plugins/tu
file://tuxtxt-resize_video_patch-7025.diff;patch=1;pnum=1 \
file://add_advanced_rc.diff;patch=1;pnum=1 \
file://resize_framebuffer.diff;patch=1;pnum=1 \
- file://allow_different_demux.diff;patch=1;pnum=1"
+ file://allow_different_demux.diff;patch=1;pnum=1 \
+ file://fake_lcd0_device.diff;patch=1;pnum=1"
FILES_${PN} = "/usr/bin /usr/share/fonts /usr/lib/enigma2/python/Plugins/Extensions/Tuxtxt /etc/tuxtxt"
SRCDATE = "20060112"
PV = "0.0+cvs${SRCDATE}"
-PR = "r10"
+PR = "r11"
S = "${WORKDIR}/tuxtxt"
diff --git a/packages/tuxbox/tuxbox-tuxtxt-32bpp/fake_lcd0_device.diff b/packages/tuxbox/tuxbox-tuxtxt-32bpp/fake_lcd0_device.diff
new file mode 100644
index 0000000000..2976bd275b
--- /dev/null
+++ b/packages/tuxbox/tuxbox-tuxtxt-32bpp/fake_lcd0_device.diff
@@ -0,0 +1,42 @@
+diff -Naur tuxtxt_org/python/plugin.py tuxtxt/python/plugin.py
+--- tuxtxt_org/python/plugin.py 2009-07-24 13:12:23.000000000 +0200
++++ tuxtxt/python/plugin.py 2009-07-24 13:16:32.000000000 +0200
+@@ -1,11 +1,13 @@
+-from enigma import *
++from enigma import eConsoleAppContainer, iServiceInformation, fbClass, eRCInput, eDBoxLCD
+ from Screens.Screen import Screen
+ from Plugins.Plugin import PluginDescriptor
++from os import symlink, mkdir, remove, rmdir, path
+
+ class ShellStarter(Screen):
+ skin = """
+ <screen position="1,1" size="1,1" title="TuxTXT" >
+ </screen>"""
++ faked_lcd = False
+
+ def __init__(self, session, args = None):
+ self.skin = ShellStarter.skin
+@@ -28,6 +30,11 @@
+ eRCInput.getInstance().lock()
+ fbClass.getInstance().lock()
+
++ self.faked_lcd = not path.exists("/dev/dbox")
++ if self.faked_lcd:
++ mkdir("/dev/dbox")
++ symlink("/dev/null", "/dev/dbox/lcd0")
++
+ if self.container.execute("/usr/bin/tuxtxt " + demux + " " + txtpid):
+ self.finished(-1)
+
+@@ -35,6 +42,11 @@
+ fbClass.getInstance().unlock()
+ eRCInput.getInstance().unlock()
+ eDBoxLCD.getInstance().unlock()
++
++ if self.faked_lcd:
++ remove("/dev/dbox/lcd0")
++ rmdir("/dev/dbox")
++
+ self.close()
+
+ def main(session, **kwargs):