aboutsummaryrefslogtreecommitdiffstats
path: root/perl/perl-5.8.3
diff options
context:
space:
mode:
Diffstat (limited to 'perl/perl-5.8.3')
-rw-r--r--perl/perl-5.8.3/Makefile.patch23
-rw-r--r--perl/perl-5.8.3/config.sh-arm-linux.patch46
-rw-r--r--perl/perl-5.8.3/libperl-5.8.3-create-libperl-soname.patch11
3 files changed, 80 insertions, 0 deletions
diff --git a/perl/perl-5.8.3/Makefile.patch b/perl/perl-5.8.3/Makefile.patch
index e69de29bb2..eec127643b 100644
--- a/perl/perl-5.8.3/Makefile.patch
+++ b/perl/perl-5.8.3/Makefile.patch
@@ -0,0 +1,23 @@
+*** ./Cross/Makefile 2004-01-12 13:44:01.000000000 -0700
+--- ./Cross/Makefile.patch 2004-08-03 16:34:18.000000000 -0700
+***************
+*** 58,66 ****
+ $(TOPDIR)/generate_config_sh config.sh-$(SYS) > $(TOPDIR)/../config.sh
+ cd $(TOPDIR)/.. ; ./Configure -S ; make depend ; make ; make more
+ cd $(TOPDIR)/.. ; mkdir -p fake_config_library ; cp lib/Config.pm fake_config_library
+! cd $(TOPDIR)/.. ; $(MAKE) more2 "PERLRUN=/usr/bin/perl -I$(TOPDIR)/../fake_config_library -MConfig"
+! cd $(TOPDIR)/.. ; $(MAKE) more3 "PERLRUN=/usr/bin/perl -I$(TOPDIR)/../fake_config_library -MConfig"
+! cd $(TOPDIR)/.. ; $(MAKE) more4 "PERLRUN=/usr/bin/perl -I$(TOPDIR)/../fake_config_library -MConfig"
+ cd $(TOPDIR)/.. ; rm -rf install_me_here
+ cd $(TOPDIR)/.. ; make install-strip
+ cd $(TOPDIR)/.. ; sh -x Cross/warp
+--- 58,66 ----
+ $(TOPDIR)/generate_config_sh config.sh-$(SYS) > $(TOPDIR)/../config.sh
+ cd $(TOPDIR)/.. ; ./Configure -S ; make depend ; make ; make more
+ cd $(TOPDIR)/.. ; mkdir -p fake_config_library ; cp lib/Config.pm fake_config_library
+! cd $(TOPDIR)/.. ; $(MAKE) more2 "PERLRUN=hostperl -I$(TOPDIR)/../fake_config_library -MConfig"
+! cd $(TOPDIR)/.. ; $(MAKE) more3 "PERLRUN=hostperl -I$(TOPDIR)/../fake_config_library -MConfig"
+! cd $(TOPDIR)/.. ; $(MAKE) more4 "PERLRUN=hostperl -I$(TOPDIR)/../fake_config_library -MConfig"
+ cd $(TOPDIR)/.. ; rm -rf install_me_here
+ cd $(TOPDIR)/.. ; make install-strip
+ cd $(TOPDIR)/.. ; sh -x Cross/warp
diff --git a/perl/perl-5.8.3/config.sh-arm-linux.patch b/perl/perl-5.8.3/config.sh-arm-linux.patch
index e69de29bb2..44d8b1a89d 100644
--- a/perl/perl-5.8.3/config.sh-arm-linux.patch
+++ b/perl/perl-5.8.3/config.sh-arm-linux.patch
@@ -0,0 +1,46 @@
+*** ./Cross/config.sh-arm-linux Mon Dec 22 06:00:37 2003
+--- ./Cross/config.sh-arm-linux.patch Tue Aug 3 17:57:08 2004
+***************
+*** 794,805 ****
+ passcat='cat /etc/passwd'
+ patchlevel='8'
+ path_sep=':'
+! perl5='/usr/bin/perl'
+ perl=''
+ perl_patchlevel=''
+ perladmin='red@criticalintegration.com'
+ perllibs='-lnsl -ldl -lm -lcrypt -lutil -lc'
+! perlpath='/usr/bin/perl'
+ pg='pg'
+ phostname='hostname'
+ pidtype='pid_t'
+--- 794,805 ----
+ passcat='cat /etc/passwd'
+ patchlevel='8'
+ path_sep=':'
+! perl5='hostperl'
+ perl=''
+ perl_patchlevel=''
+ perladmin='red@criticalintegration.com'
+ perllibs='-lnsl -ldl -lm -lcrypt -lutil -lc'
+! perlpath='hostperl'
+ pg='pg'
+ phostname='hostname'
+ pidtype='pid_t'
+***************
+*** 905,911 ****
+ srandom_r_proto='0'
+ src='.'
+ ssizetype='ssize_t'
+! startperl='#!/usr/bin/perl'
+ startsh='#!/bin/sh'
+ static_ext=' '
+ stdchar='char'
+--- 905,911 ----
+ srandom_r_proto='0'
+ src='.'
+ ssizetype='ssize_t'
+! startperl='#!hostperl'
+ startsh='#!/bin/sh'
+ static_ext=' '
+ stdchar='char'
diff --git a/perl/perl-5.8.3/libperl-5.8.3-create-libperl-soname.patch b/perl/perl-5.8.3/libperl-5.8.3-create-libperl-soname.patch
index e69de29bb2..5ffd99fceb 100644
--- a/perl/perl-5.8.3/libperl-5.8.3-create-libperl-soname.patch
+++ b/perl/perl-5.8.3/libperl-5.8.3-create-libperl-soname.patch
@@ -0,0 +1,11 @@
+--- Makefile.SH.orig 2003-07-10 14:59:04.000000000 -0700
++++ Makefile.SH 2003-07-10 15:14:08.000000000 -0700
+@@ -494,7 +494,7 @@
+ case "$useshrplib" in
+ true)
+ $spitshell >>Makefile <<'!NO!SUBS!'
+- $(LD) -o $@ $(SHRPLDFLAGS) perl$(OBJ_EXT) $(obj) $(libs)
++ $(LD) -o $@ $(SHRPLDFLAGS) perl$(OBJ_EXT) $(obj) $(libs) -soname libperl.so.`echo $(LIBPERL) | cut -d. -f3`
+ !NO!SUBS!
+ case "$osname" in
+ aix)