aboutsummaryrefslogtreecommitdiffstats
path: root/php/php-4.3.6/autotools.patch
diff options
context:
space:
mode:
Diffstat (limited to 'php/php-4.3.6/autotools.patch')
-rw-r--r--php/php-4.3.6/autotools.patch935
1 files changed, 935 insertions, 0 deletions
diff --git a/php/php-4.3.6/autotools.patch b/php/php-4.3.6/autotools.patch
index e69de29bb2..0b4dbff7f0 100644
--- a/php/php-4.3.6/autotools.patch
+++ b/php/php-4.3.6/autotools.patch
@@ -0,0 +1,935 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- php-4.3.6/acinclude.m4~autotools.patch 2004-01-19 20:11:40.000000000 -0500
++++ php-4.3.6/acinclude.m4 2004-06-04 18:21:54.893679473 -0400
+@@ -16,7 +16,7 @@
+ sed -e "s#\$(srcdir)#$ac_srcdir#g" -e "s#\$(builddir)#$ac_builddir#g" $src >> Makefile.fragments
+ ])
+
+-AC_DEFUN(PHP_PROG_RE2C,[
++AC_DEFUN([PHP_PROG_RE2C],[
+ AC_CHECK_PROG(RE2C, re2c, re2c, [exit 0;])
+ ])
+
+@@ -770,10 +770,10 @@
+ OVERALL_TARGET=[]ifelse($1,,php,$1)
+ php_c_pre='$(CC)'
+ php_c_meta='$(COMMON_FLAGS) $(CFLAGS_CLEAN) $(EXTRA_CFLAGS)'
+- php_c_post=' && echo > $[@]'
++ php_c_post=' && echo "[#] Generated by PHP badness - GNU libtool" > $[@] && echo "pic_object=none" >> $[@] && echo "non_pic_object=$[@]" | sed -e "s,=.*/,=,; s,\.lo,\.o,g" >> $[@]'
+ php_cxx_pre='$(CXX)'
+ php_cxx_meta='$(COMMON_FLAGS) $(CXXFLAGS_CLEAN) $(EXTRA_CXXFLAGS)'
+- php_cxx_post=' && echo > $[@]'
++ php_cxx_post=' && echo "[#] Generated by PHP badness - GNU libtool" > $[@] && echo "pic_object=none" >> $[@] && echo "non_pic_object=$[@]" | sed -e "s,=.*/,=,; s,\.lo,\.o,g" >> $[@]'
+ php_lo=o
+
+ shared_c_pre='$(LIBTOOL) --mode=compile $(CC)'
+@@ -1481,6 +1481,7 @@
+
+ dnl even newer glibcs have a different seeker definition...
+
++ AC_CACHE_CHECK([if cookie io functions use off64_t], php_cv_lib_cookie_io_functions_use_off64_t,
+ AC_TRY_RUN([
+ #define _GNU_SOURCE
+ #include <stdio.h>
+@@ -1510,8 +1511,8 @@
+ }
+
+ ],
+- [ cookie_io_functions_use_off64_t=yes ],
+- [ ] )
++ [ php_cv_lib_cookie_io_functions_use_off64_t=yes ],
++ [ php_cv_lib_cookie_io_functions_use_off64_t=no ] ))
+
+ else
+ dnl older glibc versions (up to 2.1.2 ?)
+--- php-4.3.6/ext/cpdf/config.m4~autotools.patch 2003-09-30 22:53:53.000000000 -0400
++++ php-4.3.6/ext/cpdf/config.m4 2004-06-04 18:21:54.893679473 -0400
+@@ -1,6 +1,6 @@
+ dnl $Id$
+
+-AC_DEFUN(CPDF_JPEG_TEST,[
++AC_DEFUN([CPDF_JPEG_TEST],[
+ AC_ARG_WITH(jpeg-dir,
+ [ --with-jpeg-dir[=DIR] CPDF: Set the path to libjpeg install prefix.],[
+ for i in $withval /usr/local /usr; do
+@@ -23,7 +23,7 @@
+ ],)
+ ])
+
+-AC_DEFUN(CPDF_TIFF_TEST,[
++AC_DEFUN([CPDF_TIFF_TEST],[
+ AC_ARG_WITH(tiff-dir,
+ [ --with-tiff-dir[=DIR] CPDF: Set the path to libtiff install prefix.],[
+ for i in $withval /usr/local /usr; do
+--- php-4.3.6/ext/db/config.m4~autotools.patch 2003-08-15 14:42:11.000000000 -0400
++++ php-4.3.6/ext/db/config.m4 2004-06-04 18:21:54.893679473 -0400
+@@ -4,7 +4,7 @@
+
+ # Checks for libraries.
+ # Prefer gdbm, Berkeley DB and ndbm/dbm, in that order
+-AC_DEFUN(AC_PREFERRED_DB_LIB,[
++AC_DEFUN([AC_PREFERRED_DB_LIB],[
+ AC_CHECK_LIB(gdbm, gdbm_open,[AC_DEFINE(GDBM,1, [Whether you have GDBM]) DBM_TYPE=gdbm; DBM_LIB=-lgdbm],
+ [AC_CHECK_LIB(c, dbm_open,[AC_DEFINE(NDBM,1,[ ]) DBM_TYPE=ndbm; DBM_LIB=],
+ [AC_CHECK_LIB(dbm, dbm_open,[AC_DEFINE(NDBM,1,[ ]) DBM_TYPE=ndbm; DBM_LIB=-ldbm],
+--- php-4.3.6/ext/dba/config.m4~autotools.patch 2004-03-07 19:01:03.000000000 -0500
++++ php-4.3.6/ext/dba/config.m4 2004-06-04 18:21:54.894679234 -0400
+@@ -4,11 +4,11 @@
+
+ dnl Suppose we need FlatFile if no support or only CDB is used.
+
+-AC_DEFUN(PHP_DBA_STD_BEGIN,[
++AC_DEFUN([PHP_DBA_STD_BEGIN],[
+ unset THIS_INCLUDE THIS_LIBS THIS_LFLAGS THIS_PREFIX THIS_RESULT
+ ])
+
+-AC_DEFUN(PHP_TEMP_LDFLAGS,[
++AC_DEFUN([PHP_TEMP_LDFLAGS],[
+ old_LDFLAGS=$LDFLAGS
+ LDFLAGS="$1 $LDFLAGS"
+ $2
+@@ -16,14 +16,14 @@
+ ])
+
+ dnl Assign INCLUDE/LFLAGS from PREFIX
+-AC_DEFUN(PHP_DBA_STD_ASSIGN,[
++AC_DEFUN([PHP_DBA_STD_ASSIGN],[
+ if test -n "$THIS_PREFIX" && test "$THIS_PREFIX" != "/usr"; then
+ THIS_LFLAGS=$THIS_PREFIX/lib
+ fi
+ ])
+
+ dnl Standard check
+-AC_DEFUN(PHP_DBA_STD_CHECK,[
++AC_DEFUN([PHP_DBA_STD_CHECK],[
+ THIS_RESULT="yes"
+ if test -z "$THIS_INCLUDE"; then
+ AC_MSG_ERROR([DBA: Could not find necessary header file(s).])
+@@ -34,14 +34,14 @@
+ ])
+
+ dnl Attach THIS_x to DBA_x
+-AC_DEFUN(PHP_DBA_STD_ATTACH,[
++AC_DEFUN([PHP_DBA_STD_ATTACH],[
+ PHP_ADD_LIBRARY_WITH_PATH($THIS_LIBS, $THIS_LFLAGS, DBA_SHARED_LIBADD)
+ unset THIS_INCLUDE THIS_LIBS THIS_LFLAGS THIS_PREFIX
+ ])
+
+ dnl Print the result message
+ dnl parameters(name [, full name [, empty or error message]])
+-AC_DEFUN(AC_DBA_STD_RESULT,[
++AC_DEFUN([AC_DBA_STD_RESULT],[
+ THIS_NAME=[]translit($1,a-z0-9-,A-Z0-9_)
+ if test -n "$2"; then
+ THIS_FULL_NAME="$2"
+@@ -131,7 +131,7 @@
+
+ dnl Berkeley specific (library and version test)
+ dnl parameters(version, library list, function)
+-AC_DEFUN(PHP_DBA_DB_CHECK,[
++AC_DEFUN([PHP_DBA_DB_CHECK],[
+ for LIB in $2; do
+ if test -f $THIS_PREFIX/lib/lib$LIB.a -o -f $THIS_PREFIX/lib/lib$LIB.$SHLIB_SUFFIX_NAME; then
+ PHP_TEMP_LDFLAGS(-L$THIS_PREFIX/lib -l$LIB,[
+@@ -340,7 +340,7 @@
+ ])
+ AC_DBA_STD_RESULT(dbm)
+
+-AC_DEFUN(PHP_DBA_BUILTIN_CDB,[
++AC_DEFUN([PHP_DBA_BUILTIN_CDB],[
+ AC_DEFINE(DBA_CDB_BUILTIN, 1, [ ])
+ AC_DEFINE(DBA_CDB_MAKE, 1, [ ])
+ AC_DEFINE(DBA_CDB, 1, [ ])
+@@ -386,7 +386,7 @@
+ ])
+ AC_DBA_STD_RESULT(cdb)
+
+-AC_DEFUN(PHP_DBA_BUILTIN_INI,[
++AC_DEFUN([PHP_DBA_BUILTIN_INI],[
+ AC_DEFINE(DBA_INIFILE, 1, [ ])
+ ini_sources="libinifile/inifile.c"
+ THIS_RESULT="builtin"
+@@ -404,7 +404,7 @@
+ ])
+ AC_DBA_STD_RESULT(inifile,INI File)
+
+-AC_DEFUN(PHP_DBA_BUILTIN_FLATFILE,[
++AC_DEFUN([PHP_DBA_BUILTIN_FLATFILE],[
+ AC_DEFINE(DBA_FLATFILE, 1, [ ])
+ flat_sources="libflatfile/flatfile.c"
+ THIS_RESULT="builtin"
+--- php-4.3.6/ext/domxml/config.m4~autotools.patch 2002-10-30 12:42:36.000000000 -0500
++++ php-4.3.6/ext/domxml/config.m4 2004-06-04 18:21:54.894679234 -0400
+@@ -2,7 +2,7 @@
+ dnl $Id$
+ dnl
+
+-AC_DEFUN(PHP_DOM_CHECK_VERSION,[
++AC_DEFUN([PHP_DOM_CHECK_VERSION],[
+ old_CPPFLAGS=$CPPFLAGS
+ CPPFLAGS=-I$DOMXML_DIR/include$DOMXML_DIR_ADD
+ AC_MSG_CHECKING(for libxml version)
+@@ -78,7 +78,7 @@
+ PHP_SUBST(DOMXML_SHARED_LIBADD)
+ fi
+
+-AC_DEFUN(PHP_DOM_XSLT_CHECK_VERSION,[
++AC_DEFUN([PHP_DOM_XSLT_CHECK_VERSION],[
+ old_CPPFLAGS=$CPPFLAGS
+ CPPFLAGS=-I$DOMXSLT_DIR/include
+ AC_MSG_CHECKING(for libxslt version)
+@@ -95,7 +95,7 @@
+ CPPFLAGS=$old_CPPFLAGS
+ ])
+
+-AC_DEFUN(PHP_DOM_EXSLT_CHECK_VERSION,[
++AC_DEFUN([PHP_DOM_EXSLT_CHECK_VERSION],[
+ old_CPPFLAGS=$CPPFLAGS
+ CPPFLAGS=-I$DOMEXSLT_DIR/include
+ AC_MSG_CHECKING(for libexslt version)
+--- php-4.3.6/ext/gd/config.m4~autotools.patch 2003-12-25 17:33:02.000000000 -0500
++++ php-4.3.6/ext/gd/config.m4 2004-06-04 18:21:54.894679234 -0400
+@@ -47,7 +47,7 @@
+ dnl Checks for the configure options
+ dnl
+
+-AC_DEFUN(PHP_GD_JPEG,[
++AC_DEFUN([PHP_GD_JPEG],[
+ if test "$PHP_JPEG_DIR" != "no"; then
+
+ for i in $PHP_JPEG_DIR /usr/local /usr; do
+@@ -72,7 +72,7 @@
+ fi
+ ])
+
+-AC_DEFUN(PHP_GD_PNG,[
++AC_DEFUN([PHP_GD_PNG],[
+ if test "$PHP_PNG_DIR" != "no"; then
+
+ for i in $PHP_PNG_DIR /usr/local /usr; do
+@@ -107,7 +107,7 @@
+ fi
+ ])
+
+-AC_DEFUN(PHP_GD_XPM,[
++AC_DEFUN([PHP_GD_XPM],[
+ if test "$PHP_XPM_DIR" != "no"; then
+
+ for i in $PHP_XPM_DIR /usr/local /usr/X11R6 /usr; do
+@@ -141,7 +141,7 @@
+ fi
+ ])
+
+-AC_DEFUN(PHP_GD_FREETYPE1,[
++AC_DEFUN([PHP_GD_FREETYPE1],[
+ if test "$PHP_TTF" != "no"; then
+ if test "$PHP_FREETYPE_DIR" = "no" -o "$PHP_FREETYPE_DIR" = ""; then
+ if test -n "$PHP_TTF"; then
+@@ -175,7 +175,7 @@
+ fi
+ ])
+
+-AC_DEFUN(PHP_GD_FREETYPE2,[
++AC_DEFUN([PHP_GD_FREETYPE2],[
+ if test "$PHP_FREETYPE_DIR" != "no"; then
+
+ for i in $PHP_FREETYPE_DIR /usr/local /usr; do
+@@ -200,7 +200,7 @@
+ fi
+ ])
+
+-AC_DEFUN(PHP_GD_T1LIB,[
++AC_DEFUN([PHP_GD_T1LIB],[
+ if test "$PHP_T1LIB" != "no"; then
+
+ for i in $PHP_T1LIB /usr/local /usr; do
+@@ -224,19 +224,19 @@
+ fi
+ ])
+
+-AC_DEFUN(PHP_GD_TTSTR,[
++AC_DEFUN([PHP_GD_TTSTR],[
+ if test "$PHP_GD_NATIVE_TTF" = "yes"; then
+ AC_DEFINE(USE_GD_IMGSTRTTF, 1, [ ])
+ fi
+ ])
+
+-AC_DEFUN(PHP_GD_JISX0208,[
++AC_DEFUN([PHP_GD_JISX0208],[
+ if test "$PHP_GD_JIS_CONV" = "yes"; then
+ USE_GD_JIS_CONV=1
+ fi
+ ])
+
+-AC_DEFUN(PHP_GD_CHECK_VERSION,[
++AC_DEFUN([PHP_GD_CHECK_VERSION],[
+ PHP_CHECK_LIBRARY(gd, gdImageString16, [AC_DEFINE(HAVE_LIBGD13, 1, [ ])], [], [ -L$GD_LIB $GD_SHARED_LIBADD ])
+ PHP_CHECK_LIBRARY(gd, gdImagePaletteCopy, [AC_DEFINE(HAVE_LIBGD15, 1, [ ])], [], [ -L$GD_LIB $GD_SHARED_LIBADD ])
+ PHP_CHECK_LIBRARY(gd, gdImageCreateFromPng, [AC_DEFINE(HAVE_GD_PNG, 1, [ ])], [], [ -L$GD_LIB $GD_SHARED_LIBADD ])
+--- php-4.3.6/ext/imap/config.m4~autotools.patch 2004-01-16 19:01:06.000000000 -0500
++++ php-4.3.6/ext/imap/config.m4 2004-06-04 18:21:54.894679234 -0400
+@@ -2,7 +2,7 @@
+ dnl $Id$
+ dnl
+
+-AC_DEFUN(IMAP_INC_CHK,[if test -r "$i$1/c-client.h"; then
++AC_DEFUN([IMAP_INC_CHK],[if test -r "$i$1/c-client.h"; then
+ AC_DEFINE(HAVE_IMAP2000, 1, [ ])
+ IMAP_DIR=$i
+ IMAP_INC_DIR=$i$1
+@@ -13,7 +13,7 @@
+ break
+ ])
+
+-AC_DEFUN(IMAP_LIB_CHK,[
++AC_DEFUN([IMAP_LIB_CHK],[
+ str="$IMAP_DIR/$1/lib$lib.*"
+ for i in `echo $str`; do
+ test -r $i && IMAP_LIBDIR=$IMAP_DIR/$1 && break 2
+@@ -21,7 +21,7 @@
+ ])
+
+ dnl PHP_IMAP_TEST_BUILD(function, action-if-ok, action-if-not-ok [, extra-libs])
+-AC_DEFUN(PHP_IMAP_TEST_BUILD, [
++AC_DEFUN([PHP_IMAP_TEST_BUILD], [
+ old_LIBS=$LIBS
+ LIBS="$4 $LIBS"
+ AC_TRY_RUN([
+@@ -54,7 +54,7 @@
+ ])
+ ])
+
+-AC_DEFUN(PHP_IMAP_KRB_CHK, [
++AC_DEFUN([PHP_IMAP_KRB_CHK], [
+ AC_ARG_WITH(kerberos,
+ [ --with-kerberos[=DIR] IMAP: Include Kerberos support. DIR is the Kerberos install dir.],[
+ PHP_KERBEROS=$withval
+@@ -101,7 +101,7 @@
+
+ ])
+
+-AC_DEFUN(PHP_IMAP_SSL_CHK, [
++AC_DEFUN([PHP_IMAP_SSL_CHK], [
+ AC_ARG_WITH(imap-ssl,
+ [ --with-imap-ssl=<DIR> IMAP: Include SSL support. DIR is the OpenSSL install dir.],[
+ PHP_IMAP_SSL=$withval
+--- php-4.3.6/ext/java/config.m4~autotools.patch 2003-04-04 12:43:13.000000000 -0500
++++ php-4.3.6/ext/java/config.m4 2004-06-04 18:21:54.895678994 -0400
+@@ -1,7 +1,7 @@
+ dnl
+ dnl $Id$
+ dnl
+-AC_DEFUN(JAVA_FIND_JAR, [
++AC_DEFUN([JAVA_FIND_JAR], [
+ AC_MSG_CHECKING([Java Jar location])
+ if test "$PHP_JAVA" = "yes"; then
+ if JAVA_JAR=`which jar 2>/dev/null`; then
+@@ -31,7 +31,7 @@
+ AC_MSG_RESULT([$JAVA_JAR])
+ ])
+
+-AC_DEFUN(JAVA_FIND_C, [
++AC_DEFUN([JAVA_FIND_C], [
+ AC_MSG_CHECKING([Java C location])
+ if test "$PHP_JAVA" = "yes"; then
+ JAVA_C=`which javac`
+@@ -55,7 +55,7 @@
+ AC_MSG_RESULT([$JAVA_C])
+ ])
+
+-AC_DEFUN(JAVA_CHECK_LIB, [
++AC_DEFUN([JAVA_CHECK_LIB], [
+ AC_MSG_CHECKING([Checking for libjava])
+ if test -d $PHP_JAVA/lib/kaffe; then
+ PHP_ADD_LIBPATH($PHP_JAVA/lib)
+--- php-4.3.6/ext/ldap/config.m4~autotools.patch 2003-06-30 20:02:29.000000000 -0400
++++ php-4.3.6/ext/ldap/config.m4 2004-06-04 18:21:54.895678994 -0400
+@@ -2,7 +2,7 @@
+ dnl $Id$
+ dnl
+
+-AC_DEFUN(PHP_LDAP_CHECKS, [
++AC_DEFUN([PHP_LDAP_CHECKS], [
+ if test -f $1/include/ldap.h; then
+ LDAP_DIR=$1
+ LDAP_INCDIR=$1/include
+--- php-4.3.6/ext/msql/config.m4~autotools.patch 2002-03-12 11:25:28.000000000 -0500
++++ php-4.3.6/ext/msql/config.m4 2004-06-04 18:21:54.895678994 -0400
+@@ -5,7 +5,7 @@
+ dnl
+ dnl Test mSQL version by checking if msql.h has "IDX_TYPE" defined.
+ dnl
+-AC_DEFUN(PHP_MSQL_VERSION,[
++AC_DEFUN([PHP_MSQL_VERSION],[
+ AC_MSG_CHECKING([mSQL version])
+ ac_php_oldcppflags=$CPPFLAGS
+ CPPFLAGS="$INCLUDES $CPPFLAGS"
+--- php-4.3.6/ext/mysql/config.m4~autotools.patch 2003-12-31 06:28:38.000000000 -0500
++++ php-4.3.6/ext/mysql/config.m4 2004-06-04 18:21:54.895678994 -0400
+@@ -7,7 +7,7 @@
+ sinclude(libmysql/acinclude.m4)
+ sinclude(libmysql/mysql.m4)
+
+-AC_DEFUN(MYSQL_LIB_CHK, [
++AC_DEFUN([MYSQL_LIB_CHK], [
+ str="$MYSQL_DIR/$1/libmysqlclient.*"
+ for j in `echo $str`; do
+ if test -r $j; then
+@@ -17,7 +17,7 @@
+ done
+ ])
+
+-AC_DEFUN(PHP_MYSQL_SOCKET_SEARCH, [
++AC_DEFUN([PHP_MYSQL_SOCKET_SEARCH], [
+ for i in \
+ /var/run/mysqld/mysqld.sock \
+ /var/tmp/mysql.sock \
+--- php-4.3.6/ext/mysql/libmysql/acinclude.m4~autotools.patch 2002-12-05 10:46:41.000000000 -0500
++++ php-4.3.6/ext/mysql/libmysql/acinclude.m4 2004-06-04 18:21:54.895678994 -0400
+@@ -1,6 +1,6 @@
+ # Local macros for automake & autoconf
+
+-AC_DEFUN(MYSQL_FUNCTION_CHECKS,[
++AC_DEFUN([MYSQL_FUNCTION_CHECKS],[
+
+ # Standard MySQL list
+ AC_CHECK_FUNCS(alarm bmove \
+@@ -27,7 +27,7 @@
+ MYSQL_CHECK_GETHOSTNAME_R
+ ])
+
+-AC_DEFUN(MYSQL_CHECK_GETHOSTNAME_R,[
++AC_DEFUN([MYSQL_CHECK_GETHOSTNAME_R],[
+ # Check definition of gethostbyname_r (glibc2.0.100 is different from Solaris)
+ ac_save_CXXFLAGS="$CXXFLAGS"
+ AC_CACHE_CHECK([style of gethostname_r routines], mysql_cv_gethostname_style,
+@@ -90,7 +90,7 @@
+ fi
+ ])
+
+-AC_DEFUN(MYSQL_CHECK_SIGWAIT_STYLE,[
++AC_DEFUN([MYSQL_CHECK_SIGWAIT_STYLE],[
+ # Check definition av posix sigwait()
+ AC_CACHE_CHECK("style of sigwait", mysql_cv_sigwait,
+ AC_TRY_LINK(
+@@ -134,7 +134,7 @@
+ fi
+ ])
+
+-AC_DEFUN(MYSQL_CHECK_READDIR_R_ARGS,[
++AC_DEFUN([MYSQL_CHECK_READDIR_R_ARGS],[
+ # Check definition of readdir_r
+ AC_CACHE_CHECK("args to readdir_r", mysql_cv_readdir_r,
+ AC_TRY_LINK(
+@@ -153,7 +153,7 @@
+ fi
+ ])
+
+-AC_DEFUN(MYSQL_CHECK_PTHREAD_MUTEX_INIT,[
++AC_DEFUN([MYSQL_CHECK_PTHREAD_MUTEX_INIT],[
+ # Check definition of pthread_mutex_init
+ AC_CACHE_CHECK("args to pthread_mutex_init", mysql_cv_mutex_init_args,
+ AC_TRY_COMPILE(
+@@ -173,7 +173,7 @@
+ fi
+ ])
+
+-AC_DEFUN(MYSQL_CHECK_PTHREAD_GETSPECIFIC,[
++AC_DEFUN([MYSQL_CHECK_PTHREAD_GETSPECIFIC],[
+ # Check definition of pthread_getspecific
+ AC_CACHE_CHECK("args to pthread_getspecific", mysql_cv_getspecific_args,
+ AC_TRY_COMPILE(
+@@ -191,7 +191,7 @@
+ fi
+ ])
+
+-AC_DEFUN(MYSQL_TYPE_ACCEPT,
++AC_DEFUN([MYSQL_TYPE_ACCEPT],
+ [ac_save_CXXFLAGS="$CXXFLAGS"
+ AC_CACHE_CHECK([base type of last arg to accept], mysql_cv_btype_last_arg_accept,
+ AC_LANG_SAVE
+@@ -224,7 +224,7 @@
+ ])
+
+ dnl Find type of qsort
+-AC_DEFUN(MYSQL_TYPE_QSORT,
++AC_DEFUN([MYSQL_TYPE_QSORT],
+ [AC_CACHE_CHECK([return type of qsort], mysql_cv_type_qsort,
+ [AC_TRY_COMPILE([#include <stdlib.h>
+ #ifdef __cplusplus
+@@ -243,7 +243,7 @@
+
+
+ #---START: Used in for client configure
+-AC_DEFUN(MYSQL_CHECK_ULONG,
++AC_DEFUN([MYSQL_CHECK_ULONG],
+ [AC_MSG_CHECKING(for type ulong)
+ AC_CACHE_VAL(ac_cv_ulong,
+ [AC_TRY_RUN([#include <stdio.h>
+@@ -261,7 +261,7 @@
+ fi
+ ])
+
+-AC_DEFUN(MYSQL_CHECK_UCHAR,
++AC_DEFUN([MYSQL_CHECK_UCHAR],
+ [AC_MSG_CHECKING(for type uchar)
+ AC_CACHE_VAL(ac_cv_uchar,
+ [AC_TRY_RUN([#include <stdio.h>
+@@ -279,7 +279,7 @@
+ fi
+ ])
+
+-AC_DEFUN(MYSQL_CHECK_UINT,
++AC_DEFUN([MYSQL_CHECK_UINT],
+ [AC_MSG_CHECKING(for type uint)
+ AC_CACHE_VAL(ac_cv_uint,
+ [AC_TRY_RUN([#include <stdio.h>
+@@ -297,7 +297,7 @@
+ fi
+ ])
+
+-AC_DEFUN(MYSQL_CHECK_USHORT,
++AC_DEFUN([MYSQL_CHECK_USHORT],
+ [AC_MSG_CHECKING(for type ushort)
+ AC_CACHE_VAL(ac_cv_ushort,
+ [AC_TRY_RUN([#include <stdio.h>
+@@ -315,7 +315,7 @@
+ fi
+ ])
+
+-AC_DEFUN(MYSQL_CHECK_INT_8_16_32,
++AC_DEFUN([MYSQL_CHECK_INT_8_16_32],
+ [AC_MSG_CHECKING([for int8])
+ AC_CACHE_VAL(ac_cv_int8,
+ [AC_TRY_RUN([
+@@ -345,7 +345,7 @@
+ ])
+
+
+-AC_DEFUN(MYSQL_HEADER_CHECKS,[
++AC_DEFUN([MYSQL_HEADER_CHECKS],[
+ AC_HEADER_STDC
+ AC_CHECK_HEADERS(sgtty.h sys/ioctl.h \
+ fcntl.h float.h floatingpoint.h ieeefp.h limits.h \
+@@ -356,7 +356,7 @@
+ unistd.h utime.h sys/utime.h termio.h termios.h sched.h crypt.h alloca.h)
+ ])
+
+-AC_DEFUN(MYSQL_TYPE_CHECKS,[
++AC_DEFUN([MYSQL_TYPE_CHECKS],[
+
+ AC_REQUIRE([AC_C_CONST])
+ AC_REQUIRE([AC_C_INLINE])
+--- php-4.3.6/ext/mysql/libmysql/mysql.m4~autotools.patch 2002-03-07 09:19:29.000000000 -0500
++++ php-4.3.6/ext/mysql/libmysql/mysql.m4 2004-06-04 18:21:54.896678755 -0400
+@@ -1,4 +1,4 @@
+-AC_DEFUN(MYSQL_CHECKS,[
++AC_DEFUN([MYSQL_CHECKS],[
+
+ AC_REQUIRE([AC_PROG_CC])
+ AC_REQUIRE([AC_PROG_LN_S])
+--- php-4.3.6/ext/oci8/config.m4~autotools.patch 2004-02-03 09:22:34.000000000 -0500
++++ php-4.3.6/ext/oci8/config.m4 2004-06-04 18:21:54.896678755 -0400
+@@ -2,7 +2,7 @@
+ dnl $Id$
+ dnl
+
+-AC_DEFUN(PHP_OCI_IF_DEFINED,[
++AC_DEFUN([PHP_OCI_IF_DEFINED],[
+ old_CPPFLAGS=$CPPFLAGS
+ CPPFLAGS=$3
+ AC_EGREP_CPP(yes,[
+@@ -18,7 +18,7 @@
+ ])
+ ])
+
+-AC_DEFUN(AC_OCI8_VERSION,[
++AC_DEFUN([AC_OCI8_VERSION],[
+ AC_MSG_CHECKING([Oracle version])
+ if test -s "$OCI8_DIR/orainst/unix.rgs"; then
+ OCI8_VERSION=`grep '"ocommon"' $OCI8_DIR/orainst/unix.rgs | sed 's/[ ][ ]*/:/g' | cut -d: -f 6 | cut -c 2-4`
+--- php-4.3.6/ext/odbc/config.m4~autotools.patch 2003-11-25 03:08:30.000000000 -0500
++++ php-4.3.6/ext/odbc/config.m4 2004-06-04 18:21:54.896678755 -0400
+@@ -5,7 +5,7 @@
+ dnl
+ dnl Figure out which library file to link with for the Solid support.
+ dnl
+-AC_DEFUN(AC_FIND_SOLID_LIBS,[
++AC_DEFUN([AC_FIND_SOLID_LIBS],[
+ AC_MSG_CHECKING([Solid library file])
+ ac_solid_uname_r=`uname -r 2>/dev/null`
+ ac_solid_uname_s=`uname -s 2>/dev/null`
+@@ -71,7 +71,7 @@
+ dnl
+ dnl Figure out which library file to link with for the Empress support.
+ dnl
+-AC_DEFUN(AC_FIND_EMPRESS_LIBS,[
++AC_DEFUN([AC_FIND_EMPRESS_LIBS],[
+ AC_MSG_CHECKING([Empress library file])
+ ODBC_LIBS=`echo $1/libempodbccl.so | cut -d' ' -f1`
+ if test ! -f $ODBC_LIBS; then
+@@ -80,7 +80,7 @@
+ AC_MSG_RESULT(`echo $ODBC_LIBS | sed -e 's!.*/!!'`)
+ ])
+
+-AC_DEFUN(AC_FIND_EMPRESS_BCS_LIBS,[
++AC_DEFUN([AC_FIND_EMPRESS_BCS_LIBS],[
+ AC_MSG_CHECKING([Empress local access library file])
+ ODBCBCS_LIBS=`echo $1/libempodbcbcs.a | cut -d' ' -f1`
+ if test ! -f $ODBCBCS_LIBS; then
+--- php-4.3.6/ext/oracle/config.m4~autotools.patch 2003-10-03 01:25:41.000000000 -0400
++++ php-4.3.6/ext/oracle/config.m4 2004-06-04 18:21:54.896678755 -0400
+@@ -2,7 +2,7 @@
+ dnl $Id$
+ dnl
+
+-AC_DEFUN(AC_ORACLE_VERSION,[
++AC_DEFUN([AC_ORACLE_VERSION],[
+ AC_MSG_CHECKING([Oracle version])
+ if test -s "$ORACLE_DIR/orainst/unix.rgs"; then
+ ORACLE_VERSION=`grep '"ocommon"' $ORACLE_DIR/orainst/unix.rgs | sed 's/[ ][ ]*/:/g' | cut -d: -f 6 | cut -c 2-4`
+--- php-4.3.6/ext/pgsql/config.m4~autotools.patch 2002-06-26 09:07:40.000000000 -0400
++++ php-4.3.6/ext/pgsql/config.m4 2004-06-04 18:21:54.896678755 -0400
+@@ -2,7 +2,7 @@
+ dnl $Id$
+ dnl
+
+-AC_DEFUN(PHP_PGSQL_CHECK_FUNCTIONS,[
++AC_DEFUN([PHP_PGSQL_CHECK_FUNCTIONS],[
+ ])
+
+ PHP_ARG_WITH(pgsql,for PostgreSQL support,
+--- php-4.3.6/ext/standard/config.m4~autotools.patch 2004-04-04 08:31:38.000000000 -0400
++++ php-4.3.6/ext/standard/config.m4 2004-06-04 18:21:54.897678515 -0400
+@@ -5,7 +5,7 @@
+ dnl
+ dnl Check if flush should be called explicitly after buffered io
+ dnl
+-AC_DEFUN(AC_FLUSH_IO,[
++AC_DEFUN([AC_FLUSH_IO],[
+ AC_CACHE_CHECK([whether flush should be called explicitly after a buffered io], ac_cv_flush_io,[
+ AC_TRY_RUN( [
+ #include <stdio.h>
+@@ -56,7 +56,7 @@
+ dnl
+ dnl Check for crypt() capabilities
+ dnl
+-AC_DEFUN(AC_CRYPT_CAP,[
++AC_DEFUN([AC_CRYPT_CAP],[
+
+ if test "$ac_cv_func_crypt" = "no"; then
+ AC_CHECK_LIB(crypt, crypt, [
+--- php-4.3.6/ext/xmlrpc/libxmlrpc/acinclude.m4~autotools.patch 2001-09-06 05:36:57.000000000 -0400
++++ php-4.3.6/ext/xmlrpc/libxmlrpc/acinclude.m4 2004-06-04 18:21:54.897678515 -0400
+@@ -1,6 +1,6 @@
+ # Local macros for automake & autoconf
+
+-AC_DEFUN(XMLRPC_FUNCTION_CHECKS,[
++AC_DEFUN([XMLRPC_FUNCTION_CHECKS],[
+
+ # Standard XMLRPC list
+ AC_CHECK_FUNCS( \
+@@ -10,12 +10,12 @@
+
+ ])
+
+-AC_DEFUN(XMLRPC_HEADER_CHECKS,[
++AC_DEFUN([XMLRPC_HEADER_CHECKS],[
+ AC_HEADER_STDC
+ AC_CHECK_HEADERS(xmlparse.h xmltok.h stdlib.h strings.h string.h)
+ ])
+
+-AC_DEFUN(XMLRPC_TYPE_CHECKS,[
++AC_DEFUN([XMLRPC_TYPE_CHECKS],[
+
+ AC_REQUIRE([AC_C_CONST])
+ AC_REQUIRE([AC_C_INLINE])
+--- php-4.3.6/ext/xmlrpc/libxmlrpc/xmlrpc.m4~autotools.patch 2002-03-07 09:19:43.000000000 -0500
++++ php-4.3.6/ext/xmlrpc/libxmlrpc/xmlrpc.m4 2004-06-04 18:21:54.897678515 -0400
+@@ -1,4 +1,4 @@
+-AC_DEFUN(XMLRPC_CHECKS,[
++AC_DEFUN([XMLRPC_CHECKS],[
+
+ AC_REQUIRE([AC_PROG_CC])
+ AC_REQUIRE([AC_PROG_LN_S])
+--- php-4.3.6/sapi/cgi/config9.m4~autotools.patch 2003-12-01 11:12:38.000000000 -0500
++++ php-4.3.6/sapi/cgi/config9.m4 2004-06-04 18:21:54.897678515 -0400
+@@ -51,7 +51,7 @@
+ PHP_ENABLE_PATHINFO_CHECK=yes
+ ])
+
+-AC_DEFUN(PHP_TEST_WRITE_STDOUT,[
++AC_DEFUN([PHP_TEST_WRITE_STDOUT],[
+ AC_CACHE_CHECK(whether writing to stdout works,ac_cv_write_stdout,[
+ AC_TRY_RUN([
+ #ifdef HAVE_UNISTD_H
+--- php-4.3.6/sapi/cgi/libfcgi/acinclude.m4~autotools.patch 2002-12-02 00:25:55.000000000 -0500
++++ php-4.3.6/sapi/cgi/libfcgi/acinclude.m4 2004-06-04 18:21:54.897678515 -0400
+@@ -1,6 +1,6 @@
+ dnl $Id$
+
+-AC_DEFUN(FCGI_COMMON_CHECKS, [
++AC_DEFUN([FCGI_COMMON_CHECKS], [
+ AC_MSG_CHECKING([for sun_len in sys/un.h])
+ AC_EGREP_HEADER([sun_len], [sys/un.h],
+ [AC_MSG_RESULT([yes])
+--- php-4.3.6/scripts/phpize.m4~autotools.patch 2003-09-03 04:07:51.000000000 -0400
++++ php-4.3.6/scripts/phpize.m4 2004-06-04 18:21:54.897678515 -0400
+@@ -6,7 +6,7 @@
+
+ PHP_INIT_BUILD_SYSTEM
+
+-AC_DEFUN(PHP_WITH_PHP_CONFIG,[
++AC_DEFUN([PHP_WITH_PHP_CONFIG],[
+ AC_ARG_WITH(php-config,
+ [ --with-php-config=PATH],[
+ PHP_CONFIG=$withval
+@@ -29,10 +29,10 @@
+ AC_MSG_RESULT($EXTENSION_DIR)
+ ])
+ dnl
+-AC_DEFUN(PHP_EXT_BUILDDIR,[.])dnl
+-AC_DEFUN(PHP_EXT_DIR,[""])dnl
+-AC_DEFUN(PHP_EXT_SRCDIR,[$abs_srcdir])dnl
+-AC_DEFUN(PHP_ALWAYS_SHARED,[
++AC_DEFUN([PHP_EXT_BUILDDIR],[.])dnl
++AC_DEFUN([PHP_EXT_DIR],[""])dnl
++AC_DEFUN([PHP_EXT_SRCDIR],[$abs_srcdir])dnl
++AC_DEFUN([PHP_ALWAYS_SHARED],[
+ ext_output="yes, shared"
+ ext_shared=yes
+ test "[$]$1" = "no" && $1=yes
+--- php-4.3.6/TSRM/acinclude.m4~autotools.patch 1999-10-04 11:22:18.000000000 -0400
++++ php-4.3.6/TSRM/acinclude.m4 2004-06-04 18:21:54.898678276 -0400
+@@ -1,5 +1,10 @@
+-
+-AC_DEFUN(AM_SET_LIBTOOL_VARIABLE,[
+- LIBTOOL='$(SHELL) $(top_builddir)/libtool $1'
++dnl
++dnl Set libtool variable
++dnl
++AC_DEFUN([PHP_SET_LIBTOOL_VARIABLE],[
++ if test -z "$LIBTOOL"; then
++ LIBTOOL='$(SHELL) $(top_builddir)/libtool $1'
++ else
++ LIBTOOL="$LIBTOOL $1"
++ fi
+ ])
+-
+--- php-4.3.6/TSRM/threads.m4~autotools.patch 2002-10-05 07:26:17.000000000 -0400
++++ php-4.3.6/TSRM/threads.m4 2004-06-04 18:21:54.898678276 -0400
+@@ -30,7 +30,7 @@
+ dnl
+ dnl Set some magic defines to achieve POSIX threads conformance
+ dnl
+-AC_DEFUN(PTHREADS_FLAGS,[
++AC_DEFUN([PTHREADS_FLAGS],[
+ if test -z "$host_alias" && test -n "$host"; then
+ host_alias=$host
+ fi
+@@ -65,7 +65,7 @@
+ dnl
+ dnl Check whether the current setup can use POSIX threads calls
+ dnl
+-AC_DEFUN(PTHREADS_CHECK_COMPILE, [
++AC_DEFUN([PTHREADS_CHECK_COMPILE], [
+ AC_TRY_RUN( [
+ #include <pthread.h>
+ #include <stddef.h>
+@@ -100,7 +100,7 @@
+ dnl -qthreaded AIX cc V5
+ dnl -threads gcc (HP-UX)
+ dnl
+-AC_DEFUN(PTHREADS_CHECK,[
++AC_DEFUN([PTHREADS_CHECK],[
+
+ if test "$beos_threads" = "1"; then
+ pthreads_working="yes"
+@@ -154,7 +154,7 @@
+ ])dnl
+ dnl
+ dnl
+-AC_DEFUN(PTHREADS_ASSIGN_VARS,[
++AC_DEFUN([PTHREADS_ASSIGN_VARS],[
+ if test -n "$ac_cv_pthreads_lib"; then
+ LIBS="$LIBS -l$ac_cv_pthreads_lib"
+ fi
+--- php-4.3.6/TSRM/tsrm.m4~autotools.patch 2003-10-03 01:25:30.000000000 -0400
++++ php-4.3.6/TSRM/tsrm.m4 2004-06-04 18:21:54.898678276 -0400
+@@ -1,6 +1,6 @@
+
+ dnl TSRM_CHECK_GCC_ARG(ARG, ACTION-IF-FOUND, ACTION-IF-NOT_FOUND)
+-AC_DEFUN(TSRM_CHECK_GCC_ARG,[
++AC_DEFUN([TSRM_CHECK_GCC_ARG],[
+ gcc_arg_name=[ac_cv_gcc_arg]translit($1,A-Z-,a-z_)
+ AC_CACHE_CHECK([whether $CC supports $1], [ac_cv_gcc_arg]translit($1,A-Z-,a-z_), [
+ echo 'void somefunc() { };' > conftest.c
+@@ -21,7 +21,7 @@
+ fi
+ ])
+
+-AC_DEFUN(TSRM_BASIC_CHECKS,[
++AC_DEFUN([TSRM_BASIC_CHECKS],[
+
+ AC_REQUIRE([AC_PROG_CC])dnl
+ dnl AC_REQUIRE([AM_PROG_CC_STDC])dnl
+@@ -33,7 +33,7 @@
+ ])
+
+
+-AC_DEFUN(TSRM_CHECK_PTH,[
++AC_DEFUN([TSRM_CHECK_PTH],[
+
+ AC_MSG_CHECKING(for GNU Pth)
+ PTH_PREFIX="`$1 --prefix`"
+@@ -50,7 +50,7 @@
+
+ ])
+
+-AC_DEFUN(TSRM_CHECK_ST,[
++AC_DEFUN([TSRM_CHECK_ST],[
+ if test -r "$1/include/st.h"; then
+ CPPFLAGS="$CPPFLAGS -I$1/include"
+ LDFLAGS="$LDFLAGS -L$1/lib"
+@@ -68,9 +68,8 @@
+ ])
+
+ sinclude(threads.m4)
+-sinclude(TSRM/threads.m4)
+
+-AC_DEFUN(TSRM_CHECK_PTHREADS,[
++AC_DEFUN([TSRM_CHECK_PTHREADS],[
+
+ PTHREADS_CHECK
+
+@@ -89,7 +88,7 @@
+ ])
+
+
+-AC_DEFUN(TSRM_THREADS_CHECKS,[
++AC_DEFUN([TSRM_THREADS_CHECKS],[
+
+ dnl For the thread implementations, we always use --with-*
+ dnl to maintain consistency
+--- php-4.3.6/Zend/acinclude.m4~autotools.patch 2000-06-18 12:51:41.000000000 -0400
++++ php-4.3.6/Zend/acinclude.m4 2004-06-04 18:21:54.898678276 -0400
+@@ -2,7 +2,7 @@
+ dnl
+ dnl This file contains local autoconf functions.
+
+-AC_DEFUN(ZEND_FP_EXCEPT,[
++AC_DEFUN([ZEND_FP_EXCEPT],[
+ AC_CACHE_CHECK(whether fp_except is defined, ac_cv_type_fp_except,[
+ AC_TRY_COMPILE([
+ #include <floatingpoint.h>
+@@ -23,7 +23,7 @@
+ dnl
+ dnl Check for broken sprintf()
+ dnl
+-AC_DEFUN(AC_ZEND_BROKEN_SPRINTF,[
++AC_DEFUN([AC_ZEND_BROKEN_SPRINTF],[
+ AC_CACHE_CHECK(whether sprintf is broken, ac_cv_broken_sprintf,[
+ AC_TRY_RUN([main() {char buf[20];exit(sprintf(buf,"testing 123")!=11); }],[
+ ac_cv_broken_sprintf=no
+@@ -41,7 +41,7 @@
+ AC_DEFINE_UNQUOTED(ZEND_BROKEN_SPRINTF, $ac_result, [Whether sprintf is broken])
+ ])
+
+-AC_DEFUN(AM_SET_LIBTOOL_VARIABLE,[
++AC_DEFUN([AM_SET_LIBTOOL_VARIABLE],[
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool $1'
+ ])
+
+--- php-4.3.6/Zend/Zend.m4~autotools.patch 2003-10-07 18:49:27.000000000 -0400
++++ php-4.3.6/Zend/Zend.m4 2004-06-04 18:21:54.898678276 -0400
+@@ -4,7 +4,7 @@
+ dnl This file contains Zend specific autoconf functions.
+ dnl
+
+-AC_DEFUN(LIBZEND_BISON_CHECK,[
++AC_DEFUN([LIBZEND_BISON_CHECK],[
+
+ if test "$YACC" != "bison -y"; then
+ AC_MSG_WARN(You will need bison if you want to regenerate the Zend parser.)
+@@ -19,7 +19,7 @@
+
+ ])
+
+-AC_DEFUN(LIBZEND_BASIC_CHECKS,[
++AC_DEFUN([LIBZEND_BASIC_CHECKS],[
+
+ AC_REQUIRE([AC_PROG_YACC])
+ AC_REQUIRE([AC_PROG_CC])
+@@ -74,12 +74,12 @@
+
+ ])
+
+-AC_DEFUN(LIBZEND_LIBDL_CHECKS,[
++AC_DEFUN([LIBZEND_LIBDL_CHECKS],[
+ AC_CHECK_LIB(dl, dlopen, [LIBS="-ldl $LIBS"])
+ AC_CHECK_FUNC(dlopen,[AC_DEFINE(HAVE_LIBDL, 1,[ ])])
+ ])
+
+-AC_DEFUN(LIBZEND_DLSYM_CHECK,[
++AC_DEFUN([LIBZEND_DLSYM_CHECK],[
+ dnl
+ dnl Ugly hack to check if dlsym() requires a leading underscore in symbol name.
+ dnl
+@@ -96,7 +96,7 @@
+
+
+
+-AC_DEFUN(LIBZEND_ENABLE_DEBUG,[
++AC_DEFUN([LIBZEND_ENABLE_DEBUG],[
+
+ AC_ARG_ENABLE(debug,
+ [ --enable-debug Compile with debugging symbols],[
+@@ -118,7 +118,7 @@
+
+
+
+-AC_DEFUN(LIBZEND_OTHER_CHECKS,[
++AC_DEFUN([LIBZEND_OTHER_CHECKS],[
+
+ AC_ARG_ENABLE(experimental-zts,
+ [ --enable-experimental-zts
+@@ -210,6 +210,6 @@
+ ])
+
+
+-AC_DEFUN(LIBZEND_CPLUSPLUS_CHECKS,[
++AC_DEFUN([LIBZEND_CPLUSPLUS_CHECKS],[
+
+ ])
+--- php-4.3.6/configure.in~autotools.patch 2004-04-14 11:00:35.000000000 -0400
++++ php-4.3.6/configure.in 2004-06-04 18:21:54.899678036 -0400
+@@ -45,10 +45,10 @@
+ VERSION="$MAJOR_VERSION.$MINOR_VERSION.$RELEASE_VERSION$EXTRA_VERSION"
+
+ dnl Define where extension directories are located in the configure context
+-AC_DEFUN(PHP_EXT_BUILDDIR,[ext/$1])dnl
+-AC_DEFUN(PHP_EXT_DIR,[ext/$1])dnl
+-AC_DEFUN(PHP_EXT_SRCDIR,[$abs_srcdir/ext/$1])dnl
+-AC_DEFUN(PHP_ALWAYS_SHARED,[])dnl
++AC_DEFUN([PHP_EXT_BUILDDIR],[ext/$1])dnl
++AC_DEFUN([PHP_EXT_DIR],[ext/$1])dnl
++AC_DEFUN([PHP_EXT_SRCDIR],[$abs_srcdir/ext/$1])dnl
++AC_DEFUN([PHP_ALWAYS_SHARED],[])dnl
+
+ dnl Setting up the PHP version based on the information above.
+ dnl -------------------------------------------------------------------------
+--- php-4.3.6/TSRM/configure.in~autotools.patch 2001-08-08 06:26:21.000000000 -0400
++++ php-4.3.6/TSRM/configure.in 2004-06-04 18:21:54.899678036 -0400
+@@ -14,7 +14,7 @@
+
+ AM_PROG_LIBTOOL
+ if test "$enable_debug" != "yes"; then
+- AM_SET_LIBTOOL_VARIABLE([--silent])
++ PHP_SET_LIBTOOL_VARIABLE([--silent])
+ fi
+
+ dnl TSRM_PTHREAD