aboutsummaryrefslogtreecommitdiffstats
path: root/python/python-numeric/no-lapack.patch
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-numeric/no-lapack.patch')
-rw-r--r--python/python-numeric/no-lapack.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/python/python-numeric/no-lapack.patch b/python/python-numeric/no-lapack.patch
index e69de29bb2..d27c666ff4 100644
--- a/python/python-numeric/no-lapack.patch
+++ b/python/python-numeric/no-lapack.patch
@@ -0,0 +1,36 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- Numeric-23.3/setup.py~no-lapack
++++ Numeric-23.3/setup.py
+@@ -32,22 +32,22 @@
+ mathlibs = []
+
+ # delete all but the first one in this list if using your own LAPACK/BLAS
+-sourcelist = [os.path.join('Src', 'lapack_litemodule.c'),
++sourcelist = [] # os.path.join('Src', 'lapack_litemodule.c'),
+ # os.path.join('Src', 'blas_lite.c'),
+ # os.path.join('Src', 'f2c_lite.c'),
+ # os.path.join('Src', 'zlapack_lite.c'),
+ # os.path.join('Src', 'dlapack_lite.c')
+- ]
++
+ # set these to use your own BLAS;
+
+-library_dirs_list = ['/usr/lib/atlas']
+-libraries_list = ['lapack', 'cblas', 'f77blas', 'atlas', 'g2c']
++library_dirs_list = [] # '/usr/lib/atlas']
++libraries_list = [] # 'lapack', 'cblas', 'f77blas', 'atlas', 'g2c']
+ # if you also set `use_dotblas` (see below), you'll need:
+ # ['lapack', 'cblas', 'f77blas', 'atlas', 'g2c']
+
+ # set to true (1), if you also want BLAS optimized matrixmultiply/dot/innerproduct
+-use_dotblas = 1
+-include_dirs = ['/usr/include/atlas'] # You may need to set this to find cblas.h
++use_dotblas = 0
++include_dirs = [] # '/usr/include/atlas'] # You may need to set this to find cblas.h
+ # e.g. on UNIX using ATLAS this should be ['/usr/include/atlas']
+
+ # The packages are split in this way to allow future optional inclusion