aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ace
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ace')
-rw-r--r--recipes/ace/ace.inc18
-rw-r--r--recipes/ace/ace_5.6.8.bb1
2 files changed, 19 insertions, 0 deletions
diff --git a/recipes/ace/ace.inc b/recipes/ace/ace.inc
new file mode 100644
index 0000000000..f2afc48a44
--- /dev/null
+++ b/recipes/ace/ace.inc
@@ -0,0 +1,18 @@
+DESCRIPTION = "C++ network programming framework"
+SECTION = "net"
+LICENSE = "http://www.cs.wustl.edu/~schmidt/ACE-copying.html"
+
+DEPENDS += "openssl gperf-native"
+
+SRC_URI = "ftp://download.dre.vanderbilt.edu/previous_versions/ACE-${PV}.tar.bz2"
+S = "${WORKDIR}/ACE_wrappers"
+B = "${WORKDIR}/build.${TARGET_SYS}"
+
+EXTRA_OECONF += "--disable-ace-tests --disable-gperf"
+LEAD_SONAME = "libACE-[0-9.]*.so"
+
+inherit autotools
+
+do_configure_prepend() {
+ export ace_cv_linux_event_poll=yes
+}
diff --git a/recipes/ace/ace_5.6.8.bb b/recipes/ace/ace_5.6.8.bb
new file mode 100644
index 0000000000..345abe17e4
--- /dev/null
+++ b/recipes/ace/ace_5.6.8.bb
@@ -0,0 +1 @@
+require ace.inc