aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/aiostress/aiostress_0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/aiostress/aiostress_0.0.bb')
-rw-r--r--recipes/aiostress/aiostress_0.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/aiostress/aiostress_0.0.bb b/recipes/aiostress/aiostress_0.0.bb
new file mode 100644
index 0000000000..430e8a50ad
--- /dev/null
+++ b/recipes/aiostress/aiostress_0.0.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Asynchronous I/O stress util"
+LICENSE = "GPLv2"
+DEPENDS = "libaio"
+PR ="r1"
+
+SRC_URI = "http://mirrors.easynews.com/linux/suse/people/mason/utils/aio-stress.c"
+
+S = "${WORKDIR}"
+
+do_compile() {
+
+ cd ${S} && ${CC} aio-stress.c -o aio-stress -I${STAGING_INCDIR} -L${STAGING_LIBDIR} -laio -lpthread
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 aio-stress ${D}${bindir}
+}