summaryrefslogtreecommitdiffstats
path: root/recipes/aircrack/aircrack_2.41.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/aircrack/aircrack_2.41.bb')
-rw-r--r--recipes/aircrack/aircrack_2.41.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/aircrack/aircrack_2.41.bb b/recipes/aircrack/aircrack_2.41.bb
new file mode 100644
index 0000000000..723215e265
--- /dev/null
+++ b/recipes/aircrack/aircrack_2.41.bb
@@ -0,0 +1,24 @@
+SECTION = "console/network"
+DESCRIPTION = "Aircrack is a set of tools for wep key statistical cracking"
+HOMEPAGE = "http://www.cr0.net:8040/code/network/aircrack/"
+LICENSE = "GPLv2"
+DEPENDS = ""
+PR ="r1"
+
+SRC_URI = "http://www.wirelessdefence.org/Contents/Files/${P}.tgz \
+ file://oe.patch;patch=1;pnum=1"
+
+inherit autotools
+
+do_install() {
+ install -d ${D}/${sbindir}
+ install -d ${D}/${libdir}/${PN}
+ install -m 0755 airodump ${D}/${sbindir}
+ install -m 0755 aircrack ${D}/${sbindir}
+ install -m 0755 aireplay ${D}/${sbindir}
+ install -m 0755 airdecap ${D}/${sbindir}
+ install -m 0755 arpforge ${D}/${sbindir}
+ install -m 0755 airmon.sh ${D}/${sbindir}
+ install -m 0755 mergeivs ${D}/${sbindir}
+ install -m 0755 pcap2ivs ${D}/${sbindir}
+}