summaryrefslogtreecommitdiffstats
path: root/recipes/aircrack
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/aircrack')
-rw-r--r--recipes/aircrack/aircrack-ng_0.9.3.bb22
-rw-r--r--recipes/aircrack/aircrack-ng_1.0-svn.bb40
-rw-r--r--recipes/aircrack/aircrack_2.1.bb22
-rw-r--r--recipes/aircrack/aircrack_2.41.bb24
-rw-r--r--recipes/aircrack/files/makefile-ldflags.patch13
-rw-r--r--recipes/aircrack/files/oe.patch10
-rw-r--r--recipes/aircrack/files/silent_patch.diff87
7 files changed, 218 insertions, 0 deletions
diff --git a/recipes/aircrack/aircrack-ng_0.9.3.bb b/recipes/aircrack/aircrack-ng_0.9.3.bb
new file mode 100644
index 0000000000..1452a64bc1
--- /dev/null
+++ b/recipes/aircrack/aircrack-ng_0.9.3.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Aircrack-ng is a set of tools for wep key statistical cracking"
+HOMEPAGE = "http://www.aircrack-ng.org/"
+SECTION = "console/network"
+LICENSE = "GPLv2"
+PR = "r0"
+
+SRC_URI = "http://download.aircrack-ng.org/aircrack-ng-${PV}.tar.gz"
+
+SBINFILES = "airodump-ng aireplay-ng airmon-ng airtun-ng"
+BINFILES = "aircrack-ng airdecap-ng packetforge-ng ivstools kstats makeivs"
+
+do_install() {
+ install -d ${D}/${sbindir}
+ for i in ${SBINFILES}; do
+ install -m 0755 $i ${D}/${sbindir}
+ done
+
+ install -d ${D}/${bindir}
+ for i in ${BINFILES}; do
+ install -m 0755 $i ${D}/${bindir}
+ done
+}
diff --git a/recipes/aircrack/aircrack-ng_1.0-svn.bb b/recipes/aircrack/aircrack-ng_1.0-svn.bb
new file mode 100644
index 0000000000..0f0f7f532d
--- /dev/null
+++ b/recipes/aircrack/aircrack-ng_1.0-svn.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "Aircrack-ng is a set of tools for wep key statistical cracking"
+HOMEPAGE = "http://www.aircrack-ng.org/"
+SECTION = "console/network"
+LICENSE = "GPLv2"
+DEPENDS = "openssl zlib sqlite3"
+PV = "0.9.99+svnr${SRCREV}"
+PR = "r1"
+SRC_URI = "svn://trac.aircrack-ng.org/svn/branch;module=1.0-dev;proto=http"
+
+S="${WORKDIR}/1.0-dev"
+
+DEFAULT_PREFERENCE = "-1"
+
+export TOOL_PREFIX = "${HOST_SYS}-"
+
+do_compile() {
+ oe_runmake SQLITE=true
+}
+
+do_install() {
+ install -d ${D}/${sbindir}
+ install -d ${D}/${bindir}
+ install -m 0755 src/airodump-ng ${D}/${sbindir}
+ install -m 0755 src/aircrack-ng ${D}/${bindir}
+ install -m 0755 src/aireplay-ng ${D}/${sbindir}
+ install -m 0755 src/airserv-ng ${D}/${sbindir}
+ install -m 0755 src/wesside-ng ${D}/${sbindir}
+ install -m 0755 src/easside-ng ${D}/${sbindir}
+ install -m 0755 src/airdecap-ng ${D}/${bindir}
+ install -m 0755 src/packetforge-ng ${D}/${bindir}
+ install -m 0755 airmon-ng ${D}/${sbindir}
+ install -m 0755 src/ivstools ${D}/${bindir}
+ install -m 0755 src/kstats ${D}/${bindir}
+ install -m 0755 src/airtun-ng ${D}/${sbindir}
+ install -m 0755 src/makeivs-ng ${D}/${bindir}
+ install -m 0755 src/buddy-ng ${D}/${bindir}
+# I'm not including airdriver-ng as it is for building drivers and most people
+# cannot use it on their handheld anyway.
+}
+
diff --git a/recipes/aircrack/aircrack_2.1.bb b/recipes/aircrack/aircrack_2.1.bb
new file mode 100644
index 0000000000..f4e6485351
--- /dev/null
+++ b/recipes/aircrack/aircrack_2.1.bb
@@ -0,0 +1,22 @@
+SECTION = "console/network"
+DESCRIPTION = "Aircrack is a set of tools for wep key statistical cracking"
+HOMEPAGE = "http://www.cr0.net:8040/code/network/aircrack/"
+LICENSE = "GPLv2"
+DEPENDS = ""
+PV="2.1"
+PR ="r0"
+
+SRC_URI = "http://www.cr0.net:8040/code/network/aircrack-2.1.tgz \
+file://silent_patch.diff;patch=1;pnum=0"
+
+inherit autotools
+
+do_install() {
+ install -d ${D}/${sbindir}
+ install -d ${D}/${libdir}/${PN}
+ install -m 0755 802ether ${D}/${sbindir}
+ install -m 0755 airodump ${D}/${sbindir}
+ install -m 0755 aircrack ${D}/${sbindir}
+ install -m 0755 aireplay ${D}/${sbindir}
+ install -m 0755 hopper.sh ${D}/${sbindir}
+}
diff --git a/recipes/aircrack/aircrack_2.41.bb b/recipes/aircrack/aircrack_2.41.bb
new file mode 100644
index 0000000000..723215e265
--- /dev/null
+++ b/recipes/aircrack/aircrack_2.41.bb
@@ -0,0 +1,24 @@
+SECTION = "console/network"
+DESCRIPTION = "Aircrack is a set of tools for wep key statistical cracking"
+HOMEPAGE = "http://www.cr0.net:8040/code/network/aircrack/"
+LICENSE = "GPLv2"
+DEPENDS = ""
+PR ="r1"
+
+SRC_URI = "http://www.wirelessdefence.org/Contents/Files/${P}.tgz \
+ file://oe.patch;patch=1;pnum=1"
+
+inherit autotools
+
+do_install() {
+ install -d ${D}/${sbindir}
+ install -d ${D}/${libdir}/${PN}
+ install -m 0755 airodump ${D}/${sbindir}
+ install -m 0755 aircrack ${D}/${sbindir}
+ install -m 0755 aireplay ${D}/${sbindir}
+ install -m 0755 airdecap ${D}/${sbindir}
+ install -m 0755 arpforge ${D}/${sbindir}
+ install -m 0755 airmon.sh ${D}/${sbindir}
+ install -m 0755 mergeivs ${D}/${sbindir}
+ install -m 0755 pcap2ivs ${D}/${sbindir}
+}
diff --git a/recipes/aircrack/files/makefile-ldflags.patch b/recipes/aircrack/files/makefile-ldflags.patch
new file mode 100644
index 0000000000..da2a0afaf1
--- /dev/null
+++ b/recipes/aircrack/files/makefile-ldflags.patch
@@ -0,0 +1,13 @@
+Index: 1.0-dev/src/Makefile
+===================================================================
+--- 1.0-dev.orig/src/Makefile 2007-06-29 21:16:15.000000000 +0100
++++ 1.0-dev/src/Makefile 2007-06-29 21:16:32.000000000 +0100
+@@ -36,7 +36,7 @@
+ endif
+ LIBOSD = $(OSD)/lib$(OSD).a
+
+-LIBSSL = -lssl -lcrypto
++LIBSSL = -lssl -lcrypto $(LDFLAGS)
+
+ all: osd userland $(SBINFILES)
+
diff --git a/recipes/aircrack/files/oe.patch b/recipes/aircrack/files/oe.patch
new file mode 100644
index 0000000000..742d83b96b
--- /dev/null
+++ b/recipes/aircrack/files/oe.patch
@@ -0,0 +1,10 @@
+diff -ur aircrack-2.41-orig/Makefile aircrack-2.41/Makefile
+--- aircrack-2.41-orig/Makefile 2005-11-22 13:09:39.000000000 -0500
++++ aircrack-2.41/Makefile 2005-12-12 19:54:29.000000000 -0500
+@@ -1,5 +1,4 @@
+-CC = gcc
+-CFLAGS = -g -W -Wall -O2
++CFLAGS = -g -W -Wall -O3
+ OPTFLAGS = -D_FILE_OFFSET_BITS=64 -D_MAJ=2 -D_MIN=41
+
+ prefix = /usr/local
diff --git a/recipes/aircrack/files/silent_patch.diff b/recipes/aircrack/files/silent_patch.diff
new file mode 100644
index 0000000000..b3ed5d3b49
--- /dev/null
+++ b/recipes/aircrack/files/silent_patch.diff
@@ -0,0 +1,87 @@
+--- aircrack.c.o 2005-02-14 01:10:25.000000000 +0100
++++ aircrack.c 2005-02-14 01:11:00.000000000 +0100
+@@ -44,6 +44,7 @@
+ "\n"
+ " usage: aircrack [options] <pcap file> <pcap file> ...\n"
+ "\n"
++" -S : silent - usefull for embedded devices\n"
+ " -d <start> : debug - specify beginning of the key\n"
+ " -f <fudge> : bruteforce fudge factor (default: 2)\n"
+ " -m <maddr> : MAC address to filter usable packets\n"
+@@ -53,6 +54,7 @@
+
+ /* command-line parameters */
+
++int silent = 0; /* Silent, just display wep key if found */
+ int debug_lvl = 0; /* # of keybytes fixed */
+ int macfilter = 0; /* BSSID check flag */
+ int stability = 0; /* unstable attacks on */
+@@ -803,7 +805,10 @@
+
+ wepkey[B] = wpoll[B][depth[B]].index;
+
+- show_stats( B );
++ if (! silent)
++ {
++ show_stats( B );
++ }
+
+ if( B == 4 && weplen == 13 )
+ {
+@@ -832,14 +837,20 @@
+
+ /* we have a valid key */
+
++ if (! silent )
++ {
+ show_stats( B );
+-
+ printf( " \33[31;1mKEY FOUND! [ " );
+-
+ for( i = 0; i < weplen; i++ )
+ printf( "%02X", wepkey[i] );
+-
+ printf( " ]\33[0m\n\n" );
++ } else
++ {
++ printf( "KEY FOUND! [ " );
++ for( i = 0; i < weplen; i++ )
++ printf( "%02X", wepkey[i] );
++ printf( "]\n\n" );
++ }
+
+ kill( 0, SIGTERM );
+
+@@ -893,7 +904,7 @@
+
+ while( 1 )
+ {
+- int option = getopt( argc, argv, "d:f:m:n:p:s:" );
++ int option = getopt( argc, argv, "Sd:f:m:n:p:s:" );
+
+ if( option < 0 ) break;
+
+@@ -997,6 +1008,10 @@
+
+ break;
+
++ case 'S':
++ silent=1;
++ break;
++
+ default : goto usage;
+ }
+ }
+@@ -1072,7 +1087,11 @@
+ tm_start = time( NULL );
+ tm_prev = time( NULL );
+
+- printf( "\33[2J" );
++ if (!silent)
++ {
++ printf( "\33[2J" );
++ }
++
+ fflush( stdout );
+
+ return( do_wep_crack( 0 ) );