aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/angstrom/angstrom-gnome-icon-theme-enable.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/angstrom/angstrom-gnome-icon-theme-enable.bb')
-rw-r--r--recipes/angstrom/angstrom-gnome-icon-theme-enable.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/angstrom/angstrom-gnome-icon-theme-enable.bb b/recipes/angstrom/angstrom-gnome-icon-theme-enable.bb
new file mode 100644
index 0000000000..423dd00588
--- /dev/null
+++ b/recipes/angstrom/angstrom-gnome-icon-theme-enable.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Enable gnome-icon-theme in gtkrc"
+LICENSE = "MIT"
+
+RDEPENDS = "gnome-icon-theme"
+
+ALLOW_EMPTY_${PN} = "1"
+PACKAGE_ARCH = "all"
+
+pkg_postinst() {
+#!/bin/sh
+mkdir -p $D${sysconfdir}/gtk-2.0
+touch $D${sysconfdir}/gtk-2.0/gtkrc
+sed -i /gtk-icon-theme-name/d $D${sysconfdir}/gtk-2.0/gtkrc
+echo 'gtk-icon-theme-name = "gnome"' >> $D${sysconfdir}/gtk-2.0/gtkrc
+}
+