aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/antlr/antlr_2.7.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/antlr/antlr_2.7.7.bb')
-rw-r--r--recipes/antlr/antlr_2.7.7.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/antlr/antlr_2.7.7.bb b/recipes/antlr/antlr_2.7.7.bb
new file mode 100644
index 0000000000..431b7b5b4f
--- /dev/null
+++ b/recipes/antlr/antlr_2.7.7.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Framework for constructing recognizers, interpreters, compilers, and translators"
+# see http://www.antlr2.org/license.html
+LICENSE = "Public Domain"
+HOMEPAGE = "http://www.antlr2.org"
+
+SRC_URI = "http://www.antlr2.org/download/${BP}.tar.gz"
+
+inherit java-library
+
+do_compile() {
+ mkdir -p build
+
+ javac -sourcepath . -d build `find antlr -name "*.java"`
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}