aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/apache2/apache2-2.2.3
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/apache2/apache2-2.2.3')
-rw-r--r--recipes/apache2/apache2-2.2.3/apr-sockets-patch10
-rw-r--r--recipes/apache2/apache2-2.2.3/configure-fix-cross-compile-ptr-check.patch17
-rw-r--r--recipes/apache2/apache2-2.2.3/configure-patch52
-rw-r--r--recipes/apache2/apache2-2.2.3/dftables-makefile-patch10
-rw-r--r--recipes/apache2/apache2-2.2.3/server-makefile-patch11
5 files changed, 100 insertions, 0 deletions
diff --git a/recipes/apache2/apache2-2.2.3/apr-sockets-patch b/recipes/apache2/apache2-2.2.3/apr-sockets-patch
new file mode 100644
index 0000000000..5e974820b3
--- /dev/null
+++ b/recipes/apache2/apache2-2.2.3/apr-sockets-patch
@@ -0,0 +1,10 @@
+--- httpd-2.2.3/srclib/apr/network_io/unix/sockets.c.orig
++++ httpd-2.2.3/srclib/apr/network_io/unix/sockets.c
+@@ -231,6 +231,7 @@
+ #if APR_O_NONBLOCK_INHERITED
+ if (apr_is_option_set(sock, APR_SO_NONBLOCK) == 1) {
+ apr_set_option(*new, APR_SO_NONBLOCK, 1);
++ apr_socket_opt_set(*new, APR_SO_NONBLOCK, 0);
+ }
+ #endif /* APR_O_NONBLOCK_INHERITED */
+
diff --git a/recipes/apache2/apache2-2.2.3/configure-fix-cross-compile-ptr-check.patch b/recipes/apache2/apache2-2.2.3/configure-fix-cross-compile-ptr-check.patch
new file mode 100644
index 0000000000..fab828ddc3
--- /dev/null
+++ b/recipes/apache2/apache2-2.2.3/configure-fix-cross-compile-ptr-check.patch
@@ -0,0 +1,17 @@
+--- ./orig-configure 2007-02-20 11:05:12.000000000 +0200
++++ ./configure 2007-02-20 11:14:11.000000000 +0200
+@@ -6667,7 +6667,13 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ if test "$cross_compiling" = yes; then
+- ap_void_ptr_lt_long=yes
++
++ if test "$ac_cv_sizeof_long_p" = "$ac_cv_sizeof_void_p"; then
++ ap_void_ptr_lt_long=no
++ else
++ ap_void_ptr_lt_long=yes
++ fi
++
+ else
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
diff --git a/recipes/apache2/apache2-2.2.3/configure-patch b/recipes/apache2/apache2-2.2.3/configure-patch
new file mode 100644
index 0000000000..d173681fd5
--- /dev/null
+++ b/recipes/apache2/apache2-2.2.3/configure-patch
@@ -0,0 +1,52 @@
+--- httpd-2.2.3/configure-orig 2006-08-11 11:00:11.000000000 -0700
++++ httpd-2.2.3/configure 2006-08-11 10:59:44.000000000 -0700
+@@ -2643,24 +2643,6 @@
+
+ else
+
+- if test -n "1" && test "1" = "1"; then
+- for apr_temp_apr_config_file in $apr_temp_acceptable_apr_config
+- do
+- if $apr_temp_apr_config_file --help > /dev/null 2>&1 ; then
+- apr_found="yes"
+- apr_config="$apr_temp_apr_config_file"
+- break
+- else
+- for lookdir in /usr /usr/local /usr/local/apr /opt/apr /usr/local/apache2; do
+- if $TEST_X "$lookdir/bin/$apr_temp_apr_config_file"; then
+- apr_found="yes"
+- apr_config="$lookdir/bin/$apr_temp_apr_config_file"
+- break 2
+- fi
+- done
+- fi
+- done
+- fi
+ if test "$apr_found" = "no" && test -d ""$srcdir/srclib/apr""; then
+ apr_temp_abs_srcdir="`cd "$srcdir/srclib/apr" && pwd`"
+ apr_found="reconfig"
+@@ -2979,24 +2961,6 @@
+
+ else
+
+- if test -n "1" && test "1" = "1"; then
+- for apu_temp_apu_config_file in $apu_temp_acceptable_apu_config
+- do
+- if $apu_temp_apu_config_file --help > /dev/null 2>&1 ; then
+- apu_found="yes"
+- apu_config="$apu_temp_apu_config_file"
+- break
+- else
+- for lookdir in /usr /usr/local /usr/local/apr /opt/apr /usr/local/apache2 ; do
+- if $TEST_X "$lookdir/bin/$apu_temp_apu_config_file"; then
+- apu_found="yes"
+- apu_config="$lookdir/bin/$apu_temp_apu_config_file"
+- break 2
+- fi
+- done
+- fi
+- done
+- fi
+ if test "$apu_found" = "no" && test -d ""$srcdir/srclib/apr-util""; then
+ apu_temp_abs_srcdir="`cd "$srcdir/srclib/apr-util" && pwd`"
+ apu_found="reconfig"
diff --git a/recipes/apache2/apache2-2.2.3/dftables-makefile-patch b/recipes/apache2/apache2-2.2.3/dftables-makefile-patch
new file mode 100644
index 0000000000..ac966db282
--- /dev/null
+++ b/recipes/apache2/apache2-2.2.3/dftables-makefile-patch
@@ -0,0 +1,10 @@
+--- http-2.2.3/srclib/pcre/Makefile.in-orig
++++ http-2.2.3/srclib/pcre/Makefile.in 2005-12-20 13:12:03.000000000 -0500
+@@ -15,6 +15,6 @@
+ $(LINK) $(EXTRA_LDFLAGS) dftables.lo $(EXTRA_LIBS)
+
+ $(srcdir)/chartables.c: dftables
+- ./dftables $@
++ dftables $@
+
+ pcre.lo: $(srcdir)/chartables.c
diff --git a/recipes/apache2/apache2-2.2.3/server-makefile-patch b/recipes/apache2/apache2-2.2.3/server-makefile-patch
new file mode 100644
index 0000000000..f1349cb6a4
--- /dev/null
+++ b/recipes/apache2/apache2-2.2.3/server-makefile-patch
@@ -0,0 +1,11 @@
+--- http-2.0.54/server/Makefile.in-old 2005-12-20 13:26:56.000000000 -0500
++++ http-2.0.54/server/Makefile.in 2005-12-20 13:27:22.000000000 -0500
+@@ -27,7 +27,7 @@
+ $(LINK) $(EXTRA_LDFLAGS) $(gen_test_char_OBJECTS) $(EXTRA_LIBS)
+
+ test_char.h: gen_test_char
+- ./gen_test_char > test_char.h
++ gen_test_char > test_char.h
+
+ util.lo: test_char.h
+