aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/apr
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/apr')
-rw-r--r--recipes/apr/apr-util_1.2.12.bb7
-rw-r--r--recipes/apr/apr-util_1.3.4.bb4
2 files changed, 5 insertions, 6 deletions
diff --git a/recipes/apr/apr-util_1.2.12.bb b/recipes/apr/apr-util_1.2.12.bb
index 698a3f0ca7..18e4ad3b97 100644
--- a/recipes/apr/apr-util_1.2.12.bb
+++ b/recipes/apr/apr-util_1.2.12.bb
@@ -3,7 +3,7 @@ SECTION = "libs"
DEPENDS = "apr expat gdbm"
LICENSE = "Apache License, Version 2.0"
-PR = "r3"
+PR = "r4"
inherit autotools lib_package binconfig
@@ -19,12 +19,11 @@ EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS} --with-dbm=gdbm \
OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
-EXTRA_OEMAKE = " LIBTOOL=\"${S}/${TARGET_PREFIX}libtool\" "
-export LIBTOOL="${S}/${TARGET_PREFIX}libtool"
+LIBTOOL = "${HOST_SYS}-libtool"
+EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
do_configure_prepend() {
- cp ${STAGING_BINDIR_NATIVE}/${TARGET_PREFIX}libtool ${S}/
cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
echo "AC_PROG_LIBTOOL" >> ${S}/configure.in
libtoolize --force
diff --git a/recipes/apr/apr-util_1.3.4.bb b/recipes/apr/apr-util_1.3.4.bb
index c0ac30c5e1..cc6781b254 100644
--- a/recipes/apr/apr-util_1.3.4.bb
+++ b/recipes/apr/apr-util_1.3.4.bb
@@ -3,7 +3,7 @@ SECTION = "libs"
DEPENDS = "apr expat gdbm"
LICENSE = "Apache License, Version 2.0"
-PR = "r5"
+PR = "r6"
SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \
file://configfix.patch \
@@ -29,7 +29,7 @@ do_configure_prepend() {
do_configure_append() {
sed -i -e s:apr_builders=/usr/share/build-1:apr_builders=${STAGING_DATADIR}/build-1:g ${S}/build/rules.mk
sed -i /^LIBTOOL/d ${S}/build/rules.mk
- echo LIBTOOL="${STAGING_BINDIR_NATIVE}/${TARGET_PREFIX}libtool --tag=CC" >> ${S}/build/rules.mk
+ echo LIBTOOL="${TARGET_PREFIX}libtool --tag=CC" >> ${S}/build/rules.mk
}