aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/argtable/argtable_2.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/argtable/argtable_2.7.bb')
-rw-r--r--recipes/argtable/argtable_2.7.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/argtable/argtable_2.7.bb b/recipes/argtable/argtable_2.7.bb
new file mode 100644
index 0000000000..ee3e6bd70a
--- /dev/null
+++ b/recipes/argtable/argtable_2.7.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Argtable is an ANSI C library for parsing GNU style command line options."
+SECTION = "libs"
+LICENSE = "LGPL"
+HOMEPAGE = "http://argtable.sourceforge.net/"
+
+PR = "r1"
+
+DEPENDS = "libtool-cross"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/argtable/argtable2-7.tar.gz"
+
+S = ${WORKDIR}/argtable2-7
+
+inherit autotools
+
+do_stage () {
+ oe_libinstall -a -so libargtable2 ${STAGING_LIBDIR}
+ install -m 0644 src/argtable2.h ${STAGING_INCDIR}
+}
+
+