aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/atftp/atftp_0.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/atftp/atftp_0.7.bb')
-rw-r--r--recipes/atftp/atftp_0.7.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/atftp/atftp_0.7.bb b/recipes/atftp/atftp_0.7.bb
new file mode 100644
index 0000000000..9bcc18edde
--- /dev/null
+++ b/recipes/atftp/atftp_0.7.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Advanced TFTP server and client"
+SECTION = "network"
+PRIORITY = "optional"
+HOMEPAGE = "http://packages.debian.org/atftp"
+LICENSE = "GPL"
+PR = "r6"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/a/atftp/atftp_${PV}.orig.tar.gz \
+ ${DEBIAN_MIRROR}/main/a/atftp/atftp_${PV}.dfsg-6.diff.gz;patch=1 \
+ file://atftpd.init"
+S = "${WORKDIR}/atftp-${PV}"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "atftpd"
+INITSCRIPT_PARAMS = "defaults 80"
+
+EXTRA_OECONF = ""
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/atftpd.init ${D}${sysconfdir}/init.d/atftpd
+}