aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/aufs
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/aufs')
-rw-r--r--recipes/aufs/aufs_cvs.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/recipes/aufs/aufs_cvs.bb b/recipes/aufs/aufs_cvs.bb
index 815a24fda4..6a0e952379 100644
--- a/recipes/aufs/aufs_cvs.bb
+++ b/recipes/aufs/aufs_cvs.bb
@@ -2,7 +2,6 @@ DESCRIPTION = "Aufs is a stackable unification filesystem such as Unionfs, which
HOMEPAGE = "http://aufs.sourceforge.net/"
LICENSE = "GPL"
PV = "cvs${SRCDATE}"
-PR = "r3"
RSUGGESTS_${PN} = "${PN}-tools"
@@ -12,6 +11,8 @@ S = "${WORKDIR}/aufs"
SRC_URI = "cvs://anonymous@aufs.cvs.sourceforge.net/cvsroot/aufs;module=aufs;date=${SRCDATE}"
+TARGET_CC_ARCH += "${LDFLAGS}"
+
EXTRA_OEMAKE = "KDIR=${STAGING_KERNEL_DIR} -f local.mk"
# We need to check the architecture and the kernel version to
@@ -42,6 +43,10 @@ do_compile_prepend() {
cd ${S}
}
+do_compile(){
+ LDFLAGS=""
+ oe_runmake
+}
do_install() {
install -d ${D}/${sbindir}
@@ -52,7 +57,6 @@ do_install() {
install -m 0644 aufs.ko ${D}/${base_libdir}/modules/${KERNEL_VERSION}/drivers/extra/
}
-
FILES_${PN} = "/lib/modules"
PACKAGES += "${PN}-tools"
PACKAGE_ARCH = "${MACHINE_ARCH}"