aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/autofs/autofs_4.1.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/autofs/autofs_4.1.4.bb')
-rw-r--r--recipes/autofs/autofs_4.1.4.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/autofs/autofs_4.1.4.bb b/recipes/autofs/autofs_4.1.4.bb
new file mode 100644
index 0000000000..d9863ad9dd
--- /dev/null
+++ b/recipes/autofs/autofs_4.1.4.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "Kernel based automounter for linux."
+SECTION = "base"
+LICENSE = "GPL"
+
+PR = "r2"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-${PV}.tar.bz2 \
+ ${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-4.1.4-misc-fixes.patch;patch=1 \
+ ${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-4.1.4-multi-parse-fix.patch;patch=1 \
+ ${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-4.1.4-non-replicated-ping.patch;patch=1 \
+ file://cross.patch;patch=1 \
+ file://Makefile.rules-cross.patch;patch=1 \
+ file://install.patch;patch=1 \
+ file://auto.net-sort-option-fix.patch;patch=1 \
+ file://autofs-additional-distros.patch;patch=1 \
+ file://no-bash.patch;patch=1"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "autofs"
+INITSCRIPT_PARAMS = "defaults"
+
+EXTRA_OEMAKE="TARGET_PREFIX=${TARGET_PREFIX}"
+PARALLEL_MAKE = ""
+
+do_configure_prepend () {
+ if [ ! -e acinclude.m4 ]; then
+ cp aclocal.m4 acinclude.m4
+ fi
+}
+
+do_install () {
+ oe_runmake 'INSTALLROOT=${D}' install
+}