aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/automake/automake_1.10.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/automake/automake_1.10.2.bb')
-rw-r--r--recipes/automake/automake_1.10.2.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/automake/automake_1.10.2.bb b/recipes/automake/automake_1.10.2.bb
new file mode 100644
index 0000000000..a17fe7aabb
--- /dev/null
+++ b/recipes/automake/automake_1.10.2.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "A tool for automatically generating Makefiles."
+LICENSE = "GPL"
+HOMEPAGE = "http://www.gnu.org/software/automake/"
+SECTION = "devel"
+PR = "r0"
+
+SRC_URI = "\
+ ${GNU_MIRROR}/automake/automake-${PV}.tar.bz2 \
+ ${@['file://path_prog_fixes.patch;patch=1', ''][bb.data.inherits_class('native', d)]} \
+"
+S = "${WORKDIR}/automake-${PV}"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/automake-${PV}"
+
+inherit autotools
+
+export AUTOMAKE = "${@bb.which('automake', bb.data.getVar('PATH', d, 1))}"
+FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
+
+require automake.inc
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+ install -d ${D}${datadir}
+ if [ ! -e ${D}${datadir}/aclocal ]; then
+ ln -sf aclocal-1.10 ${D}${datadir}/aclocal
+ fi
+ if [ ! -e ${D}${datadir}/automake ]; then
+ ln -sf automake-1.10 ${D}${datadir}/automake
+ fi
+}