summaryrefslogtreecommitdiffstats
path: root/recipes/avahi/avahi-python_0.6.21.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/avahi/avahi-python_0.6.21.bb')
-rw-r--r--recipes/avahi/avahi-python_0.6.21.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/avahi/avahi-python_0.6.21.bb b/recipes/avahi/avahi-python_0.6.21.bb
new file mode 100644
index 0000000000..639f1de34e
--- /dev/null
+++ b/recipes/avahi/avahi-python_0.6.21.bb
@@ -0,0 +1,19 @@
+require avahi.inc
+
+PR = "r8"
+
+# FIXME: without --enable-gtk, avahi-discover (pygtk) won't be built
+FILES_avahi-discover = ""
+
+PROVIDES = "avahi"
+DEPENDS += "python-native"
+
+SRC_URI += "file://dbus-pre-1.1.1-support.patch;patch=1 \
+ file://configure-check-pymod.patch;patch=1"
+S = "${WORKDIR}/avahi-${PV}"
+
+RDEPENDS_avahi-discover = "python-avahi python-pygtk"
+RDEPENDS_python-avahi = "python-dbus"
+PACKAGES =+ "python-avahi"
+
+AVAHI_PYTHON = "--enable-python"