summaryrefslogtreecommitdiffstats
path: root/recipes/batmand/batmand_0.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/batmand/batmand_0.3.bb')
-rw-r--r--recipes/batmand/batmand_0.3.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/batmand/batmand_0.3.bb b/recipes/batmand/batmand_0.3.bb
new file mode 100644
index 0000000000..c78f94d5e3
--- /dev/null
+++ b/recipes/batmand/batmand_0.3.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Routing protocol daemon for multi-hop ad-hoc mesh networks."
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "https://www.open-mesh.net/batman"
+
+PR = "r0"
+
+RDEPENDS = "kernel-module-tun"
+
+SRC_URI = "\
+ http://downloads.open-mesh.net/batman/stable/sources/batman-0.3.tar.gz \
+ file://makefile-fix.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/batman-${PV}"
+
+do_compile() {
+ oe_runmake
+}
+
+do_stage() {
+ :
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 batmand ${D}${bindir}
+}