aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bcel/bcel_5.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/bcel/bcel_5.2.bb')
-rw-r--r--recipes/bcel/bcel_5.2.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/bcel/bcel_5.2.bb b/recipes/bcel/bcel_5.2.bb
new file mode 100644
index 0000000000..faf6043c00
--- /dev/null
+++ b/recipes/bcel/bcel_5.2.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Java Bytecode manipulation library"
+LICENSE = "AL2.0"
+AUTHOR = "Apache Software Foundation"
+
+SRC_URI = "http://archive.apache.org/dist/jakarta/bcel/source/${BP}-src.tar.gz"
+
+inherit java-library
+
+DEPENDS = "fastjar-native xerces-j regexp"
+
+do_compile() {
+ mkdir -p build
+
+ oe_makeclasspath cp -s xercesImpl regexp
+
+ javac -sourcepath src/java -d build -cp $cp `find src/java -name \*.java`
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}