aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/binutils
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/binutils')
-rw-r--r--recipes/binutils/binutils.inc8
-rw-r--r--recipes/binutils/binutils_2.14.90.0.6.bb9
-rw-r--r--recipes/binutils/binutils_2.14.90.0.7.bb9
-rw-r--r--recipes/binutils/binutils_2.15.94.0.1.bb9
-rw-r--r--recipes/binutils/binutils_2.16.91.0.6.bb9
-rw-r--r--recipes/binutils/binutils_2.16.91.0.7.bb9
-rw-r--r--recipes/binutils/binutils_2.17.50.0.1.bb9
-rw-r--r--recipes/binutils/binutils_csl-arm-20050416.bb9
-rw-r--r--recipes/binutils/binutils_csl-arm-20050603.bb9
9 files changed, 19 insertions, 61 deletions
diff --git a/recipes/binutils/binutils.inc b/recipes/binutils/binutils.inc
index ab9e457fb7..633cce5898 100644
--- a/recipes/binutils/binutils.inc
+++ b/recipes/binutils/binutils.inc
@@ -7,7 +7,7 @@ INC_PR = "r13"
COMPATIBLE_TARGET_SYS ?= "(?!nios2)"
-inherit autotools gettext
+inherit autotools_base gettext
PACKAGES += "${PN}-symlinks"
@@ -68,13 +68,11 @@ export CPP_FOR_BUILD = "${BUILD_CPP}"
export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
do_configure () {
- (cd ${S}; gnu-configize) || die "Failed to run gnu-configize"
-
# Fix for issues when system's texinfo version >= 4.10
# (See https://bugzilla.redhat.com/show_bug.cgi?id=345621)
sed -i -e "s@egrep 'texinfo.*'@egrep 'texinfo[^0-9]*([1-3][0-9]|4\.[4-9]|4.[1-9][0-9]+|[5-9])'@" '${S}/configure'
- oe_runconf
+ autotools_base_do_configure
#
# must prime config.cache to ensure the build of libiberty
#
@@ -85,7 +83,7 @@ do_configure () {
}
do_install () {
- autotools_do_install
+ autotools_base_do_install
# We don't really need these, so we'll remove them...
rm -rf ${D}${libdir}/ldscripts
diff --git a/recipes/binutils/binutils_2.14.90.0.6.bb b/recipes/binutils/binutils_2.14.90.0.6.bb
index ce095933d8..f32b321b9d 100644
--- a/recipes/binutils/binutils_2.14.90.0.6.bb
+++ b/recipes/binutils/binutils_2.14.90.0.6.bb
@@ -1,6 +1,6 @@
SECTION = "devel"
LICENSE = "GPL"
-inherit autotools gettext
+inherit autotools_base gettext
INC_PR = "r5"
PR = "${INC_PR}.1"
@@ -82,13 +82,8 @@ export CC_FOR_BUILD = "${BUILD_CC}"
export CC = "${CCACHE} ${HOST_PREFIX}gcc"
-do_configure () {
- (cd ${S}; gnu-configize) || die "Failed to run gnu-configize"
- oe_runconf
-}
-
do_install () {
- autotools_do_install
+ autotools_base_do_install
# We don't really need these, so we'll remove them...
rm -rf ${D}${libdir}/ldscripts
diff --git a/recipes/binutils/binutils_2.14.90.0.7.bb b/recipes/binutils/binutils_2.14.90.0.7.bb
index fb056b077f..d3219e06cb 100644
--- a/recipes/binutils/binutils_2.14.90.0.7.bb
+++ b/recipes/binutils/binutils_2.14.90.0.7.bb
@@ -1,6 +1,6 @@
SECTION = "devel"
LICENSE = "GPL"
-inherit autotools gettext
+inherit autotools_base gettext
DESCRIPTION = "A GNU collection of binary utilities"
HOMEPAGE = "http://www.gnu.org/software/binutils/"
@@ -83,13 +83,8 @@ export CC_FOR_BUILD = "${BUILD_CC}"
export CC = "${CCACHE} ${HOST_PREFIX}gcc"
-do_configure () {
- (cd ${S}; gnu-configize) || die "Failed to run gnu-configize"
- oe_runconf
-}
-
do_install () {
- autotools_do_install
+ autotools_base_do_install
# We don't really need these, so we'll remove them...
rm -rf ${D}${libdir}/ldscripts
diff --git a/recipes/binutils/binutils_2.15.94.0.1.bb b/recipes/binutils/binutils_2.15.94.0.1.bb
index 50ae28862e..92ef2ebdbe 100644
--- a/recipes/binutils/binutils_2.15.94.0.1.bb
+++ b/recipes/binutils/binutils_2.15.94.0.1.bb
@@ -5,7 +5,7 @@ LICENSE = "GPL"
INC_PR = "r5"
PR = "${INC_PR}.1"
-inherit autotools gettext
+inherit autotools_base gettext
PACKAGES = "${PN} ${PN}-dev ${PN}-doc ${PN}-symlinks"
@@ -79,13 +79,8 @@ export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
export CC = "${CCACHE} ${HOST_PREFIX}gcc ${HOST_CC_ARCH}"
-do_configure () {
- (cd ${S}; gnu-configize) || die "Failed to run gnu-configize"
- oe_runconf
-}
-
do_install () {
- autotools_do_install
+ autotools_base_do_install
# We don't really need these, so we'll remove them...
rm -rf ${D}${libdir}/ldscripts
diff --git a/recipes/binutils/binutils_2.16.91.0.6.bb b/recipes/binutils/binutils_2.16.91.0.6.bb
index 5fc05a0bab..41170fd30a 100644
--- a/recipes/binutils/binutils_2.16.91.0.6.bb
+++ b/recipes/binutils/binutils_2.16.91.0.6.bb
@@ -10,7 +10,7 @@ PR = "${INC_PR}.1"
DEFAULT_PREFERENCE = "-1"
-inherit autotools gettext
+inherit autotools_base gettext
PACKAGES = "${PN} ${PN}-dev ${PN}-doc ${PN}-symlinks"
@@ -84,13 +84,8 @@ export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
export CC = "${CCACHE} ${HOST_PREFIX}gcc ${HOST_CC_ARCH}"
-do_configure () {
- (cd ${S}; gnu-configize) || die "Failed to run gnu-configize"
- oe_runconf
-}
-
do_install () {
- autotools_do_install
+ autotools_base_do_install
# We don't really need these, so we'll remove them...
rm -rf ${D}${libdir}/ldscripts
diff --git a/recipes/binutils/binutils_2.16.91.0.7.bb b/recipes/binutils/binutils_2.16.91.0.7.bb
index 21e7fb2051..eefcd3be4e 100644
--- a/recipes/binutils/binutils_2.16.91.0.7.bb
+++ b/recipes/binutils/binutils_2.16.91.0.7.bb
@@ -6,7 +6,7 @@ DEFAULT_PREFERENCE = "-1"
INC_PR = "r5"
PR = "${INC_PR}.1"
-inherit autotools gettext
+inherit autotools_base gettext
PACKAGES = "${PN} ${PN}-dev ${PN}-doc ${PN}-symlinks"
@@ -80,13 +80,8 @@ export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
export CC = "${CCACHE} ${HOST_PREFIX}gcc ${HOST_CC_ARCH}"
-do_configure () {
- (cd ${S}; gnu-configize) || die "Failed to run gnu-configize"
- oe_runconf
-}
-
do_install () {
- autotools_do_install
+ autotools_base_do_install
# We don't really need these, so we'll remove them...
rm -rf ${D}${libdir}/ldscripts
diff --git a/recipes/binutils/binutils_2.17.50.0.1.bb b/recipes/binutils/binutils_2.17.50.0.1.bb
index 9a42484373..c750399f7b 100644
--- a/recipes/binutils/binutils_2.17.50.0.1.bb
+++ b/recipes/binutils/binutils_2.17.50.0.1.bb
@@ -5,7 +5,7 @@ LICENSE = "GPL"
DEFAULT_PREFERENCE = "-1"
PR = "r2"
-inherit autotools gettext
+inherit autotools_base gettext
PACKAGES = "${PN} ${PN}-dev ${PN}-doc ${PN}-symlinks"
@@ -79,13 +79,8 @@ export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
export CC = "${CCACHE} ${HOST_PREFIX}gcc ${HOST_CC_ARCH}"
-do_configure () {
- (cd ${S}; gnu-configize) || die "Failed to run gnu-configize"
- oe_runconf
-}
-
do_install () {
- autotools_do_install
+ autotools_base_do_install
# We don't really need these, so we'll remove them...
rm -rf ${D}${libdir}/ldscripts
diff --git a/recipes/binutils/binutils_csl-arm-20050416.bb b/recipes/binutils/binutils_csl-arm-20050416.bb
index 71803d1501..d9e2297cfc 100644
--- a/recipes/binutils/binutils_csl-arm-20050416.bb
+++ b/recipes/binutils/binutils_csl-arm-20050416.bb
@@ -1,5 +1,5 @@
SECTION = "devel"
-inherit autotools gettext
+inherit autotools_base gettext
DESCRIPTION = "A GNU collection of binary utilities"
HOMEPAGE = "http://www.gnu.org/software/binutils/"
@@ -78,13 +78,8 @@ export CC_FOR_BUILD = "${BUILD_CC}"
export CC = "${CCACHE} ${HOST_PREFIX}gcc"
-do_configure () {
- (cd ${S}; gnu-configize) || die "Failed to run gnu-configize"
- oe_runconf
-}
-
do_install () {
- autotools_do_install
+ autotools_base_do_install
# We don't really need these, so we'll remove them...
rm -rf ${D}${libdir}/ldscripts
diff --git a/recipes/binutils/binutils_csl-arm-20050603.bb b/recipes/binutils/binutils_csl-arm-20050603.bb
index 50e8677a43..abacd75a29 100644
--- a/recipes/binutils/binutils_csl-arm-20050603.bb
+++ b/recipes/binutils/binutils_csl-arm-20050603.bb
@@ -1,5 +1,5 @@
SECTION = "devel"
-inherit autotools gettext
+inherit autotools_base gettext
DESCRIPTION = "A GNU collection of binary utilities"
HOMEPAGE = "http://www.gnu.org/software/binutils/"
@@ -78,13 +78,8 @@ export CC_FOR_BUILD = "${BUILD_CC}"
export CC = "${CCACHE} ${HOST_PREFIX}gcc"
-do_configure () {
- (cd ${S}; gnu-configize) || die "Failed to run gnu-configize"
- oe_runconf
-}
-
do_install () {
- autotools_do_install
+ autotools_base_do_install
# We don't really need these, so we'll remove them...
rm -rf ${D}${libdir}/ldscripts