aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bootmenu/bootmenu_0.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/bootmenu/bootmenu_0.6.bb')
-rw-r--r--recipes/bootmenu/bootmenu_0.6.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/bootmenu/bootmenu_0.6.bb b/recipes/bootmenu/bootmenu_0.6.bb
new file mode 100644
index 0000000000..c94efcaf90
--- /dev/null
+++ b/recipes/bootmenu/bootmenu_0.6.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Pluginable bootup menu."
+SECTION = "base"
+LICENSE = "GPL"
+
+SRC_URI = "http://www.cosmicpenguin.net/pub/bootmenu/bootmenu-${PV}.tar.gz \
+ file://compile.patch;patch=1"
+
+EXTRA_OEMAKE = ""
+
+do_compile () {
+ oe_runmake -C src 'CC=${CC}' 'CFLAGS=${CFLAGS}' 'LDFLAGS=${LDFLAGS}'
+}
+
+do_install () {
+ oe_runmake -C src 'PLUGINDIR=${datadir}/bootmenu' 'PREFIX=${bindir}' 'DESTDIR=${D}' install
+}