aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/boxee/tre_0.7.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/boxee/tre_0.7.5.bb')
-rw-r--r--recipes/boxee/tre_0.7.5.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/boxee/tre_0.7.5.bb b/recipes/boxee/tre_0.7.5.bb
new file mode 100644
index 0000000000..71f09e0b6f
--- /dev/null
+++ b/recipes/boxee/tre_0.7.5.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "TRE is a lightweight, robust, and efficient POSIX compliant regexp matching library "
+LICENSE = "LGPL"
+
+SRC_URI = "http://laurikari.net/tre/tre-${PV}.tar.bz2"
+
+inherit autotools
+
+do_compile_append() {
+ sed -i -e s:${STAGING_DIR_TARGET}::g \
+ -e s:/${TARGET_SYS}::g \
+ tre.pc
+}
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+do_stage() {
+ autotools_stage_all
+}
+