aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/brutefir/brutefir_1.0i.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/brutefir/brutefir_1.0i.bb')
-rw-r--r--recipes/brutefir/brutefir_1.0i.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/brutefir/brutefir_1.0i.bb b/recipes/brutefir/brutefir_1.0i.bb
new file mode 100644
index 0000000000..52e56aca20
--- /dev/null
+++ b/recipes/brutefir/brutefir_1.0i.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "BruteFIR is a software convolution engine, a program for applying long FIR filters to multi-channel digital audio, either offline or in realtime."
+LICENSE = "GPLv2"
+
+DEPENDS = "alsa-lib fftw fftwf fftwl"
+
+PR = "r1"
+
+# The unbreak-makefile disables the SSE2, MMX and jack support, feel free
+# to add back SSE and MMX after fixing the makefile to not use uname to check for cpu
+
+SRC_URI = "http://www.ludd.luth.se/~torger/files/brutefir-${PV}.tar.gz \
+ file://unbreak-makefile.patch;patch=1 \
+ "
+
+do_configure() {
+ sed -i -e s:-L/usr/local/lib:-L${STAGING_LIBDIR}:g Makefile
+ sed -i -e s:-I/usr/local/include:-I${STAGING_INCDIR}:g Makefile
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 755 *.bf* ${D}${bindir}
+ install -m 755 brutefir ${D}${bindir}
+}
+