aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/btsco
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/btsco')
-rw-r--r--recipes/btsco/btsco-module-0.41/makefile.patch16
-rw-r--r--recipes/btsco/btsco-module-0.42/makefile.patch16
-rw-r--r--recipes/btsco/btsco-module.inc19
-rw-r--r--recipes/btsco/btsco-module_0.41.bb3
-rw-r--r--recipes/btsco/btsco-module_0.42.bb1
-rw-r--r--recipes/btsco/btsco.inc12
-rw-r--r--recipes/btsco/btsco_0.41.bb3
-rw-r--r--recipes/btsco/btsco_0.42.bb9
8 files changed, 79 insertions, 0 deletions
diff --git a/recipes/btsco/btsco-module-0.41/makefile.patch b/recipes/btsco/btsco-module-0.41/makefile.patch
new file mode 100644
index 0000000000..a7beb54761
--- /dev/null
+++ b/recipes/btsco/btsco-module-0.41/makefile.patch
@@ -0,0 +1,16 @@
+--- kernel/Makefile.orig 2006-01-13 00:32:58.000000000 +0100
++++ kernel/Makefile 2006-01-13 00:33:35.000000000 +0100
+@@ -10,10 +10,10 @@
+
+
+ default:
+- @make -C /lib/modules/`uname -r`/build M=`pwd` modules
++ $(MAKE) -C $(KERNEL_SRC) M=`pwd` modules
+
+ install:
+- @make -C /lib/modules/`uname -r`/build M=`pwd` modules_install
++ $(MAKE) -C $(KERNEL_SRC) M=`pwd` modules_install
+
+ clean:
+- @make -C /lib/modules/`uname -r`/build M=`pwd` clean
++ $(MAKE) -C $(KERNEL_SRC) M=`pwd` clean
diff --git a/recipes/btsco/btsco-module-0.42/makefile.patch b/recipes/btsco/btsco-module-0.42/makefile.patch
new file mode 100644
index 0000000000..a7beb54761
--- /dev/null
+++ b/recipes/btsco/btsco-module-0.42/makefile.patch
@@ -0,0 +1,16 @@
+--- kernel/Makefile.orig 2006-01-13 00:32:58.000000000 +0100
++++ kernel/Makefile 2006-01-13 00:33:35.000000000 +0100
+@@ -10,10 +10,10 @@
+
+
+ default:
+- @make -C /lib/modules/`uname -r`/build M=`pwd` modules
++ $(MAKE) -C $(KERNEL_SRC) M=`pwd` modules
+
+ install:
+- @make -C /lib/modules/`uname -r`/build M=`pwd` modules_install
++ $(MAKE) -C $(KERNEL_SRC) M=`pwd` modules_install
+
+ clean:
+- @make -C /lib/modules/`uname -r`/build M=`pwd` clean
++ $(MAKE) -C $(KERNEL_SRC) M=`pwd` clean
diff --git a/recipes/btsco/btsco-module.inc b/recipes/btsco/btsco-module.inc
new file mode 100644
index 0000000000..5c38fb1719
--- /dev/null
+++ b/recipes/btsco/btsco-module.inc
@@ -0,0 +1,19 @@
+DESCRIPTION = "Bluetooth-alsa headset module"
+SECTION = "kernel/modules"
+HOMEPAGE = "http://bluetooth-alsa.sourceforge.net/"
+LICENSE = "GPL"
+DEPENDS = "alsa-lib bluez-libs"
+
+inherit module
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/bluetooth-alsa/btsco-${PV}.tar.gz \
+ file://makefile.patch;patch=1"
+
+S = "${WORKDIR}/btsco-${PV}/kernel"
+
+MAKE_TARGETS = "KERNEL_PATH=${STAGING_KERNEL_DIR} MAKE='make -e'"
+
+do_install() {
+ install -m 0755 -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra
+ install -m 0644 ${S}/snd-bt-sco${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra/
+}
diff --git a/recipes/btsco/btsco-module_0.41.bb b/recipes/btsco/btsco-module_0.41.bb
new file mode 100644
index 0000000000..46f647998b
--- /dev/null
+++ b/recipes/btsco/btsco-module_0.41.bb
@@ -0,0 +1,3 @@
+require btsco-module.inc
+
+PR = "r1"
diff --git a/recipes/btsco/btsco-module_0.42.bb b/recipes/btsco/btsco-module_0.42.bb
new file mode 100644
index 0000000000..85b7790342
--- /dev/null
+++ b/recipes/btsco/btsco-module_0.42.bb
@@ -0,0 +1 @@
+require btsco-module.inc
diff --git a/recipes/btsco/btsco.inc b/recipes/btsco/btsco.inc
new file mode 100644
index 0000000000..32009b9a26
--- /dev/null
+++ b/recipes/btsco/btsco.inc
@@ -0,0 +1,12 @@
+DESCRIPTION = "Bluetooth-alsa headset tool"
+HOMEPAGE = "http://bluetooth-alsa.sourceforge.net/"
+LICENSE = "GPL"
+DEPENDS = "alsa-lib bluez-libs"
+
+inherit autotools pkgconfig
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/bluetooth-alsa/btsco-${PV}.tar.gz"
+
+S = "${WORKDIR}/${PN}-${PV}"
+
+CFLAGS += " -I${STAGING_INCDIR} "
diff --git a/recipes/btsco/btsco_0.41.bb b/recipes/btsco/btsco_0.41.bb
new file mode 100644
index 0000000000..46c388a83f
--- /dev/null
+++ b/recipes/btsco/btsco_0.41.bb
@@ -0,0 +1,3 @@
+require btsco.inc
+
+PR = "r2"
diff --git a/recipes/btsco/btsco_0.42.bb b/recipes/btsco/btsco_0.42.bb
new file mode 100644
index 0000000000..3fa6b0636b
--- /dev/null
+++ b/recipes/btsco/btsco_0.42.bb
@@ -0,0 +1,9 @@
+require btsco.inc
+
+#there are some bogus macros putting -I/usr/include into C(PP)FLAGS, lets fix that
+do_configure() {
+ libtoolize --force
+ gnu-configize
+ sed -i 's:-I${bluez_prefix}/include::g' configure
+ oe_runconf
+}