aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/busybox/busybox_1.16.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/busybox/busybox_1.16.2.bb')
-rw-r--r--recipes/busybox/busybox_1.16.2.bb13
1 files changed, 12 insertions, 1 deletions
diff --git a/recipes/busybox/busybox_1.16.2.bb b/recipes/busybox/busybox_1.16.2.bb
index 25f69f3dd0..2502c52512 100644
--- a/recipes/busybox/busybox_1.16.2.bb
+++ b/recipes/busybox/busybox_1.16.2.bb
@@ -1,5 +1,5 @@
require busybox.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
DEFAULT_PREFERENCE = "-1"
@@ -46,4 +46,15 @@ do_install_append() {
install -d ${D}${sysconfdir}/mdev
install -m 0755 ${WORKDIR}/find-touchscreen.sh ${D}${sysconfdir}/mdev/
install -m 0755 ${WORKDIR}/mdev ${D}${sysconfdir}/init.d/
+
+ if grep "CONFIG_UDHCPD=y" ${WORKDIR}/defconfig; then
+ install -m 0755 ${WORKDIR}/busybox-udhcpd ${D}${sysconfdir}/init.d/
+ fi
+
+ if grep "CONFIG_UDHCPC=y" ${WORKDIR}/defconfig; then
+ install -d ${D}${sysconfdir}/udhcpc.d
+ install -d ${D}${datadir}/udhcpc
+ install -m 0755 ${WORKDIR}/simple.script ${D}${sysconfdir}/udhcpc.d/50default
+ install -m 0755 ${WORKDIR}/default.script ${D}${datadir}/udhcpc/default.script
+ fi
}