summaryrefslogtreecommitdiffstats
path: root/recipes/cairo/cairo_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/cairo/cairo_git.bb')
-rw-r--r--recipes/cairo/cairo_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/cairo/cairo_git.bb b/recipes/cairo/cairo_git.bb
new file mode 100644
index 0000000000..44212103a6
--- /dev/null
+++ b/recipes/cairo/cairo_git.bb
@@ -0,0 +1,24 @@
+#This is a development snapshot, so lets hint OE to use the releases
+DEFAULT_PREFERENCE = "-1"
+
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "pixman virtual/libx11 libsm libpng fontconfig libxrender"
+DESCRIPTION = "Cairo graphics library"
+LICENSE = "MPL LGPL"
+
+PV = "1.5.3+git${SRCDATE}"
+
+SRC_URI = "git://git.cairographics.org/git/cairo;protocol=git \
+ "
+inherit autotools pkgconfig
+
+S = "${WORKDIR}/git"
+
+do_compile_append() {
+ cd ${S}/perf ; oe_runmake
+}
+
+do_stage () {
+ autotools_stage_all
+}