aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ccdv/ccdv.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ccdv/ccdv.bb')
-rw-r--r--recipes/ccdv/ccdv.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes/ccdv/ccdv.bb b/recipes/ccdv/ccdv.bb
new file mode 100644
index 0000000000..0a3753add5
--- /dev/null
+++ b/recipes/ccdv/ccdv.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "ccdv is a tool to reduce the deluge of make output to make \
+finding actual problems easier."
+LICENSE = "GPL"
+SRC_URI = "http://openembedded.org/dl/ccdv.c"
+S = "${WORKDIR}"
+
+do_compile () {
+ ${CC} ${CFLAGS} ${LDFLAGS} ccdv.c -o ccdv
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 ccdv ${D}${bindir}/
+}