summaryrefslogtreecommitdiffstats
path: root/recipes/ccxstream/ccxstream_1.0.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ccxstream/ccxstream_1.0.15.bb')
-rw-r--r--recipes/ccxstream/ccxstream_1.0.15.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/ccxstream/ccxstream_1.0.15.bb b/recipes/ccxstream/ccxstream_1.0.15.bb
new file mode 100644
index 0000000000..466a116ec2
--- /dev/null
+++ b/recipes/ccxstream/ccxstream_1.0.15.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "XStream Server"
+DEPENDS = "readline"
+LICENSE = "GPLv2"
+PR = "r2"
+
+SRC_URI = "http://surfnet.dl.sourceforge.net/sourceforge/xbplayer/${P}.tar.gz \
+ file://ccxstream-termcap.patch;patch=1 \
+ file://ccxstream.init \
+ file://ccxstream.conf"
+
+inherit autotools
+
+do_install() {
+ # add startup and sample config
+ install -d ${D}${sysconfdir}/init.d
+ install -d ${D}${sbindir}
+ install -m 0755 ${WORKDIR}/ccxstream.init ${D}${sysconfdir}/init.d/ccxstream
+ install -m 0644 ${WORKDIR}/ccxstream.conf ${D}${sysconfdir}/ccxstream.conf
+ install -m 0755 ccxstream ${D}${sbindir}/ccxstream || exit 1
+}