aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cdrkit
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/cdrkit')
-rw-r--r--recipes/cdrkit/cdrkit_1.1.9.bb19
-rw-r--r--recipes/cdrkit/files/xconfig.patch15
2 files changed, 34 insertions, 0 deletions
diff --git a/recipes/cdrkit/cdrkit_1.1.9.bb b/recipes/cdrkit/cdrkit_1.1.9.bb
new file mode 100644
index 0000000000..d6700e9df8
--- /dev/null
+++ b/recipes/cdrkit/cdrkit_1.1.9.bb
@@ -0,0 +1,19 @@
+# cdrkit build file
+
+LICENSE="GPLv2"
+DESCRIPTION="A set of tools for CD recording"
+HOMEPAGE="http://www.cdrkit.org"
+
+PARALLEL_MAKE = ""
+DEPENDS = "libcap"
+SRC_URI="http://cdrkit.org/releases/cdrkit-${PV}.tar.gz \
+ file://xconfig.patch;patch=1"
+
+S="${WORKDIR}/cdrkit-${PV}"
+PR = "r2"
+
+inherit cmake
+
+do_install() {
+ oe_runmake install DESTDIR="${D}"
+}
diff --git a/recipes/cdrkit/files/xconfig.patch b/recipes/cdrkit/files/xconfig.patch
new file mode 100644
index 0000000000..5af1a373b9
--- /dev/null
+++ b/recipes/cdrkit/files/xconfig.patch
@@ -0,0 +1,15 @@
+--- cdrkit-1.1.9/include/xconfig.h.in.orig 2006-12-02 12:10:05.000000000 +0100
++++ cdrkit-1.1.9/include/xconfig.h.in 2009-03-08 13:29:05.000000000 +0100
+@@ -233,7 +233,11 @@
+ /* If using network byte order */
+ #cmakedefine WORDS_BIGENDIAN
+ /* If high bits come first in structures */
+-#cmakedefine BITFIELDS_HTOL
++#ifdef WORDS_BIGENDIAN
++#define BITFIELDS_HTOL
++#else
++#define BITFIELDS_LTOH
++#endif
+ #define HAVE_C_BIGENDIAN /* Flag that WORDS_BIGENDIAN test was done */
+ #define HAVE_C_BITFIELDS /* Flag that BITFIELDS_HTOL test was done */
+