summaryrefslogtreecommitdiffstats
path: root/recipes/check/check_0.9.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/check/check_0.9.2.bb')
-rw-r--r--recipes/check/check_0.9.2.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/check/check_0.9.2.bb b/recipes/check/check_0.9.2.bb
new file mode 100644
index 0000000000..101f963293
--- /dev/null
+++ b/recipes/check/check_0.9.2.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "a unit test framework for C"
+LICENSE = "LGPL"
+PRIORITY = "optional"
+SECTION = "devel"
+
+PR ="r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/check/check-${PV}.tar.gz"
+S = "${WORKDIR}/check-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF += "--enable-plain-docdir"
+
+do_stage() {
+
+ install -m 0644 ${S}/src/check.h ${STAGING_INCDIR}/check.h
+ oe_libinstall -a -C src libcheck ${STAGING_LIBDIR}
+}
+