summaryrefslogtreecommitdiffstats
path: root/recipes/chillispot/chillispot_1.0RC3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/chillispot/chillispot_1.0RC3.bb')
-rw-r--r--recipes/chillispot/chillispot_1.0RC3.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/chillispot/chillispot_1.0RC3.bb b/recipes/chillispot/chillispot_1.0RC3.bb
new file mode 100644
index 0000000000..b4338a0ba0
--- /dev/null
+++ b/recipes/chillispot/chillispot_1.0RC3.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "ChilliSpot is an open source captive portal or wireless LAN access point controller. It is used for authenticating users of a wireless LAN."
+HOMEPAGE = "http://www.chillispot.org/"
+LICENSE = "GPL"
+SRC_URI = "http://www.chillispot.org/download/chillispot-${PV}.tar.gz \
+ file://no-ansi.patch;patch=1 \
+ file://init"
+RDEPENDS = "kernel-module-tun"
+
+inherit autotools
+
+do_install_append() {
+ install -d ${D}/${sysconfdir} ${D}/${sysconfdir}/init.d
+ install ${S}/doc/chilli.conf ${D}/${sysconfdir}
+ install -m 755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/chillispot
+}
+
+CONFFILES_${PN}_nylon = "${sysconfdir}/chilli.conf"