aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cnc/openredalert_r438.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/cnc/openredalert_r438.bb')
-rw-r--r--recipes/cnc/openredalert_r438.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/cnc/openredalert_r438.bb b/recipes/cnc/openredalert_r438.bb
new file mode 100644
index 0000000000..098f293b2e
--- /dev/null
+++ b/recipes/cnc/openredalert_r438.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Game engine to run Red Alert 1"
+LICENSE = "GPLv2"
+
+DEPENDS = "virtual/libsdl libsdl-mixer"
+
+SRC_URI = "http://openredalert.googlecode.com/files/openredalert-${PV}-src.tar.gz \
+ file://gcc43-fix.patch;patch=1 \
+ file://openredalert-launcher"
+
+PR = "r1"
+
+S = "${WORKDIR}"
+
+CFLAGS_append = " -I. -I${STAGING_INCDIR}"
+
+do_compile() {
+ cd ${S}/src ; cp ${S}/makefile .
+ oe_runmake -e
+}
+
+do_install() {
+ install -d ${D}/${datadir}/games/redalert/
+ cp -pPr ${S}/data ${D}/${datadir}/games/redalert/
+ install -m 0755 ${S}/src/openredalert ${D}/${datadir}/games/redalert/
+
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/openredalert-launcher ${D}/${bindir}
+}
+
+FILES_${PN} += "${datadir}/games/redalert/"
+FILES_${PN}-dbg += "${datadir}/games/redalert/.debug"